Just nu i M3-nätverket
Gå till innehåll
gusmagna

Hjälp, från Legacy mode till UEFI mode?

Rekommendera Poster

Hej,

Jag skulle behöva hjälp med att gå från legacy mode till uefi mode. Ganska enkelt tänker Ni som vet hur man gör och visst, det finns ett flertal guider om hur man gör detta, både med och utan förlust av data. Det finns till exempel AOMEI partitioneringsverktyg som kan göra detta, men det kostar en rejäl slant, sedan har vi terminalen och med den har jag redan omvandlat en ssd från mbr till gpt, MEN, i bios så är båda mina ssd, samt allt annat (optisk enhet mm) i legacy mode och jag vill få allt i UEFI mode. Jag kan börja med att berätta att datorn är en Dell Precision T3600, originalinstallerat med windows 7 pro. Jag köpte datorn begagnad för drygt två veckor sedan och säljaren slängde snabbt in windows 10 (tyvärr i legacy mode) innan jag köpte den. Datorn kom med bara en ssd, där windows 10 då var installerat och jag som gillar linux försökte först partitionera ssd:n, men då linux är i uefi mode så hittades inte bootable usb:n med linux på. Om jag i bios markerar UEFI, så är det helt tomt och jag kan inte heller lägga till en ny boot option. I och med att den ssd:n som följde med i köpet bara var på 256 GB, så tänkte jag att jag kunde köpa en ny ssd där jag kunde installera linux. Sagt och gjort, ssd:n inhandlades och monterades in, men till min besvikelse så ligger även den i Legacy mode i bios. Markerar jag UEFI, så är det som innan, dvs helt tomt och inga valmöjligheter. Jag testade då att via terminalen omvandla den nyinköpta ssd:n till gpt, och kollade bios igen. Fortfarande ingenting under UEFI-fliken. Vet ej om ni som läser detta har fått hela bilden och med dessa rader kan vägleda mig om bästa och enklaste vägen till att omvandla allt till uefi, så om det är något viktigt vänligen fråga. Skulle verkligen uppskatta om någon kunde hjälpa mig. Jag har testat att fabriksåterställa ssd:n med win10 på och ominstallera windows 10, i min förhoppning om att jag då kunde välja UEFI någon gång under installationsprocessen, men dessvärre inte. Jag vet att ett alternativ kanske skulle kunna vara att återgå till windows 7 för att sen när jag uppgraderar till windows 10, välja UEFI framför legacy. Som sagt, tips, råd och vägledning vore väldigt uppskattat.

Tack på förhand!

Mvh Gustaf

 

20181220_195130.jpg

20181220_195320.jpg

20181220_195406.jpg

20181220_195447.jpg

20181220_195938.jpg

20181220_200057.jpg

20181220_200107.jpg

20181220_200108.jpg

20181220_200240.jpg

20181220_200347.jpg

20181220_195109.jpg

20181220_195145.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej,

Ska tillägga att jag i Legacy mode skapat en återställnings-USB med windows 10 för jag tänkte att jag kanske då under installationen kunde få välja vilken av mina 2 diskar jag ville installera windows på och förhoppningsvis även välja Legacy mode eller UEFI mode. Datorn känner ej av usb-stickan när jag försöker boota från den, trots att jag enablat alla usb-portar, vilket kan ses i bilderna bifogat ovan i första inlägget. Har testat att installera om windows med detta bootable usb i både Legacy och i UEFI mode, men har inte fungerat i något av försöken. Det är väldigt märkligt tycker jag att det i alla fall inte går att installera om Windows i Legacy mode eftersom usb:t skapades i legacy mode och alla usb portar är aktiverade. Jag har såklart även i bios valt att boota från usb.

 

Any ideas?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har du alternativet Secure Boot i bios? Sätt den i så fall till Disable, spara och prova igen med F12. Var du hittar det alternativet i Dell bios vet jag inte. Kanske under Advanced meny om den finns. Fungerar det så sätt också Sata mode till AHCI innan du installerar Windows.

 

Ändrar man från Legacy till UEFI så fungerar inte det som redan är installerat. Samma med AHCI om du ändrar efter installation.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej vertpre,

Tack för svar!

Nej, secure boot stöds inte. Jag lyckades via terminalen omforma formatet till UEFI och har i UEFI i bios setup lagt till windows boot manager och EFI. Allt bootar upp som det skall i UEFI, men båda ssd-diskarna (kopplade till SATA0 & SATA1), Dvd och usb är alla kvar i legacy i bios och kan inte läggas till i uefi i bios. Det är ganska märkligt för att i disk management så är båda ssd i GPT. Det är med andra ord inte helt ok ännu för jag vill kunna boota från usb i uefi, vilket jag inte kan i nuläget då usb finns i legacy ... Vet faktiskt inte om jag har något annat alternativ än att nedgradera till windows 7 med en usb-sticka som är formaterad i mbr. Den borde kunna bootas i legacy mode tänker jag och är jag väl tillbaka i windows 7 så kan jag uppgradera till windows 10 och i processen välja formatet gpt i UEFI mode. Jag har själv inte uppgraderat datorn till windows 10 från 7 utan det gjordes av säljaren av datorn, som jag köpte för drygt två veckor sedan. Han tänkte aldrig på att ändra till uefi i uppgraderingsprocessen. Har du några tankar, råd och tips som kan vara bättre att testa tar jag varmt emot dem.

 

Mvh Gustaf

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Underligt, när jag tittar på Dells hemsida och manualen för din dator så står det att Secure Boot finns i BIOS.

 

Har du fått ordning på datorn?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ok, ja jag hade faktiskt också förväntat mig det och blev överraskad när jag såg att sec... boot inte stöds. Hursomhelst, så har jag fått ordning på datorn och gick tillbaka helt i legacy mode.

 

Mvh Gustaf

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...