Just nu i M3-nätverket
Gå till innehåll
PatTheCat79

Skapa automatisk ranking

Rekommendera Poster

PatTheCat79

Hej,
 
jag har ett problem i excel som jag får gråa hår över. Har bifogat en fil som åskådliggör detta. I cellerna A5:C11 finns datan som ska användas. I cellerna F5:H11 visas hur jag vill att resultatet ska se ut. Jag vill alltså att formeln ska plocka ut de projekt som har värdet "Ja" i kolumn A och sedan rangordna dessa utifrån den poäng de har i kolumn C. Hoppas någon förstår vad jag menar...

 

Skapa ranking.xlsx

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Oftast är de enkla lösningarna de självklaraste och de man missar.

 

Lägg till en kolumn till din tabell där du kopierar ut värdena för de rader som ska rangordnas. Applicera sedan RANG() på denna kolumn.

Kanske lägga till en liten liten decimal till värdena du kopierar ut så att du får unika RANG-värden.

 

Ja alltså

=OM(A2="ja";C2+rad()/10000);"")

och så RANG på detta

Därefter MINSTA på resultatet av RANG, en PASSA för att finna vilken rad MINSTA-värdet finns på och till sista INDEX för att hämta värdena du önskar.

 

 

Hänger du med?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
PatTheCat79

Oftast är de enkla lösningarna de självklaraste och de man missar.

 

Lägg till en kolumn till din tabell där du kopierar ut värdena för de rader som ska rangordnas. Applicera sedan RANG() på denna kolumn.

Kanske lägga till en liten liten decimal till värdena du kopierar ut så att du får unika RANG-värden.

 

Ja alltså

=OM(A2="ja";C2+rad()/10000);"")

och så RANG på detta

Därefter MINSTA på resultatet av RANG, en PASSA för att finna vilken rad MINSTA-värdet finns på och till sista INDEX för att hämta värdena du önskar.

 

 

Hänger du med?

Jag hänger med men hann faktiskt lösa det på annat sätt. Tack ändå!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...