Just nu i M3-nätverket
Gå till innehåll
Avicii

Radera tom mapp går ej

Rekommendera Poster

Avicii

Jag har en mapp på skrivbordet som jag inte kan ta bort. Högerklickar jag och väljer Ta bort, så händer inget. Högerklickar jag och väljer Byt namn, så händer inget. Mappen är tom och har inget namn.

Öppnar jag Utforskaren, så ser jag mappen, men den går inte att flytta.

Bakgrunden är att jag kopierade en mapp till skrivbordet för att testa ett kommando (Alt + 255), som skulle dölja mappnamnet. Tydlig fungerae detta alldeles för bra. Nu kan jag inte få tillbaka ett namn, för att sedan kunna radera.

Tacksam för tips/idé hur gå vidare.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
0x2A

Rättigheterna på mappen ?

 

 

-

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii

Jag har tagit ägarskap på mappen. Så jag står som ägare med fulla rättigheter.

Har loggat in med Administratörskontot, men då syns inte mappen någonstans.

Har också startat i felsäkert läge, men samma där att det går inte att radera, byta namn eller flytta.

I Systemåterställning finns inga återställningspunkter.

 

 

[inlägget ändrat 2007-03-27 18:33:48 av Maratonmannen]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Går det i någon motsvarighet till Kommandotolken?

Där kan man ju använda * i stället för att skriva in något mapp-namn.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
0x2A

Om du startar (på svensk) Alla program->Tillbehör->Kommandotolken i adminläge och CD'a dig till mappen och listar med DIR och sedan en RMDIR ?

Lite pyssel...

 

 

-

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii
Går det i någon motsvarighet till Kommandotolken?

Kommandotolken finns i Vista. Tror inte att den är annorlunda än XP:s. Vad skriver jag för kommando för att komma fram till skrivbordet?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii

Bifogar en bild på utgångsläget för Kommandotolken, som är Adminstratörsstartad.

Hur CD:ar jag mig fram?

Vista är på partition D.

 

[bild bifogad 2007-03-27 18:49:29 av Maratonmannen]

931880_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
0x2A

skriv DIR i kommandotolken å posta bild

 

[inlägget ändrat 2007-03-27 18:56:40 av 0x2A]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii

Inget konstigt med vad jag ser då.

789cad3c2eeb1f3911 är ett textdokument.

 

[bild bifogad 2007-03-27 18:57:56 av Maratonmannen]

931884_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
0x2A

Näe, du måste 'gå in' i mappen via CD-kommandot

tex

CD users

kör en ny DIR där

CD <din användare>

DIR

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii

Har kommit så här långt nu. Filmapp och TomMapp är aktuella mappar, men vad är <KAT> x3?

 

 

 

[inlägget ändrat 2007-03-27 19:30:41 av Maratonmannen]

[bild bifogad 2007-03-27 19:30:50 av Maratonmannen]

931896_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

KAT är förkortning för katalog dvs mapp.

. är en beteckning på aktuell katalog, i detta fall Desktop

.. är en beteckning på katalogen ovanför denna, dvs mappen som heter Ma...

Den understa däremot lär väl vara mappen som ska bort.

 

Man använder RMDIR (remove directory=mapp) för att ta bort mappar, men det känns lite farligt att göra:

RMDIR *

Jag vet inte om den då kommer att ta bort även Desktop-mappen. Går det att skapa en ny mapp på Skrivbordet och flytta mappen in i den?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii
Man använder RMDIR (remove directory=mapp) för att ta bort mappar, men det känns lite farligt att göra

Någongång måste man leva farligt. :)

RMDIR/RMDIR * blir bara felaktig kommandosyntax/syntax

 

Har flyttat mapparna >FilMapp och TomMapp från skrivbordet, så nu är det tre rader kvar.

Min gissning är att den tredje raden med datum 2007-03-26 ska bort. Det var vid den tidpunkten jag gjorde bort mig. Men hur radera då det inte finns något namn på mappen?

Jag skapade en ny mapp på skrivbordet och försökte flytta den jag vill ta bort, men det går inte att flytta. Den ligger kvar orörd vad jag än försöker med den.

 

[bild bifogad 2007-03-27 20:21:36 av Maratonmannen]

931914_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Erki

Du kan vad jag vet inte använda * i rmdir utan måste ange ett katalognamn. En möjlighet skulle kunna vara att ta bort överliggande katalog inklusive den namnlösa mappen under förutsättning att den i övrigt är helt tom. Det är möjligt att det inte går att ta bort Desktop mappen men som sista utväg.

 

OBS! Låt någon mer ha en åsikt så att vi inte förstör mer.

 

Om du med kommandotolken ställer dig i katalogen som ligger två nivåer över den namnlösa. Alltså den som har Desktop under sig.

 

Normalt måste en mapp vara tom för att kunna tas bort med rmdir. Om du lägger till växeln /s kan du även ta bort mappar med filer eller undermappar i sig.

Skriv RMDIR /S Desktop Skriv sedan MD Desktop för att återskapa mappen.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii
Skriv RMDIR /S Desktop Skriv sedan MD Desktop för att återskapa mappen.

Som du ser på bilden "Det går inte att hitta filen" med kommandot RMDIR /S Desktop.

Skriver jag MD Desktop så skapas en ny mapp med namnet Desktop. Den kan jag sedan ta bort med RMDIR /S Desktop.

 

 

[bild bifogad 2007-03-27 20:58:56 av Maratonmannen]

 

 

Ska upp tidigt i morgon bitti, så jag får sova på saken.

Tack för all respons så länge.

Kan lägga till att efter jag tagit bort namnvisningen på mappen i går, så efter att jag tagit ägarskap kunde jag radera filerna som fanns i mappen.

Det går också att lägga till filer i mappen nu fölr att sedan ta bort från mappen. Men tyvär inte mappen i sig.

 

[inlägget ändrat 2007-03-27 21:05:49 av Maratonmannen]

931938_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Erki

Ett riktigt långskott värt att prova. Jag ser att du har svensk version installerad. Vista har en knepig lösning på namn på systemmappar som har både svenka och engelska namn samtidigt. Kan det var så här fast omvänt. Du ser att katalogen heter Desktop men den kanske samtidigt heter Skrivbord(et). Testa med det.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii
Erki skrev:

 

Du ser att katalogen heter Desktop men den kanske samtidigt heter Skrivbord

Med Skrivbord eller Skrivbordet hittas ingen fil.

Med Desktop hittas tre rader. Men mappen som jag vill ta bort, syns inte att den nu innehåller en fil.

 

[bild bifogad 2007-03-27 21:16:19 av Maratonmannen]

931943_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Erki

du måste upp en nivå till så att du står i den katalogen som ligger i slutet på det du "tipexat" så att du kan ta bort (original)desktopmappen.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii

Menar du som på denna bild?

Det jag tipexat är mitt namn.

 

[bild bifogad 2007-03-27 21:28:55 av Maratonmannen]

931946_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii

Mappen är borta. Hur gick det till?

Måste ha varit Erkis sista tips eller det innan. Jag kollade aldrig på skrivbordet däremellan.

 

Tack för all respons!

 

Nu kan jag sova lugnt. :)

 

 

 

 

 

[inlägget ändrat 2007-03-27 21:42:14 av Maratonmannen]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Hoppas att du har sovit gott när du läser det här då ;)

 

Det var roligt att du fick till det till slut i alla fall och tack själv för poängen!:)

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
0x2A

Problemet är löst det vet jag men läste om lite tips i en tidning.

Om man håller shift nere och högerklickar på mappen i högra delen av utforskaren så får man en meny med några extra val och kan välja Öppna kommandofönster här

 

I kommandofönstret skriver man sedan

takeown /F mappnamnet /R /D J

icacls mappnamnet /grant administrators:F /T

 

detta återställer äganderättigheterna på mappen och nu skall det gå att radera.

 

-

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii
0x2A skrev:

 

...detta återställer äganderättigheterna på mappen och nu skall det gå att radera.

Måste genast testas, men denna gång gör jag det i Virtual PC.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Avicii
Om man håller shift nere och högerklickar på mappen i högra delen av utforskaren så får man en meny med några extra val och kan välja Öppna kommandofönster här

 

I kommandofönstret skriver man sedan

Får det inte att fungera. MSN är det ursprungliga mappnamnet, som nu är dolt med kommandot Alt + 255

 

J value is not allowed för /D options

 

 

 

[bild bifogad 2007-04-09 16:39:49 av Maratonmannen]

935318_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...