Just nu i M3-nätverket
Jump to content

åäö problem


sdgdg

Recommended Posts

Får inga träffar när jag söker poster som innehåller å, a och ö via mitt sökformulär som är kopplad till en Accessdatabas. När jag gör samma sökning med testfunktionen i datauppsättningen i Dreamweaver, fungerar det emellertid utmärkt. Kör serverfunktionen ASP.NET.

Varför??

 

Link to comment
Share on other sites

Antagligen ett teckenuppsättningsproblem, vilka ofta uppstår i Windowsmiljö tyvärr.

Här är en tråd som behandlar ämnet fastän med MySQL som databasapplikation istället för Access.

Kanske kan du få några tips.

//eforum.idg.se/viewmsg.asp?EntriesId=316347

 

Link to comment
Share on other sites

För mig händer det hela tiden.

Kanske inte så ofta i vanliga applikationer, men så fort man ska ut med något på Internet, eller sparar något i en databas...

 

Internet Explorer har också konstiga teckenuppsättningsproblem för sig (ibland får jag kinesisk teckenuppsättning på en sida, fastän det är tydligt angivet i <head> att iso-8859-1 ska användas).

 

I och med att man började använda NT (Windows 2000/XP), som är Unicode kompatibel, så försvann många problem, men ibland råkar man ut för dem i alla fall.

Därmed är det inte sagt att det är ett Windows-problem, utan snarare ett fel i de program där problemet uppstår, då dessa är dåligt programmerade.

Men i *nix-miljö har jag faktiskt aldrig har ett enda problem. Beror det på arkitekturen eller att *nix-programmerare är mer kompetenta? Jag vet inte, och har faktiskt inte så stort intresse i det helelr, bara det fungerar. ;)

 

Link to comment
Share on other sites

Snarare att *nix programmerare inte förstår Windows alls, enda gången jag sett detta problem är någon gång jag fått för mig att testa MySQL.

 

Men det är off topic, jag tror nog inte det är något utbrett problem, men även i Windows måste man veta vad man håller på med.

 

[inlägget ändrat 2003-02-28 09:21:18 av qwerty99]

Link to comment
Share on other sites

Hej Cariad!

 

Men om det vore liknande teckenuppsättningsproblem som i MySQL tråden du hänvisar till borde jag i alla fall få skräptecken istället för å, ä och ö när jag söker på ord innehållandes dessa tecken...och inte som nu ingenting alls? Trots att jag konverterat all data i accessdatabasen till unicode tecken och sedan importerat samma data i nvarchar kolumner i en MSSQL Server databas, får jag inga träffar ändå.

En sak som är förbryllande är emellertid att när jag loggat in på databasen från Dreamweaver MX visas inte kolumnerna i trädet som nvarchar-typ utan som wchar-typ. Har försökt läsa mig till skillnaden mellan de två typerna på internet men har inte hittat något matnyttigt ännu. Dreamweaver verkar inte stödja "nvarchar" eftersom jag inte kan välja detta i datauppsättningen "Parametrar" sedan. Har försökt hitta någon extention som fixar detta men inte hittat någon.

 

Hmm...detta är verklingen enerverande.

 

//reekee

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...