Just nu i M3-nätverket
Jump to content

CSS-problem i IE6


ns

Recommended Posts

Jag har fått överta ansvaret för en del av vårt intranät och förutom alla problem jag har att sätta mig in i den djungel av tabeller och views som ligger i databasen så har jag stött på vad jag tror är ett CSS-problem.

 

Iallafall märks bara problemet på min dator med IE6 och inte på de andra med IE5.

 

Det är en div som inte syns. CSS-en för diven ser ut så här:

 

.contentTop3 {

position:absolute;

width:100%;

top: 60px;

left: 0px;

margin:10px 16px 0px 0px;

border:0px solid black;

background-color:#fff;

padding:0px;

z-index:99;

height : 30px;

visibility : visible;

}

 

Någon som ser något konstigt där? Alla andra divar syns som de ska. Jag har testat att ändra positionering, z-index mm men ingen skillnad.

 

/Niklas

 

Link to comment
Share on other sites

Testa med att deklarera med ett # istället för en punkt.

Men jag vet inte om den gör någon skillnad men när man deklarerar divtaggar så ska man göra det med ett #-tecken iaf.

 

Link to comment
Share on other sites

Det har väl bara att göra med om det är en klass eller ett id?

<div class="class1">div1</div>

<div id="id1">div2</div>

 

i css:en

.class1 {

}

 

#id1 {

}

 

eller? Jag ska testa iallafall.

 

tillägg: gjorde ingen skillnad

 

/Niklas

 

 

[inlägget ändrat 2003-01-10 10:48:48 av ns]

Link to comment
Share on other sites

Jimmie Pettersson

När man deklarerar med # så deklarerar man ett id och inte en klass.

 

Du har helt rätt ns.

 

/J

 

Link to comment
Share on other sites

Jimmie Pettersson
Bakgrundsfärgen gillar han väl inte; ska det inte vara #ffffff

 

Man kan skriva så tror jag.

 

(Har tittat på W3.org och fått det bekräftat att det kan vara så, de använder tom det själva i sin kod. Så det är KORREKT.

 

/Jimmie

 

[inlägget ändrat 2003-01-10 11:46:03 av Jimmie Pettersson]

Link to comment
Share on other sites

Jag har också hajat till på att det bara är 3 tecken i färgkoden, men det är så nästan övergripande i css:en och det funkar i övrigt och en ändring till #ffffff gjorde ingen skillnad, inte heller display: show.

 

Det kan ju vara just min installation som är knas, men eftersom ingen annan på kontoret har sexan kan jag inte testa från någon annan dator, och eftersom det är på intranätet kan jag ju inte kolla hemifrån heller.

 

/Niklas

 

Link to comment
Share on other sites

Hej

#fff går alldeles utmärkt att skriva.

likaså .xxx om det är en class man deklarerar

#xxx skriver man om man deklarerar ett id.

 

Testade din kod i IE6 och ser texten om det är text du skall ha. Däremot syns inte bordern då den är satt till 0px.

Förtydliga lite vad det är som inte syns.

 

Det som slår mig nu... om man använder visibility: visible; brukar man ha någon form av onMouseOver eller nåt... kan det vara det som spökar? Att classen inte används i normalläge?

En tanke bara...

[inlägget ändrat 2003-01-10 11:48:55 av Nilsson]

[inlägget ändrat 2003-01-10 11:51:43 av Nilsson]

Link to comment
Share on other sites

Jag satte visibility: hidden på alla andra divar och upptäckte då att det fanns men låg på fel plats. Det verkar som att den struntar i top-värdet för den ligger längst upp till vänster!

 

Det är ingen onMouseover inblandad.

 

/Niklas

 

Link to comment
Share on other sites

Inte i min IE6!? Där ligger den 60px från toppen och 0px in. Däremot så struntar den i margin, vilket ser (i mina ögon) lite fel ut. Jag brukar aldrig använda mig av både margin och top utan antingen eller.

Kan det vara det som ställer till det.

IE6 har ju blivit lite tuffare i kraven på rätt skriven kod oxå.

//Ch

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...