Just nu i M3-nätverket
Jump to content

apache-problem


Krister E

Recommended Posts

det är kanske fel forum men jag försöker ändå här - oxå

 

har installerat foxserv-paket med php,apache och mysql.

php och mysql funkade bra, däremot verkar inte apachen funka.

i apache-info stod det att service inte funkade på win98 så jag tog bort apache-mappen under foxserv-mappen.

hämtade hem apache2 från deras hemsida och installerade den under foxserv-mappen och startade apache2 i console.

(vet ej riktigt vad service är)

kör man monitor så visar den inte att apache startat el.liknande.

i dos-fönstret kom följande medd.

apache.exe: could not open document config file c:/foxserv/apache/apache2/http.conf

 

hur kan apache finnas med i sökvägen, jag har ju tagit bort den mappen (även om den bara blivit deletad)?

finns den här sökvägen i ngn fil så man kan ändra den?

 

hoppas ngn förstår min gallimatias och kan hjälpa

/krister

Link to comment
Share on other sites

HTTP:conf är inställningsfilen till apache, och är i så fall inte på den plats, prova med att leta upp filen, och leta upp var sökvägen finns.

 

Ändra!

 

Eftersom jag inte har foxserv kan jag inte veta hur det ser ut.

 

Link to comment
Share on other sites

httpd.conf ligger i \foxserv\apache2\conf, men i felmeddelandet så står det att den inte kan hitta filen i \foxserv\APACHE\apache2\conf.

 

var får den apache ifrån?

 

jag avinstallerade ju den apache som kom med foxserv-paketet och installerade apache2 istället.

 

tacksam om ngn kan reda ut detta.

 

Link to comment
Share on other sites

hittade inget i registret som kunde hjälpa mig.

körde detta i dos:

C:\FoxServ\Apache2\bin>apache -t

Syntax OK

C:\FoxServ\Apache2\bin>apache

 

-t skulle tydligen kolla conf-filen och den verkar ju ok, sedan när man kör apache (exe-filen ligger i bin) så händer inget, och apache monitor som ska säga att apache startat, finns bara ok-knappen att trycka på, varken strt el. stopp-knappen går att trycka på.

 

när man sedan öppnar ett annat fönster för att stänga så står detta:

C:\FoxServ\Apache2\bin>apache -k shutdown [Thu Nov 07 21:19:07 2002] [error] (720002)Det gÕr inte att hitta filen. : No installed service named "Apache2".

 

konstigt, va? eftersom jag har apache2 liggandes under foxserv, eller måste den ha en egen mapp (typ C:/apachegroup/apache)?

 

trodde det här skulle vara a walk in the park, men det är en mardröm.

 

snälla, hjälp!

 

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...