Just nu i M3-nätverket
Jump to content

php-sidor visas som 'plain text' - alltså källkod


Gurra4

Recommended Posts

Jag kan inte använda php parsern. Jag kör Apache2 och har installerat senaste php. När jag öppnar en .php sida så visas den som vanlig text, det vill säga man ser hela källkoden.

Jag provade även att lägga till 'AddType application/x-httpd-php .html' i httpd.conf för att även .html sidor skulle filtreras. men det som händer då är att när jag öppnar en html-sida i webbläsaren så får jag upp kör/spara-dialogen.

Vad har jag gjort för fel? Hur ska jag få php att fungera. Tidigare minns jag att allt fungerade direkt efter att man installerat php.

Link to comment
Share on other sites

Två saker ska du kolla:

 

1. Är PHP kompilerat för Apache 2? Som standard kompileras det för Apache 1.x.

 

2. Lägg även till följande i httpd.conf:

<FilesMatch "\.php(\..+)?$">

SetOutputFilter PHP

</FilesMatch>

 

Link to comment
Share on other sites

Jag hittade detta på PHPs webbsidor:

(http://se.php.net/manual/en/install.linux.php)

Updated instructions for installing Apache 2.x with PHP4 and MySQL:

(1)

Download httpd-2.0.40-i686-pc-linux-gnu-rh73.tar.gz from http://www.apache.org/dist/httpd/binaries/linux/

 

(2)

Download php4-latest.tar.gz from http://snaps.php.net/

 

(3)

tar -xzvf httpd-2.0.40-i686-pc-linux-gnu-rh73.tar.gz

cd httpd*

./configure --prefix=/Apps/apache --enable-module=so

make

make install

 

(4)

tar -xzvf php-4.2.2.tar.gz

cd php*

./configure --with-mysql --with-apxs2=/path/to/apxs

(To find path/to/apxs, do slocate -u /, then slocate apxs)

make

make install

cp php.ini-dist /usr/local/lib/php.ini

 

(5)

Add the following to httpd.conf

AddType application/x-httpd-php .php

LoadModule php4_module /path/to/libphp4.so

(To find path/to/libphp4.so, do slocate -u /, then slocate libphp4.so)

 

(6)

Restart httpd:

/path/to/apachectl restart

 

Notes:

Never had problems with ./configure or make with apache. But wow, a world of pain in trying to do a make on php. (Make sure to use --enable-module=so, when doing a ./configure with apache.) I kept getting make errors with php (No problems with ./configure). Thanks to pvenable@cs.cmu.edu, I found out the problem was with php-4.2.2.tar.gz. Make sure to get php4-latest.tar.gz! Hope this helps someone out there. Good luck!

 

Link to comment
Share on other sites

jag hade samma problem för någon månad sedan, det löste sig för mig genom att jag gjorde så som Cariad skriver.

 

Don't Underestimate The Power Of Esuk ...

 

Link to comment
Share on other sites

Nej, detta var avsett för Linux.

 

För att göra ett kort svar långt:

\-tecknena är inte sökvägstecken, utan "escape"-tecken, eftersom . (punkt) har en speciell betydelse i reguljära uttryck. Dessa är till för att parsern ska veta att det bara är text.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...