Just nu i M3-nätverket
Jump to content

hjälp med en fil jag har i exel med tider


nisse24
 Share

Recommended Posts

 behöver hjälp med  en sak i  exelfilen  skriver jag tid in och tid ut så räknar han ut tim och enkel övertid och kval övertid

det jag behöver hjälp med är när en röd dag är på en vardag för då är det kval övertid tänkte om det går med en omsats är inte så duktig i exel men jag tränar på att bli bättre

Link to comment
Share on other sites

Kolla in:

https://support.microsoft.com/sv-se/office/nettoarbetsdagar-funktionen-nettoarbetsdagar-48e717bf-a7a3-495f-969e-5005e3eb18e7

 

Det är en funktion där du skriver in ett start/slutdatum så får du reda på hur många vardagar det finns emellan datumen.  Jag antar att start/slut står i cell A-B (och att du har skrivit tid och datum i samma cell)

image.png.d26e2d8fef0fc201971a6b13783b453f.png

 

Om du skriver in den här formeln i C2

=(NETTOARBETSDAGAR(A2;B2)=0)

Så får du "Sant" om det är veckoslut (då är det 0 arbetsdagar emellan start/slut)

 

NETTOARBETSDAGAR tillåter dessutom att du anger röda dagar i en lista. Två dagar i mitt exempel..

image.png.f8ac5b22a6cddb4dd5685e24646bac65.png

Då räknas även dessa dagar bort från arbetsdagar.

=NETTOARBETSDAGAR(A2;B2;$H$2:$H$3)=0

 

Det här kan du använda genom att jämför resultatet från de olika formlerna.  Men det blir problem om en röd dag inträffar under ett veckoslut. Då vet du inte om det är ledigt pga veckoslut eller röd dag. 

 

Men det fixar du med hjälp av den internationella varianten av NETTOARBETSDAGAR där du kan bestämma vilka dagar som är veckoslut/veckoledig.

https://support.microsoft.com/sv-se/office/nettoarbetsdagar-int-funktionen-nettoarbetsdagar-int-a9b26239-4f20-46a1-9ab8-4e925bfd5e28

Eftersom du är en elak arbetsgivare så säger du att Alla veckodagar är arbetsdagar (strängen "0000000" betyder att ingen dag är 1=ledigt). Då blir det här villkoret bara sant om datumet är en röd dag (dvs 2 gånger om året :-))

=NETTOARBETSDAGAR.INT(A2;B2;"0000000";$H$2:$H$3)=0

 

Om du klurar ett tag så kan du göra en smart lösning som använder skillnaden mellan svaren för att lista ut om det är en vardag/helg/röd dag

Typ

=OM(NETTOARBETSDAGAR.INT(A2;B2;"0000000";$H$2:$H$3)=0;"Röd dag";OM(NETTOARBETSDAGAR(A2;B2)=0;"Veckoslut";"Vardag"))

 

image.png.81d6873522cadc2d54540389563c114a.png

 

 

Sen har du alla roliga situationer när arbetstiden går över dygnsgränsen osv. Men det finns en klistrad tråd högst upp i excel delen av forumet som handlar om det .

 

 

Link to comment
Share on other sites

veckodag Datum Tid in  Tid ut  Arbetad tid Kommentar Enkel övertid Kval.övertid Kval övertid morgon
6 01-jan 08:20 09:20 01:00 utkörning 00:00 01:00 00:00
6 01-jan 09:20 14:00 04:40 utkörning 00:00 04:40 00:00
6 01-jan 14:00 14:30 00:30

samtal

 

 

 

 

 

 

00:00 00:30 00:00

 

 så här ser filen ut veckodag är i d kolumn vet ej hur man kan överföra på ett smidigt sätt jag tänkte att man sätte en 8 om 8 =röd dag so är en vardag

Link to comment
Share on other sites

behöver hjälp med en sak i exelfilen  i flik jan 22 skriver jag tid in och tid ut så räknar han ut tim och enkel övertid och kval övertid det jag behöver hjälp med är när en röd dag är på en vardag för då är det kval övertid tänkte om det går med en omsats är inte så duktig i exel men jag tränar på att bli bättre sänder en fil

1927476325_Lekvertidny5tillforum.xlsx

Link to comment
Share on other sites

Hej.

Du har skrivit in datumet för Midsommardagen fel i helglistan så formeln får "frispel". Jag insåg just att jag läste fel på din fråga. Du vill räkna veckoslut och Röd dag som samma? det är inte storhelgstillägg? Då kan du ju behandla alla helger likadant.

 

Är helg 0/1

=(NETTOARBETSDAGAR(E15;E15;helgdagar!$O$5:$O$30)=0)

 

slutet på övertid morgon (hanterar om passet slutar före 08:30, eller fortsätter efter 08:30): 

=MIN(G15;morgonövertid)

TotTid morgon

=MIN(G15;morgonövertid)-F15

räkna bara pass som startar före 08:30 

=OM(F15<morgonövertid;MIN(G15;morgonövertid)-F15;0)

 

Kval Övertid, samma sak fast åt andra hållet:

G15-MAX(F15;Startkvalövertid)

=OM(G15>Startkvalövertid;G15-MAX(F15;Startkvalövertid);0)

 

Enkel övertid är lite krångligare eftersom passen kan delas med både normaltid och kval-övertid. 

=MIN(G15;Startkvalövertid)-MAX(F15;startenkelövertid)

Ogiltiga värden hanteras enklast genom att Ta bort negativa värden (Om-villkoren blir för krångliga annars)

=OM(MIN(G15;Startkvalövertid)-MAX(F15;startenkelövertid)>0;MIN(G15;Startkvalövertid)-MAX(F15;startenkelövertid);0)

 

Peta ihop på lämpligt sätt (jag använder "mina" tidsformler, men du kan självklart köra dina egna)

"0:a" övertid och morgonövertid om det är helg

=OM(NETTOARBETSDAGAR(E15;E15;helgdagar!$O$5:$O$30)=0;0;OM(F15<morgonövertid;MIN(G15;morgonövertid)-F15;0))

 

övertid

=OM(NETTOARBETSDAGAR(E15;E15;helgdagar!$O$5:$O$30)=0;0;OM(MIN(G15;Startkvalövertid)-MAX(F15;startenkelövertid)>0;MIN(G15;Startkvalövertid)-MAX(F15;startenkelövertid);0))

 

Och låt kval övertid ta all tid (precis som du gjort för vanliga helger)

=OM(NETTOARBETSDAGAR(E15;E15;helgdagar!$O$5:$O$30)=0;H15;OM(G15>Startkvalövertid;G15-MAX(F15;Startkvalövertid);0))

 

Och återigen - obs att de här formlerna inte hantera pass som går över midnatt.

Link to comment
Share on other sites

har du kolla på filen enkel övertid börjar 16:40 slutar 18:40 sen blir det kval övertid vardagar

kval övertid morgon  slutar 08:30

våran beredskap börjar 16:40 slutar dagen efter 08:30

jag skulle vilja om du kunde bifoga filen så kan jag kolla på den vill inte förstöra dom omsatser som finns eller bygga nytt vi är flera  som andvänder filen 

vad det handlar om är när en röd dag infaller på en vardag för då blir det kval övertid det är som är problem

men kan du sända filen så kan jag kolla på den

jag är tacksam för all hjälp jag kan få

Link to comment
Share on other sites

jag provade  denna=(NETTOARBETSDAGAR(E15;E15;helgdagar!$O$5:$O$30)=0) då  säger den sant eller falskt beroende vilket datum jag skriver   är det rätt så             jag kollar på den vidare

Link to comment
Share on other sites

Ja, excel tolkar en tom cell som 0:00

Jag antar att du får lägga in ett villkor som kollar att det överhuvudtaget står något i cellen innan den räknar.

=OM(ANTAL(F15:G15)<2;0;OM(NETTOA.....

Och slänga in en extra avslutande parantes på slutet

 

=OM(ANTAL(F15:G15)<2;0;OM(NETTOARBETSDAGAR(E15;E15;helgdagar!$O$5:$O$30)=0;0;OM(MIN(G15;Startkvalövertid)-MAX(F15;startenkelövertid)>0;MIN(G15;Startkvalövertid)-MAX(F15;startenkelövertid);0)))

 

=OM(ANTAL(F15:G15)<2;0;OM(NETTOARBETSDAGAR(E15;E15;helgdagar!$O$5:$O$30)=0;H15;OM(G15>Startkvalövertid;G15-MAX(F15;Startkvalövertid);0)))

 

=OM(ANTAL(F15:G15)<2;0;OM(NETTOARBETSDAGAR(E15;E15;helgdagar!$O$5:$O$30)=0;0;OM(F15<morgonövertid;MIN(G15;morgonövertid)-F15;0)))

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...