Just nu i M3-nätverket
Jump to content

Hur skriver jag fler OM funktioner efter varandra?


Markus79
 Share

Recommended Posts

Ove Söderlund

Du behöver kapsla (eller nästla, kärt barn har många namn) in OM-satserna inuti varandra så din formel behöver se ut så här:

=OM(B2="FAZ856445";A2/32;OM(B2="COC1756";A2/4;""))

 Alltså OM villkor 1 så beräkna 1a annars OM villkor 2 så beräkna 2a och slutligen om villkor inte alls uppfylls så värde = "".

 

Mer info på följande sida:

Funktionen OM – kapslade formler och hur du undviker fallgropar / Microsoft.com

 

 

Link to comment
Share on other sites

Ove har ju redan löst ditt problem. Men för framtida användning: 

I nyare excel har du flera nya varianter av OM(). T.ex VÄXLA() som tittar i en cell (b2) och "växlar" mellan olika alternativ beroende på värdet i cellen:

=VÄXLA(B2;"FAZ856445";A2/32;"COC1756";A2/4;"")

Det påminner ju mer om hur du verkar ha tänkt när du försökte skriva flera OM-formler

 

Dessutom finns IFS. Men då handlar det om att stapla flera villkor som är mer komplexa än ett exakt värde i en cell.

https://support.microsoft.com/sv-se/office/funktionen-ifs-36329a26-37b2-467c-972b-4a39bd951d45

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...