Just nu i M3-nätverket
Jump to content

Hjälp med klurig formel i Excel


einfinity
 Share

Go to solution Solved by MH_,

Recommended Posts

Hej!

Svårt att ställa rätt fråga till google ang detta känner jag!

 

Jag har ett antal kolumner med värden (siffror). Jag vill summera: A2*U2, A3*U3, A4*U4 i samma CELL i slutet av kolumnen. Det får jag till.

 

Jag vill göra samma sak i nästa kolumn till höger men värdet jag gångrar med skall vara samma. Ex.  B2*U2, B3*U3, B4*U4. Jag har rätt många kolumner så jag vill bara kunna markera en cell med summan  och dra med hjälp av plustecknet till höger. Men då flyttar den båda värdena två steg till B2*V2, B3*V3 etc. Då vill jag att den per automatik skall byta från att hämta värdet i C2 till att hämta det i D2 men fortfarande gångra det med motsvarande värde i kolumnen U. DVS summan i kolumnen A skall vara A2*U2, summan i kolumn B skall vara B2*U2. Jag vill automatisera detta :)

 

Hoppas ni förstår vad jag menar och tack på förhand!

 

Emelie

Link to comment
Share on other sites

  • Solution

Om jag förstår dig rätt så vill du använda Absoluta (låsta) referenser. De ändras inte när du kopierar din cell

Om din originalformel är någonting i stil med:

=SUMMA( A2*U2;A3*U3; A4*U4)

så använder du $-tecknet för att "låsa fast" cellreferensen (adressen). Ungefär så här:

=SUMMA( A2*$U$2;A3*$U$3; A4*$U$4)

Antingen skriver du in dollartecknet ($) eller  också trycker du på tangenten [F4] som gör att du kan hoppa mellan olika låsningslägen.

 

Det här är väldigt användbart. Du kan köra olika varianter. Exempelvis nöja dig med att "låsa fast" kolumnen men låta raden variera. Kolla Excelhjälpens sida:

https://support.office.com/sv-se/article/växla-mellan-relativa-absoluta-och-blandade-referenser-dfec08cd-ae65-4f56-839e-5f0d8d0baca9

 

En helt annan variant är att ge U2, U3, U4 fasta namn (Ctr+F3 eller FORMLER->skapa namn) sen kan du skrivva in namnen i formeln.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...