Just nu i M3-nätverket
Gå till innehåll
Mikael63

CAD-problem x 2

Rekommendera Poster

Postad (redigerade)

Två olika problem/frågeställningar som inte har ett dugg med varandra att göra.

Frågorna avser egentligen Bricscad från Bricsys men om svar finnes för AutoCad från Autodesk så torde det vara tillräckligt då programmen är väldigt lika varandra.

 

1. Jag har vid kopiering av objekt lyckats få ett väldigt knepigt värde för Z i position, för kopiorna. Ritar bara i 2D så värdet ska vara 0 och det är också det normala. Jag torde ha kopierat miljontals objekt under alla år utan att ha råkat ut för detta men nu de senaste veckorna ett flertal gånger.
Frågan avser inte hur jag ändrar/åtgärdar detta utan hur/när detta ens varit möjligt? Jag lyckas inte reproducera symptomen oavsett hur jag bär mig åt. (Ja, förutom att manuellt ändra värdet på Z)

2. Händer då och då att det uppstår ett (då väldigt stort) behov av att kunna ändra ett TAG,namn som används i en befintlig ritning och utan att värdet återställs till det förinställda värdet. Jag kan med BATTMAN ändra TAG,en i ett block men för att det ska slå igenom på ritningen behöver jag använda "Sync" i BATTMAN och det är då som det inskrivna värdet sabbas.

 

Förslag & tips uppskattas, jag sitter och väntar/googlar!

 

Tillägg190220. Hittade en gammal tråd där problematiken i punkt 2 bekräftas.

https://forum.bricsys.com/discussion/23995/the-command-battman-fails-to-sychronize-changed-attribute-definitions-of-existing-block-inserts-ins

 

 

 

Redigerad av Mikael63
hittat lite på nätet

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Svarar mig själv för att lyfta bort från "Obesvarade ämnen"

1. Bricsys har ingen förklaring, de lyckas inte heller återskapa ett sådant fel. Tipsar om att sätta OSNAPZ =1 för att (ev.) motverka att detta händer.

2. Bricsys svarar att "det är så det fungerar"...

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
6 timmar sedan, skrev Flyfisherman:

Hmm.

 

Om du har löst det,

Varför ens då ta upp detta

 

 

Frågorna ställdes 19/2 efter att jag inte själv, efter mycket testande, hittat någon förklaring till fråga 1 som hände ett par veckor tidigare.

Eftersom jag ändå frågade om 1. ställde jag fråga 2. som är ett problem som funnits mycket längre tid men som jag inte engagerat mig i så mycket, förrän problematiken åter dök upp någon vecka tidigare än min postning.

 

Jag fortsatte själv att luska kring detta och kontaktade Bricsys angående fråga 1. Eftersom jag fick gehör (men inte svar på den direkta frågan) ställde jag även fråga 2. till Bricsys.

 

Eftersom ingen annan svarat på min fråga här på eforum postade jag, en vecka senare, svaret som Bricsys gav mig, efter lite konverserande. 

 

Båda frågorna kvarstår/är inte lösta!

Att Bricscad inte kan förklara 1. innebär inte att ingen kan det. Jag vill fortfarande veta hur man kan åstadkomma detta fel bara genom att kopiera objekt från ett ställe på en ritning till ett annat ställe på samma ritning?

 

Att Bricscad inte hanterar 2. innebär inte att inget annat program kan det. Jag har sett gamla trådar där man beskriver att detta fungerar bra i AutoCad, jag har sett gamla trådar där man beskriver att detta går att lösa med LISP men i samma tråd att saker inte fungerar med detta osv.

Ingen konkret lösning således.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

OK.

 

Citat

1. Jag har vid kopiering av objekt lyckats få ett väldigt knepigt värde för Z i position, för kopiorna. Ritar bara i 2D så värdet ska vara 0 och det är också det normala. Jag torde ha kopierat miljontals objekt under alla år utan att ha råkat ut för detta men nu de senaste veckorna ett flertal gånger.
Frågan avser inte hur jag ändrar/åtgärdar detta utan hur/när detta ens varit möjligt? Jag lyckas inte reproducera symptomen oavsett hur jag bär mig åt. (Ja, förutom att manuellt ändra värdet på Z)

Om du nollställer z- (och givetvis XY) ta en ny referenspunkt varsomhelst, hur hamnar du då?

 

När jag gör en mätning  i AutoCad så har jag ofta stött på detta fenomen, men aldrig tänkt så mycket på det egentligen.

Eftersom jag enkelt kan kan ta en ny referenspunkt och nollställa (origo). Jag börjar alltid med detta. Sedan går alla mätningar klockrent, bara vid öppning av ny ritning/fil måste jag göra detta och helt oavsett hur många öppna ritningar/fönster jag har igång så räcker det med att göra detta en gång.

 

Kan det vara samma slag vi upplever, trots olika programvaror?

 

😕

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

1. Problemet är att jag inte kan återskapa/forcera detta fel. Förhoppningsvis kommer det aldrig att inträffa igen men eftersom jag råkat ut för detta ett flertal gånger i samma DWG (ja det gemensamma är faktiskt en specifik DWG men på olika lager) vill jag säkerställa, om möjligt, att jag inte får detta fel igen.

Misstänker, utan några belägg för det, att det skulle kunna vara en följd av något annat kommando. ESNAP kan ex. ge mysko fenomen i min applikation men aldrig tidigare av detta slag.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
5 minuter sedan, skrev Mikael63:

1. Problemet är att jag inte kan återskapa/forcera detta fel. Förhoppningsvis kommer det aldrig att inträffa igen men eftersom jag råkat ut för detta ett flertal gånger i samma DWG (ja det gemensamma är faktiskt en specifik DWG men på olika lager) vill jag säkerställa, om möjligt, att jag inte får detta fel igen.

Misstänker, utan några belägg för det, att det skulle kunna vara en följd av något annat kommando. ESNAP kan ex. ge mysko fenomen i min applikation men aldrig tidigare av detta slag.

 

I fall du vill kan du skicka mig .dwg filen (med detaljerad information om vad) och jag kanske kan försöka att återskapa problemet?

I så fall kanske vi kan spara i ett annat format och se om problemet finns?

Ja ett led för att försöka hitta rot-orsaken menar jag.

 

Mvh

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×