Just nu i M3-nätverket
Gå till innehåll
at1981at1981

Egna formler / beräkningar i Excel!

Rekommendera Poster

Hejsan!


***
Om man vill programmera en egen beräkning till Excel!
Hur gör man?

Vilket programmeringsspråk är bäst att utföra momentet på,
Java eller C++?

***
Här har jag ett konkret exempel :)
Denna kod skall ersätta den inbyggda OM-formeln i Excel och förhoppningsvis förenkla! :)

I Cell A1 står det "Poäng" och i cell B1 står det "Betyg".
I Cell A2 till A202 har vi slumpmässiga halva tal mellan 0 till 100 där ett tal får förekomma max en gång.
(0, 0,5, 1 o.s.v. till 99,5 och 100)

Med hjälp av koden skall betyget kunna redovisas i Cell B2 till B202 med hjälp av Autofyll-funktionen.

***
Här nedan presenterar jag den extremt långa betygsskalan med 22 st. termer och resp. poäng för att uppnå dessa betyg!
(Denna listan kan redovisas i cell D1:E22) (Detta skulle vara mycket jobbigt att skriva med OM-formeln)

SMVG: <0,25
SMVG-: 4,995
MVG+: 9,74
MVG: 14,485
MVG-: 19,23
VG+: 23,975
VG: 28,72
VG-: 33,465
G+: 38,21
G: 42,955
G-: 47,7
IG+: 52,445
IG: 57,19
IG-: 61,935
VIG+: 66,68
VIG: 71,425
VIG-: 76,17
MVIG+: 80,915
MVIG: 85,66
MVIG-: 90,405
SMVIG+: 95,15
SMVIG: >99,895


MVH at1981 !!
Ps. Tack på förhand för hjälpen :) Ds.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Det går med formler. Men jag tror att du har lämnat en glugg utan betyg mellan 95 och 99,5 
Enligt logiken i början av listan betyder:
SMVG-: 4,995
Att värden från 0,25 och upp till 4,995 skall få betyg SMVG-
Då måste den näst sista raden: 
SMVIG+: 95,15
 betyda att SMVIG+ bara går till 95,15. 
Sen anger du att det sista betyget bara gäller för värdet 100. 
SMVIG: >99,895, dvs det fattas betyg för värden mellan 95,15 och 99,895

 

 

Hursomhelst. Om du gör om din hjälplista enligt nedanstående förslag så borde de här formlerna fungera:

=INDEX($E$1:$E$23;PASSA(A1;$F$1:$F$23;1))

 

SMVG: 0

SMVG-: 0,25
MVG+: 4,995
MVG: 9,74
MVG-: 14,485
VG+: 19,23
VG: 23,975
VG-: 28,72
G+: 33,465
G: 38,21
G-: 42,955
IG+: 47,7
IG: 52,445
IG-: 57,19
VIG+: 61,935
VIG: 66,68
VIG-: 71,425
MVIG+: 76,17
MVIG: 80,915
MVIG-: 85,66
SMVIG+: 90,405
Saknas:
95,15
SMVIG: 99,895

 

 

Byter du plats på kolumn D och E så att siffrorna står till vänster kan du köra letarad med Ungefärligt=SANT istället (om det känns mer bekant)

=LETARAD(A1;$D$1:$E$23;2;SANT)

Redigerad av MH_resurrected

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×