Just nu i M3-nätverket
Gå till innehåll
pjohannesson

No bootable device, mm.

Rekommendera Poster

pjohannesson

Hej,

senaste veckan, under arbete vid min 3½ år gamla Notebook Toshiba Qosmio X870-11P, 17", med OS W7 och en 128GB SSD + 1TB HDD, har jag vid två tillfällen fått upp svart-skärm med text enligt nedan.

Jag upptäckte det först när jag återvänt efter att varit iväg några minuter från PC:n.

Stängde då av PC:n med strömknappen och återstartade igen med strömknappen efter någon minut.

Under startförloppet valde jag bort alternativet att "starta felsäkert", utan körde normal-start och det fungerade bra och PC:n fungerar normalt efteråt.

Tacksam om någon kan förklara hur felet uppstår och föreslå åtgärd!

 

FELTEXT:

"Intel UNDI, PXE-2.0 (build 083)

Copyright © 1998-2000 Inter Corporation

For Atheros PCIE Ethernet Controller v2.1.1.1(12/23/11)

Check Cable Connection!

PXE-MOF: Exiting Intel PXE ROM

No bootable device -- insert boot disk and press any key"

 

 

// pjohannesson

post-125521-0-40294000-1472125570_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
.M

No bootable device tyder på att din dator inte hittat hårddisken den ska starta ifrån.

 

Kanske så enkelt att det är glapp i en sladd. Så du kanske skulle titta in i datorn och kontrollera att alla sladdar verkar sitta ordentligt.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
vertpre

Håller med .M för det står ju faktiskt "Check Cable Connection!" i feltexten.

 

Sitter alla sladdar ordentligt kan du prova det som står här:

https://malwaretips.com/threads/how-to-fix-no-bootable-device-%E2%80%93-insert-boot-disk-and-press-any-key.8907/

 

 

"Check cable connection" har nog inte med hårddisken att göra, utan med Ethernet Contollern, d.v.s. Internet. Det är möjligt att det i BIOS under "Boot Order" finns ett alternativ som heter Network Boot eller något liknade. När datorn försöker starta från det alternativet, hittar den ingen förbindelse och då kommer meddelandet upp.

 

Andra gånger lyckas datorn gå datorn förbi det alternativet och går på nästa startalternativ, som då är hårddisken och kan då starta datorn. Helt säker på att det förhåller sig så, kan man inte vara utan se hur Boot Order ser ut i bios.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
ljungholm

Har varit med om ett liknade problem där min stationera helt plötsligt dör med svartskärm som följd (OS Ubuntu). Först trodde jag det var processorn som det var fel på och bytte till en ny men problemet kvarstod. Då testade jag med att sätta in en ny hårddisk och nu fungerar den. Det diagnostisering verktyget som jag använde kunde inte vissa att det var något fel på den gamla disken. Kanske det är likadant för dig tänker jag, när din dator nu letar efter andra enheter att boota ifrån.
 
Ett sätt att testa ifall notebookens hårddiskar är defekta kan vara att skapa en bootnings bar usb-minne. (Har ingen erfarenhet av det själv men tänkte att det kunde vara ett billigt sätt att komma runt problemet om den primära hårddisken är trasig.
Klistrar in en guide här nedan
http://www.pendrivelinux.com/run-linux-mint-9-from-a-usb-flash-drive/

Redigerad av Cecilia
Tagit bort kodrutan runt länken /Cecilia, moderator

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pjohannesson

Hej, tack för tipsen ovan!

Har ägnat dagen åt följande, tyvärr utan att hitta orsaken till svartskärmen...

1. Kontrollerat SSD:n & DDD:n via Toshiba Health Monitor. "Båda fungerar som de skall"

2. Kört Windows admin-verktyg "Analysera minnesproblem". "Inga problem"

3. Kört Windows admin-verktyg "Visa händelseloggar". Gick igenom alla 5 olika "Händelsetyperna" och hittade de två tidsspann på 15 resp. 25 minuter då svartskärmen uppstod den 17/8 rep. 24/8, samtidigt som jag inte just då satt vid datorn och kunde se vad som hände. Analyserade händelserna i anslutning till dessa tidsspann men hittade inget som jag kan koppla till svartskärmens uppkomst.

4. Kontrollerade startordningen i BIOS. San Disk-SSD:n är markerad som1:a alternativ, sedan följer i tur och ordning Toshiba-HDD:n > USB (WD My Passport, backupdisk) > ODD > Nätverk (LAN Atheros Boot agent). Och det är väl inget anmärkningsvärt med det, eller hur?

 

Så, jag kliar mig fortfarande i huvudet och skulle bli mycket tacksam om någon kan förklara hur min svartskärm uppstår.....

Med vänlig hälsning // pjohannesson

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Åge N

Eftersom du har en bärbar dator sitter inte diskarna kopplade med kabel. De sitter monterade i en SATA-kontakt och kanske är diskarna skruvade fast i höljet på datorn. Det är inte alltid som diskarna skruvas fast.

Att det skall vara ett kabelfel mellan moderkortet och diskarna är uteslutet.

 

Du skulle kunna öppna luckan där diskarna sitter. Det är ett enkelt ingrepp och du behöver bara en Philips-mejsel eventuellt en Pozidrive-mejsel om det är pozidriveskruvar (även kallad kryssmejsel eller stjärnskruvmejsel) och lossar samtliga skruvar. Det kan röra sig om ca. 4-7 skruv. När du lossat skruvarna tar du tag i en kant på luckan och lyfter försiktigt upp den.

Se till att använda ESD-skydd när du öppnar luckan för att inte riskera att skada komponenter i datorn.

 

Kontrollera att diskarna sitter ordentligt anslutna till SATA-kontakten på moderkortet. Om så är fallet, fortsätt med förslagen nedan.

 

Kan du se om datorn behåller tid och datum i BIOS? Koppla bort datorn från internet så att inte Windows uppdaterar klockan. Om datorn tappar tid och datum kan felet bero på att batteriet för CMOS-minnet är slut. Det är även det batteri som ser till att behålla inställningarna i BIOS när datorn är avstängd.

 

Jag skulle också föreslå en sak till att testa.

 

Hämta en Linux-distribution, t.ex. Ubuntu, och bränn den på en optisk skiva.

Ubuntu kan du hämta här:

 

http://www.ubuntu.com/download/desktop

 

När du väl bränt Linux på en optisk skiva lägger du skivan i din optiska enhet i datorn.

Aktivera BIOS och ställ in BIOS att starta först från en optiska enheten.

Spara BIOS-inställningarna.

Starta om datorn och se om den startar upp Linux från skivan. OBS! Starta inte någon installation från skivan! Du riskerar att skriva över allt på dina diskar. Kontrollera bara att datorn startar upp och avbryt utan att påbörja installation.

Prova detta några gånger, utifall det fungerar, för att se om datorn fortsätter att starta från den optiska skivan.

 

Om datorn startar varje gång från skivan kan du ha ett fel på din SSD eller någon komponent som kommunicerar med disken.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pjohannesson

Hej Åge, och tack för tipsen!

Jag plockade ur både SSD: och HDD:n och satte tillbaka dom. Så vitt jag kan bedöma satt de fast ordentligt i sina resp. SATA-kontakter.

Kontrollerade därefter klockan i BIOS med Internet frånkopplat. Datum och tid var korrekta och sekunderna tickar fram normalt.

Körde sedan Toshibas medlevererade verktyg "PC-diagnos" mot Processor, Minne, Bildskärm, Nätverk, USB, Hårddisk, mm. Godkända resultat på allt.

 

Tror jag avvaktar med vidare åtgärder för nu, med förhoppningen om att jag råkar sitta framför skärmen precis just då problemet dyker upp nästa gång.

// pjohannesson

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...