Just nu i M3-nätverket
Jump to content

Hur funkar egentligen avbildsfiler?


Mikael63

Recommended Posts

Jag har ju gjort en hel del tester, över tid, i denna tråd:

//eforum.idg.se/topic/340707-usb-verktyg-i-linux/

 

Jag har gång på gång behövt revidera mina egna försök och jag kan inte själv förklara resultaten.

 

Denna gång skulle jag lägga över en ISO till ett USB-minne.

Beskrivningen för den var:

 

live and installation iso

 

Eftersom mina egna försök ledde fram till att Unetbootin var mest lämpad, enligt den andra tråden, använde jag den.

Skrivningen lyckades men det gick inte att starta upp datorn.

Boot error

 

Jag använde mig då av den enkla "usb-writer" som jag har i Linux.

Den jag en gång hade dömt ut.

Då går det att boota.

 

Varför blir det olika resultat?

 

Program som Unetbootin och YUMI skapar ju en egen liten meny där man kan välja olika alternativ. Är det DET som hamnar i konflikt med vissa avbildsfiler?

 

Nu är det ju inte värre än att man prövar tills man hittar en metod som fungerar men det är ju lite irriterande att behöva göra så.

 

Idéer?

 

Finns något verktyg för att kolla vilken "typ" av image-fil det är frågan om? Om det ny är något som skiljer?

Link to comment
Share on other sites

160122

Jag har nu gjort ytterligare försök med avbildsfiler till USB.

Jag använder mig av samma USB-port som jag alltid använt för detta ändamål.

Jag ska nu pröva med två olika USB-minnen.
Det ena ett "no-name"/reklam.
Detta är grönt till färgen varför jag använder "grön" när jag menar det USB-minnet.
Det andra ett Kingston DataTraveler 100 G2 och detta kommer att får heta "svart".

Båda är på 4 GB.
Båda får genomgå samma förberedning:
Ta bort partition, skapa ny, primär, fat32.
Etikett sätts till grön resp. svart.

Använder två olika ISO-filer:
android-x86-5.1-rc1.iso och precise-5.7.1.ISO (Puppy)

De program som ska användas är:
Unetbootin för Linux
USB-avbildsskrivare (Linux)
Diskar (Linux)

GParted stängs direkt efter att man angivit lösen, trots ominstallation, varför denna mjukvara utelämnas.
TuxBoot verkar vara i princip samma mjukvara som Unetbotin varför den inte testas.

En bärbar dator används för att testa om datorn startar upp på USB-minnet eller ej.
En och samma port används.
Kontroll med ett sedan tidigare känt fungerande USB-minne görs och datorn bootar upp med det.

 

Resultatet visas här:

 

post-52940-0-79343500-1453501954_thumb.png

 

Till en början kunde man konstatera att programmet Diskar inte var så bra men ett andra försök visade att det kan gå lite hur som helst!

Unetbootin kunde inte hantera det gröna minnet utan klagade på att det behövde monteras, trots att det var det och de andra programmmen funkade.

 

Hur ska man komma till rätta med detta egentligen?

Ja, utan att bara testa sig fram från gång till gång?

 

Tillägg: Hittade YUMI för Linux men det hade inte stöd för att hantera Android och Puppy bootar ej.

Link to comment
Share on other sites

  • 9 months later...

Blev anledning att väcka (även) denna tråd till liv.

Ska försöka fatta mig kort.

 

Denna gång ett Kingston DataTraveler G3, 4 GB.

Använder USB-avbildsskrivare (i Linuxmiljö), skriver en ISO-fil (med Linxu Mint på)

Startar om men datorn startar ej på minnet

Börjar undersöka och GParted säger "Ogiltig partitionstabell rekursiv partition på /dev/sdc/"

Minnet är oallokerat.

Skapar ny partition och börjar om.

Samma fel, och detta prövar jag flera gånger.

Med programmet "Diskar" försöker jag ta bort befintlig partition men får i stort sett samma felmeddelande.

Minnet går inte heller att montera.

 

Gör ett försök med Unetbootin och filer skrivs till minnet, det är läsbart. Men ej startbart.

 

Googlar och får förslag att köra

dd if=/dev/zero of=/dev/hda bs=512 count=1

(fast där hda byts mot min sdc)

Vilket jag då utför.

 

Eftersom jag hade programmet Diskar igång använde jag det för att skriva ISO-filen.

Filer skrivs och minnet går nu att montera.

Dock bråkar GParted om precis samma sak.

(Är ju sedan tidigare inte helt nöjd med GParted)

 

Diskar anser att minnet är startbart.
Återkommer efter omstart och efter att åter ha prövat med USB-avbildsskrivare.

Äsch! Detta blev ju en mustigare soppa än vad jag räknat med...

 

Nix, startar ej, skriver på nytt, GParted påtalar samma fel, går inte montera via filhanteraren, Diskar visar inget fel och det går att montera via det programmet. Startar dock inte upp

 

Prövar med ett annat USB-minne

GParted påtalar samma fel, går inte montera via filhanteraren, Diskar visar inget fel och det går att montera via det programmet. Startar dock inte upp

 

I nuläget tankar jag hem en annan ISO att pröva med för att utesluta fel där.

Återkommer.

 

Åh så otroligt korkat av mig! :blush:

Hur många gånger har jag inte skrivit inlägg där jag påpekat att om min skrivare är ansluten via USB så skiter det sig när man ska starta upp från ett USB-minne!!??

Således är just problemet att starta/boota löst.

De felmeddelanden som GParted tjötar om får jag lämna därhän.

Får komma ihåg att använda programmet Diskar istället

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...