Just nu i M3-nätverket
Gå till innehåll

[löst] Automounta ntfs


Mikael63

Rekommendera Poster

Skulle vilja automounta en windowspartition sda2 men det vill sig inte.

Vad krävs?

 

fstab:

 

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	defaults	0	0
#Entry for /dev/sda5 :
UUID=7c4dc96a-492e-4c99-8b50-5ac76d5c4477	/	ext4	rw,errors=remount-ro	0	1
#Entry for /dev/sda2 :
UUID=1A66FF4066FF1AE9	/media/1A66FF4066FF1AE9_	ntfs	defaults,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,dmask=0077,fmask=0177	0	0
#Entry for /dev/sda6 :
UUID=d4cc1a24-f4e4-40df-ae60-5295184e0c83	swap	swap	sw	0	0

 

Om jag fösrsöker montera via Caja får jag:

 

post-52940-0-77393900-1354191645_thumb.png

Länk till inlägg
Dela på andra webbplatser

Nu är jag lite osäker, men måste du inte först skapa en monteringspunkt för varje partition som skall monteras?

 

ex.

/media/Mikael63

sudo mkdir /media/Mikael63

 

Sedan i etc/fstab

UUID=1A66FF4066FF1AE9 /media/Mikael63 ...etc. etc...

 

Se dessa:

https://help.ubuntu....ndowsPartitions

https://help.ubuntu....MountPartitions

Länk till inlägg
Dela på andra webbplatser

Tack! Kollade första länken och testade manuellt.

Fick detta:

Windows is hibernated, refused to mount.
Failed to mount '/dev/sda2': Operationen inte tillåten
The NTFS partition is hibernated. Please resume and shutdown Windows
properly, or mount the volume read-only with the 'ro' mount option, or
mount the volume read-write with the 'remove_hiberfile' mount option.
For example type on the command line:

           mount -t ntfs-3g -o remove_hiberfile /dev/sda2 /media/windisk

 

Detta kommando gav:

$LogFile version 2.0 is not supported.  (This driver supports version 1.1 only.)
$LogFile version 2.0 is not supported.  (This driver supports version 1.1 only.)
Did not find any restart pages in $LogFile and it was not empty.
The file system wasn't safely closed on Windows. Fixing.

 

Då är frågan hur/var jag petar in remove_hiberfile i fstab?

 

Eller hur ska man avsluta Windows 8 för att slippa detta? Jag väljer Startknappen (ClassicShell) och Stäng av - Stäng av

Edit: Avstängning med åttans eget gränssnitt ger samma resultat.

Länk till inlägg
Dela på andra webbplatser

Nu är jag alls inte säker på vad du menar, men stänger du av Windows 8 och Linux anser att den ändå ligger i hibernate?

 

Ja då beror detta på den inbyggda "Windows 8 snabbstart" eller 'Hybrid boot'.

Om datorn inte skall sättas i Viloläge så kan ju Hibernate stängas av (om detta är aktiverat under Kontrollpanelen, Energialternativ).

Men däremot är jag osäker på om detta påverkar den snabbare uppstarten på Windows 8 sk. ”hybrid boot"

Vet i nuläget inte tillräckligt om hur exakt det fungerar, annat än vad som står i länken.

Länk till inlägg
Dela på andra webbplatser

Hehe vad kul och tack för poängen.:thumbsup:

 

Btw. kan du inte skriva ned dom steg du gjorde för denna NTFS Automount, eller var det bara att följa den första länken rakt av?

Länk till inlägg
Dela på andra webbplatser

Jag hade ju redan UUID klar för mig, den befintliga raden hade säkert fungerat om det inte var detta med avstängningen i Windows som ställde till det.

Den raden hade jag fått av verktyget ntfs-config men jag har läst att det inte är så bra för nyare distar.

 

Jag skulle kunnat börja med stycket - Manual Configuration

och ner till Two special cases

 

Den del där man ska redigera filen fstab använde jag sudo pluma /etc/fstab eftersom jag kör med LMDE på denna.

 

Ska testa om jag kan montera manuellt också utan bråk.

 

Edit: Jadå - felmeddelandet enligt inlägg 1 uppstår inte längre-

Länk till inlägg
Dela på andra webbplatser

Arkiverat

Det här ämnet är nu arkiverat och är stängt för ytterligare svar.



×
×
  • Skapa nytt...