Just nu i M3-nätverket
Jump to content

IIS4 - Problem ?


Jan-E

Recommended Posts

Hej !

 

Vi har utvecklat en Web application i IIS4 , denna application skall hämta ett antal uppgifter ifrån en vanlig textfil på Servern.

När vi försöker öppna filen säger den att filen redan är öppen.

Vi kör NT4.0 SP6A , alla rättigheter ser Ok ut .

Applicationen accessas även ifrån en Talsvars application och denna kan öppna filen.

Vi har samma application gående på en identisk Server och där fungerar den bra.

Finns det någon sam kan ha något tips på ev Servicepack , el dyl hur man skall komma åt problemet.

Link to comment
Share on other sites

connyjohansson

Det kan inte vara så att filen blir låst av någon programdel som har bestämt sig för att skriva/ändra ntg i filen ?

 

 

 

 

Link to comment
Share on other sites

Svårt att säga , vi har scannat maskinen med hjälp av en programvara , och det vi får ut av den så ser det inte ut som filen är låst , öppen på något sätt

 

 

 

Tjenis !

Link to comment
Share on other sites

connyjohansson

Förslagsvis,

Starta all nödvändig programvara och kör tiis Felet uppstår.

Svara inte på medelanderutor och dyligt utan Browsa er fram till filen, klipp ut den och klistar inden i en annan mapp. Fungerar det så är felmedelandet inte korrekt.

Fungerar det Inte så är felmedelandet troligtvis rätt och ni får söka felet i programcoden. Troligtvis ör filen öppnad för skrivning.....

Det kanske den skall vara men då är det bättre och skriva till en ny fil och bara byta namn när det är klart.

Om skrivning till filen sker via ett inmatningsfält från WWW så lagra bara posterna i minnet tills dess att uppdateringen aktiveras, skapa då ny fil och byt namn....

 

 

Link to comment
Share on other sites

Ok, då ska du få en uppgift av mig :-)

Gå igenom de båda systemen och jämför om det skiljer någonting, även obetydliga saker kan vara viktigt.. Ta en noggrann titt på IIS konfigurationen på de olika burkarna för att ta reda på om konfiggen skiljer sig... Jaja du fattar säkert vart jag vill komma..

I och med att det är en egenutvecklad app så kan jag ju inte svara på vad som kan va felet. Däremot kan jag härifrån säga så mycket att det troligen är fel på någon konfigurationsinställning på burken.. Men det visste du säkert innan :-)

 

Förutsatt att det är exakt samma build av appen på båda maskinuppsättningarna..

 

 

 

 

 

 

[inlägget ändrat 2001-08-17 13:26:30 av gondorlias]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...