Just nu i M3-nätverket
Jump to content

Egen ftp-server hjälp!


lisnn

Recommended Posts

Hej, jag har följt guiden i pcföralla nr 9 oktober 2008 -Egen ftp-server. Jag har gjort precis som det står i guiden, öppnat portarna och det står i Filezilla att servern är online.

Så här står det ut om jag skriver in min Static IP Adress +port 2125 efter. I filezilla har jag skrivit in Brakko! som Welcome Message och som ni ser så kommer de upp först sen händer det inte mer.

220 Brakko!
500 Syntax error, command unrecognized.
500 Syntax error, command unrecognized.
500 Syntax error, command unrecognized.
500 Syntax error, command unrecognized.
500 Syntax error, command unrecognized.
500 Syntax error, command unrecognized.
500 Syntax error, command unrecognized.
500 Syntax error, command unrecognized.
421 Login time exceeded. Closing control connection.

Men när jag vill att andra ska komma in på den, vad är det för ip dom ska använda sig av?

Jag har registretat mig hos dyndns.org och fått ett hostname men jag är inte säker på vilken ip-adress jag ska skriva in för att mina vänner ska komma från den andressen till min ftp-server?

Tack på förhand hoppas någon kan hjälpa!

Link to comment
Share on other sites

lisnn @ 2008-12-03, 13:52
Jag har registretat mig hos dyndns.org och fått ett hostname men jag är inte säker på vilken ip-adress jag ska skriva in för att mina vänner ska komma från den andressen till min ftp-server?


Du har ju fått ett namn av dyndns, låt säga att det är brakko.homeftp.org
Då ska dina vänner skriva det som värdnamn i sin klient

Har du använt standardport 21 behöver inte den anges, har du valt annan port ex. 2125 måste man i klienten ange denna, antingen i särskilt fält för Port eller om detta saknas så skriver man (ex.) brakko.homeftp.org:2125

Sedan måste ju dyndns få veta om du byter ip-adress
Nyttja INTE denna funktion i ev. router utan använd en mjukvara i din dator
HÄR
Link to comment
Share on other sites

lisnn @ 2008-12-03, 13:52
Jag har registretat mig hos dyndns.org och fått ett hostname men jag är inte säker på vilken ip-adress jag ska skriva in för att mina vänner ska komma från den andressen till min ftp-server?


Du har ju fått ett namn av dyndns, låt säga att det är brakko.homeftp.org
Då ska dina vänner skriva det som värdnamn i sin klient

Har du använt standardport 21 behöver inte den anges, har du valt annan port ex. 2125 måste man i klienten ange denna, antingen i särskilt fält för Port eller om detta saknas så skriver man (ex.) brakko.homeftp.org:2125

Sedan måste ju dyndns få veta om du byter ip-adress
Nyttja INTE denna funktion i ev. router utan använd en mjukvara i din dator

HÄR

 

Okej, tack, men när jag jag ska skriva i ipadressen hos dyndns ska jag skriva in min ipadress jag får fram med tex whatismyip.com där?

och måste den person som vill komm in på ftp-servern ha en klient kan man inte gå in via webläsaren, det har iallafall jag gjort på en ftp-server som en kompis hade förr.

Link to comment
Share on other sites

Nu har en kompis testat connecta till ftpn med filezilla Client och för mig ser jag någon som är på väg in men får sedan det här meddelandet:

(not logged in) (ip-nummer)> Connected, sending welcome message...
(not logged in) (ip-nummer)> 220 Brakko!
(not logged in) (ip-nummer)> USER guest
(not logged in) (ip-nummer)> 331 Password required for guest
(not logged in) (ip-nummer)> PASS *********
guest (ip-nummer)> 230 Logged on
guest (ip-nummer)> PWD
guest (ip-nummer)> 257 "/" is current directory.
guest (ip-nummer)> TYPE I
guest (ip-nummer)> 200 Type set to I
guest (ip-nummer)> PASV
guest (ip-nummer)> 227 Entering Passive Mode (ip-nummer)
guest (ip-nummer)> LIST
guest (ip-nummer)> 425 Can't open data connection.
guest (ip-nummer)> CDUP
guest (ip-nummer)> 200 CDUP successful. "/" is current directory.
guest (ip-nummer)> PWD
guest (ip-nummer)> 257 "/" is current directory.
guest (ip-nummer)> PASV
guest (ip-nummer)> 227 Entering Passive Mode (ip-nummer)
guest (ip-nummer)> LIST
guest (ip-nummer)> 425 Can't open data connection.

 

Och hans meddelande blir:

Status: Frånkopplad från servern
Status: Slår upp IP-adressen för exempel.mine.nu
Status: Ansluter till ip-nummer...
Status: Anslutningen etablerad, väntar på välkomstmeddelande...
Svar: 220 Brakko!
Kommando: USER guest
Svar: 331 Password required for guest
Kommando: PASS *********
Svar: 230 Logged on
Status: Ansluten
Status: Hämtar kataloglistning...
Kommando: PWD
Svar: 257 "/" is current

Fel: Misslyckades med att hämta kataloglistning 

 

Vad är felet ?



Link to comment
Share on other sites

Du måste nog också specificera vilken uppsättning portar som passive mode ska tillåtas använda. Port 5000-5100 duger bra. Detta måste du ställa in i FTP servern och sedan även tillåta i brandväggen.

Link to comment
Share on other sites

 

JoAr @ 2008-12-03, 20:08
Du måste nog också specificera vilken uppsättning portar som passive mode ska tillåtas använda. Port 5000-5100 duger bra. Detta måste du ställa in i FTP servern och sedan även tillåta i brandväggen.

 

 

jag har öppnat 2125-2125 i NAT som det stod i guiden men hur vet jag om passive mode tillåts?

edit: jag öppnade 5000-5100 nu i routern och sen i filezilla att de skulle vara 5000-5100 passive mode

Link to comment
Share on other sites

Du måste öppna brandväggen ifall du har den i routern, eller i mjukvaruform i datorn. I datorn kan det vara en tredjepartsprodukt eller Windows inbyggda.

Av loggen du postade så såg det trots allt ut som att passive mode tillåts. Någonstans i Filezilla bör det gå att ställa in vilka portar som används för passive mode. Tolkar jag dig rätt så har du hittat stället där man gör det i Filezilla.

Det är mycket att ställa in om du har både router och brandvägg så det är lika bra att du får lite av den infotext jag hittat om det hela. Om engelska inte är ett problem så står det så här på vanliga frågor och svar i Filezillas forum (källa http://forum.filezilla-project.org/viewtopic.php?f=6&t=368):

I'm behind a firewall and nobody can connect to my server or transfer files / directory listings
You have to configure your firewall to allow incoming connections on the ftp port (default: 21), as well as allowing outgoing connections from the server. FileZilla Server tries to use a port one less than the ftp port for outgoing connections. If that fails it tries to use a port one larger than the ftp port and after that it requests a port from windows. It may be best to allow all outgoing connections from the server.
Further you have to allow a port range for incoming connections for passive mode transfers. You can specify this port range on the "passive mode settings" page in the settings dialog in the server interface. In most cases, a range like 5000-5100 is sufficient.
With certain firewalls, it may be possible that FileZilla can't determinate the external IP address. In this case you have to enter the IP address (or your host name) on the passive mode page in the settings dialog. In case you've a dynamic IP (most dialup users), you can also chose to retrieve the ip address from a website.

I'm behind a router and nobody can connect to my server or transfer files / directory listings
You have to configure your router to forward the ftp port (default: 21) to the server machine.
Further you have to forward a port range for passive mode transfers. You can specify this port range on the "passive mode settings" page in the settings dialog in the server interface. In most cases, a range like 5000-5100 is sufficient.
Most likely, FileZilla can't determinate the external IP address if behind a router. In this case you have to enter the IP address (or your host name) on the passive mode page in the settings dialog. In case you've a dynamic IP (most dialup users), you can also chose to retrieve the ip address from a website.

Link to comment
Share on other sites

Jo, det är din externa ip-adress dyndns vill veta.
Programmet i länken ser till att detta sköts automatiskt.
var 25:e dag blir bra.
Uppdateras det för ofta tolkar dyndns det som spam och stänger kontot.
En webläsare ska gå att använda men det blir, enligt min erfarenhet, mycket segare..

Har inte läst igenom Joars svar men kan klienten köra "ej passive"?
Öppna port 20 också (om du nyttjar port 21)

Var ett tag sedan jag hade ftp-server hemma, har nog testat alla servrar som går..
En hel del trixande med brandvägg mm. i samband med byte av såväl router som säkerhetslösning gjorde att jag la ner detta. Nyttjar filöverföringen i Radmin i stället..

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...