Just nu i M3-nätverket
Jump to content

BAT-fil problem


NatGum

Recommended Posts

Jag ska kopiera en fil från en uppmappad enhet på nätverket med hjälp av en bat-fil.

Om jag kör koden "copy G:\Infoskärm\Output\info.scr c:\test /Y" i kommandotolken så fungerar det utmärkt. Men lägger jag in samma kod i en batfil så fungerar det inte. Om jag ändrar koden till "copy c:\test\info.scr c:\test\kopia /Y" i batfilen så fungerar det även i batfilen.

 

Varför skulle det inte fungera att kopiera från en uppmappad enhet till lokal disk i batfilen?

/NatGum

 

Link to comment
Share on other sites

Jag gissar att du använder notepad för att tillverka bat-filen?

 

Om du gör det, kommer inte åäö att sparas som tecken som kommandotolken förstår. Testa att skapa din bat-fil, gå till kommandoläget och skriv :

 

type minbatfil.bat

 

Då kommer du se att ä är utbytt mot ett skumt tecken.

 

Det enklaste är att använda den textbaserad editorn EDIT i kommandoläget.

 

skriv bara:

 

edit

 

i kommandläget.

 

[inlägget ändrat 2009-01-20 23:06:43 av Mr Andersson]

Link to comment
Share on other sites

Att det var något problem med å ä ö började jag ana men att det var notepads fel hade jag aldrig kommit på.

 

Tack för hjälpen, nu funkar det.

 

 

 

Link to comment
Share on other sites

Det är egentligen inte Notepads fel, utan DOS och Windows använder olika teckentabeller. Sparar man en textfil med ett Windowsprogram så blir det fel tecken när ett DOS-program läser filen (och tvärt om).

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...