Just nu i M3-nätverket
Jump to content

sumprdouct men utesluta en del tal


Rob..

Recommended Posts

Hej,

 

Vill ha en formel i excel för att använda sumproduct men där man vill utesluta alla värden över/under ett visst tal. Ngn som vet hur man gör?

 

/prg

 

 

Link to comment
Share on other sites

Vilken version av Excel? I Excel 2007 finns SUMMA.OMF-formel som är enkel att använda.

 

I tidigare version får man använda PRODUKTSUMMA i stil med

 

=PRODUKTSUMMA((A1:A10)*(A1:A10>5)*(A1:A10<10))

 

Villkorsutrycken evalueras till SANT (=1) eller FALSKT (=0)

 

I Excel 2007 skriver vi istället

=SUMMA.OMF(A1:A10;A1:A10;">5";A1:A10;"<10")

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

 

[inlägget ändrat 2008-09-16 17:05:00 av Monshi]

Link to comment
Share on other sites

PÅ english kan det se ut som

=SUMPRODUCT((A1:A10)*(A1:A10>5)*(A1:A10<10))

 

men givet, oavsett språk är att ALLA värden i A1:A10 är TAL och absolut INTE felvärden eller text. Tomma celler går bra bra.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Jag har två kolumner som ska multipliceras med varandra (sumproduct). Men jag vill utesluta en del tal ur multiplikationen när ett tal är över/under ett visst värde.

 

Kolumn a har värde 10, 20 och 30 kolumn b har värde 2, 5 respektive 7. När b kolumnens värde är över 7 eller under 3 ska den inte vara med i beräkningen.

 

 

Link to comment
Share on other sites

Inte så stor skillnad, bara en kolumn till i formeln:

=SUMPRODUCT((A1:A10)*(B1:B10)*(B1:B10>=3)*(B1:B10<=7))

Dvs avelueras till

(A1*B1*(B1>=3)*(B1<=7)) + (A2...) +....

dvs

(A1*B1*(1/0)* (1/0)) + (A2...)+...

1/0 = 1 eller noll

 

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Sumproduct är bara en formel....

 

Testa. Skriv in den exakt som den är, skriv in värden i A1 til B10 och se vad som händer. Anpassa den sedan till dina förutsättningar.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...