Just nu i M3-nätverket
Jump to content

Firefox laddar bara sidan


Stoffes

Recommended Posts

Hej jag har ett litet problem med Firfox antar jag, eller är det jag som har gjort fel med min hemsida.

 

Det är så att när jag ska till min hemsida, så skriver jag in den och firefox hittar den och laddar den och laddar den och ja ni förstår nog säkert.

För varje gång den laddar kommer det ett frågetecken, ett exempel på länken Http://users.se/roligt

 

Det är så att Internet explorer hittar den och laddar upp sidan utan problem.

 

Det kan också va den "mänsliga" faktorn med.

 

Tackar för all hjälp, vill ni ha mer fakta så säg till

 

Mvh Christoffer

 

Link to comment
Share on other sites

en har kommer den riktiga länken

Hm, jag hade inga problem att komma in på den sidan med Firefox (2.0) och bara en varning i felkonsollen

(Varning: Okänd egenskap ”layer-background-color”. Ignorerad deklaration.

Källkodsfil: http://users.se/foralskad/?

Rad: 0)

 

 

Link to comment
Share on other sites

Okej det är märkigt det

 

För jag har också Firefox 2.0 men jag kommer inte alls åt sidan.

För jag får oxså frågetecken men då pågår det tills jag stoppar sidan och då visar den bara en vit sida utan något.

 

Link to comment
Share on other sites

För det vore roligt och veta vad jag måste göra för att det ska fungerar.

För det fungerar i mellan åt men inte alltid.

 

Är det något jag behöver göra med Firefox eller är det jag som måste reda ut dom problem som finns på hemsidan jag har?

För jag använder Dreamweaver 2004

 

Tackar för hjälp

 

Link to comment
Share on other sites

Firefox är en webbläsare - varför inte posta i forumet webbläsare?

 

Flyttar den dit ivartfall

 

/T

Moderator Webb-allmänt

 

Link to comment
Share on other sites

För det vore roligt och veta vad jag måste göra för att det ska fungerar.

Om jag tittar i javascript-consolen när jag får felet så noterar jag en handfull:

Error: uncaught exception: [Exception... "Component returned failure code: 0x805e000a [nsIDOMLocation.href]"  nsresult: "0x805e000a (<unknown>)"  location: "JS frame :: http://users.se/foralskad/? :: <TOP_LEVEL> :: line 24"  data: no]

Vilket förmodligen är tillräckligt för att den här raden ska spela roll:

window.onerror = Symerror;

 

Testade att ta bort den och då fungerar allt för mig.

 

 

Link to comment
Share on other sites

 

Okej de låter ju bra att det fungerar, men när jag själv ska hitta denna textrad när jag ska redigera koden så hittar jag inte den för den finns inte i den kod som jag redigerar utan den som finns "ute"

 

Så man kan säga att den finns innan <html> tagen finns.

 

Så då undrar jag fhe hur du gick till väga för att ta bort den text rad eller om det var hela:

 

function Symerror()

{

top.location.href = location.href;

}

 

window.onerror = Symerror;

 

var x=top.location.href;

var a=window.location.href;

 

if(window==window.top)

 

Eller bara det du skrev?

 

 

 

Link to comment
Share on other sites

Okej de låter ju bra att det fungerar, men när jag själv ska hitta denna textrad när jag ska redigera koden så hittar jag inte den för den finns inte i den kod som jag redigerar utan den som finns "ute"

Det där får du hoppas att någon som kan dreamweaver kan hjälpa dig med.

Så man kan säga att den finns innan <html> tagen finns.

Du har rätt, vilket i sig är ett fel, inte för att dreamweaver är känd för att leverera korrekt kod men att det skulle vara dreamweaver som gjort det där härket verkar nästan för osannolikt.

 

Så då undrar jag fhe hur du gick till väga för att ta bort den text rad eller om det var hela:

Jag tog bort exakt just bara:

window.onerror = Symerror;

 

Naturligtvis kan du också ta bort all annan javascript i filen, inget av det verkar göra någon som helst nytta.

 

 

 

Link to comment
Share on other sites

Okej det får man hoppas att någon kan,

 

Men i går satt jag med att ta bort koden som orakar prolemet,

Jag sparade den och la ut den via min FTP men med lite magi från internet så var hela kodremsan tillbaka på samma ställe.

 

Jag försökte ta bort tre ggr men lyckades inte för det kom tillbaka lika f*n i alla fall.

 

Ska fortsätta och testa, men det är nog ingen idé när den bara kommer tillbaka eller??

 

 

 

Link to comment
Share on other sites

när du öppnar filen i dreamweaver, öppnar du den i remote eller lokal?

för om det skulle vara så att du öppnar i remote och sedan ändrat och sparar så är det inte säkert att local inte är uppdaterat, och sedan ifall du skulle öppna från local o sedan spara så får du tillbaka det gamla..

 

Link to comment
Share on other sites

Det kan tänkas att jag öppnar den local i dreamweaver.

 

För jag ändrar ju det på min dator där alla filer ligger och sen använder jag Total Commander för att föra över dom filer jag har ändrat.

 

För det där att ändra dom local och remote har jag inte vetat så mycket om, så jag är lite osäker på det.

 

 

 

Link to comment
Share on other sites

Det Codler menar med remote är det du kallar för ute, medan local är det som finns i din egen dator, innan du för över det med FTP.

 

Det verkar som om du har ett webhotell som lägger till en del kod för egna syften. Var ligger sidan? Om det är ett webhotell som sponsras med reklam, kan du kanske flytta sidan nånstans? Jag kan tipsa om Hemsida.net o Brinkster.com. Båda har nog lite reklamspons, men jag har inte sett problem med dem tidigare.

 

Link to comment
Share on other sites

Okej då fattar jag det i alla fall, tackar så mycket.

 

Jo det är ett Webbhotell som är gratis och heter Users.se, och dom har någon "måste" banner.

Det kanske är den som ställer till allt?

 

Ska kolla dom hemsidor som du har angett och se om det löser sig.

 

Tackar för alla svar så här lång i alla fall. :D

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...