Just nu i M3-nätverket
Jump to content

Putta in rätt siffror på rätt ställe...


Glennta

Recommended Posts

Hej,

 

Jag har följade fråga.

 

jag har följande formel:

 

1,2 x arean (m2) x genomsnittlig tjocklek (mm) = antal kg

 

formeln byter ständigt första siffror, 1,2 kan vara 2,5 etc, beroende på vilken produkt jag väljer. Cellen med formel byter alltså sina första siffror beroende på vilken produkt som skall räknas ut.

 

Vad jag vill kunna göra är att användaren skall kunna fylla i sin area och sina mm (Detta sker i två separata celler), dessa inmatningar vill jag att dom skall hamna på rätt ställe och ge mig mitt svar. Problemet är att hämta första siffran i formeln och placera in den i formeln med dom inmatade värderna.

 

Hoppas att jag gjort mig förstådd.

 

Finns det något sätt eller är jag ute på hal is här?

 

/Glenn

 

 

 

 

Link to comment
Share on other sites

Jag tror att jag förstått...

Användaren ska redovisa yta i kvadratmeter och genomsnittlig tjocklek i millimeter, samt välja en produkt. Produkten styr då hur många kilogram/kubikdecimeter som skall användas i formeln.

 

Då får du ha en stödtabell någonstans i kalkylen (i exemplet har jag valt Blad2 A1:B30).

Användaren kan exvis mata in Produkt i A1, Area i B1 och Tjocklek i C1, då blir formeln:

=LETARAD(A1;Blad2!$A$1:$B$30;2)*B1*C1

 

Som letarad är skrivet här krävs det att produkterna är sorterade i bokstavsordning i tabellen.

 

/Pär B

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...