Just nu i M3-nätverket
Jump to content

Konstiga färger vid uppspelning av film


Crochan

Recommended Posts

Plötsligt har ALLA filmer jag har på datorn fått konstiga färger vid uppspelning, oavsett vilken spelare jag använder. Jag vet inte vad som har hänt och har försökt att byta ut codecs och uppdatera drivrutiner för grafikkort o s v men inget hjälper. Det gäller alltså oavsett vilket format det är på filmen.

 

Är det någon som har tips på vad som kan vara fel? Spontant tänkte jag codec men eftersom det blir med alla filmer oavsett vilken codec som körs och det inte hjälper att byta ut den codec som används så vet jag inte vad det kan vara.

 

Mycket tacksam för allt som kan hjälpa.

 

/Crochan

 

[inlägget ändrat 2005-07-02 19:25:55 av Crochan]

Link to comment
Share on other sites

mmh, alla filmer? Plötsligt på alla?

 

Nja, inget rakt tips annat än att du kan testa ffdshow...

 

Ett enkelt snyggt interface med stöd för många codecar.

Sök via google och ladda ned den alpha version du önskar, de brukar fungera bra... Eller ta senaste hos sourceforge.

 

Eller, fast denna spelare gillar inte jag, ladda ned VLC och använd denna. Den har sin egen uppsättning codecar och du behöver inte bekymra dig mera.

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Ja jag vet det är grymt skumt att det kom på alla samtidigt.

ffdshow har jag testat och det löser inte problemet.

 

Testade VLC nu och samma problem uppstår. Så det är kanske inte codec som är problemet. Och jag har ingen aning om vad det kan vara isf.

 

Men tack ändå.

 

 

/Crochan

 

Link to comment
Share on other sites

MMh, nej då vet jag inte..

 

Fast det finns en guide som kanske kan hjälpa dig:

http://www.inmatrix.com/articles/mediasetup3.shtml

 

"A clean start" en bit ned på sidan.

 

Har inte kört denna själv, men den ska ge dig ett rent system du kan börja om på vad gäller mediauppspelning.

 

Men grönt, normlat associerar jag det med DivX5 som försöker spela upp Xvid. Men det borde ffdshow ha fixat. Men - vänta - kanske någon inställning i grafikkortets drivrutiner. Där finns ofta en möjlighet att påverka hur den ytan som media spelas upp i ska se ut (kontrast, färg osv). Ta en titt där först. Och testa i WMP att ställa om att inte nyttja överlägg (Overlay) (diagnos enbart, inte en lösning) eller vice versa.

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Körde guiden från inimatrix, vilket inte hade ngn synbar effekt. Installerade sedan ffdshow, och två andra codecs en för xvid och en för ogg vorbis. Nu kan jag spela upp med riktig bild i mplayer classic men inte i wmp eller i VLC, men i mpclassic så har jag istället inget ljud vilket jag får i de två andra.

 

Dvd film ger fortfarande konstig bild men riktigt ljud.

 

Väljer jag att spela upp utan overlay i WMP så blir allt bra, både ljud och bild fungerar för båda vanliga filmer och DVD. Jag vet inte vad det betyder men kan konstatera att det uppenbarligen fungerar. Problemet återstår ju dock i andra spelare, t ex Power DVD som jag annars använder för uppspelning av DVD filmer.

 

Med risk för att göra mig riktigt dum så undrar jag också vad overlay egentligen är, eller snarare vilken skillnad det ska göra? Ser ingen skillnad mot hur det brukade vara när jag spelar upp film.

 

/Cro

 

Link to comment
Share on other sites

Okej, det var tråkigt att höra att guiden från inmatrix inte löste det. Men att du kan spela upp utan overlay och få gott resultat låter bra.

 

En kort förklaring.

Overlay, överlagring, är en nu ganska gammal teknik för att rita upp filmytor på en skärm. Processorn i datorn är den som sköter om en overlay yta, den styr grafikkortet. Enbart en overlay kan vara aktiv åt gången. (Därav den klassiska svarta rutan på film på den sekundära klonade skärmen om man ej aktiverat helskärmsvideo)

 

Alternativet till överlagring hetter WMR, Windows Media Render, och är nu uppe i version 9 (en del av DirectX8 och framåt tror jag). Denna är mer flexibel, finns olika lägen att rita filytan i. Windowless, renderless och vad de du heter. Nu ligger hela ansvaret, nja större delen ivartfall, för uppspelningen på grafikkortet. Detta ger att äldre grafikkort kanske inte klarar att skapa denna yta. (Overlay klarar nästan alla)

 

Nåja, ta en titt i drivrutinen för ditt grafikkort. Kanske testa att installera om det, uppdatera, drivrutinen. För jag tror att felet ligger där.

 

Inget ljud i MPClassic? Men du har det i WMP? Tja, du saknar kanske den codec som krävs för ljudet, eller ivartfall hittar inte MPClassic denna. Testa att aktivera ffdshows audiocodec(ar)...

 

Lycka till!

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Hittade inställning för hantering av överlagring i grafikkortsdrivrutinerna och nu fungerar allt som förut igen.

 

Stort tack för att du har tagit dig tid och hjälpt mig allt och tagit dig tid att förklara.

 

/Crochan

 

 

Link to comment
Share on other sites

Tackar för det. Och tack för en erfarenhet. Nu vet jag att om någon råkar ut för liknande problem så ska man testa att stänga av overlay...

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...