Just nu i M3-nätverket
Jump to content

installera iis


Suck

Recommended Posts

Jag vill installera iis men jag hittar det inte! det finns inte på xp skivan och inte bland windows komponenter! Kan man ladda ner det nånstans?

PS.har home edition

 

MVH Fredde

 

Link to comment
Share on other sites

Anjuna Moon

XP Home levereras inte med IIS och stödjer det heller inte. Det finns trick för att komma runt detta (som den nyss postade tyska länken visar). Här är några länkar på engelska:

 

Workaround:

http://www.15seconds.com/issue/020118.htm

 

Diskussion kring ovan nämnda lösning:

http://www.iis-resources.com/modules/AMS/article.php?storyid=48

 

Lösningarna stöds absolut inte av MS och är du inte försiktig kommer du att sabba ditt system. Dessutom kan SP2 och kommande updates säkert ställa till med problem.

 

Om du verkligen vill hosta sidor hemma så rekommenderar jag att du antingen uppgraderar till Pro-versionen eller använder dig av Apache eller andra webbservrar som finns att få till HE.

 

Link to comment
Share on other sites

Tack! nu har jag lyckats installera iis 5.0 men jag får inte det an fungera.. vet ni om det finns nån typ nybörjar guide till hur man få allt att funka?

 

Link to comment
Share on other sites

Stefan Eklinder
((SuCk) skrev:

Tack! nu har jag lyckats installera iis 5.0 men jag får inte det an fungera.. vet ni om det finns nån typ nybörjar guide till hur man få allt att funka?

 

Kan det här hjälpa dig:

http://jakarta.apache.org/tomcat/connectors-doc-archive/jk2/jk/iishowto.html

 

---

C:\Eforum\Stefan Eklinder>|

 

"Det finns två företeelser som är oändliga, universum och den mänskliga dumheten. Jag är dock inte säker på den förstnämnda."

 

- Albert Einstein

 

Link to comment
Share on other sites

Anjuna Moon

Vilken typ av sidor skall du använda (vanlig html, asp, php....)

Har du ett fast IPNR?

 

Börja iallafall med följande.

- Gå in i Control Panel->Administrative Tools->Internet Services Manager

- I vänster fönster ser du ett träd. Expandera noden med ditt datornamn på och högerklicka på Default Web Sit och välj Properties.

- Du ska nu börja göra inställningar för din webbplats:

 

--- Web Site ---

- Se till att din ip-adress och port 80 är ifyllda under Web Site Identification

--- Home Directory ---

Välj den mapp på datorn där du vill ha din webbrot. Av kryssrutorna räcker det tillsvidare med att Read är ikryssad.

--- Documents ---

Ta bort det som ligger i rutan och välj det filnamn som du vill skall vara default för din sajt (dvs den fil som körs i en mapp om du inte anger något filnamn i URL:en)

 

Klicka OK och se till att Default Web Site inte är stoppad. Är den det, högerklicka på den och välj Start.

 

Nu ska du kunna titta på din sajt med http://xxx.xxx.xxx.xxx (ditt ipnr)

 

Link to comment
Share on other sites

tack, jag fixade allt du sa men det kommer inte upp nåt ändå!

 

jag har C:\Inetpub\wwwroot som path och i den ligger det en fil med namnet index.asp

jag har prövar dessa adresser:

http://217.211.22.238/

http://217.211.22.238/index.asp

http://localhost

http://localhost/index.asp

http://217.211.22.238:80

 

men det kommer bara upp HTTP 500 internt serverfel

 

Vad menas med det? :/

 

Link to comment
Share on other sites

Anjuna Moon

Det felmeddelande jag får är "Det går inte att hitta den angivna modulen. "

vilket jag inte känner igen.

 

Gå in i Properties igen. Under fliken Home Directory klicka på Configuration (Om den är gråad så klicka först på Create)

 

Under App Debugging markera Send detailed ASP error messages to client.

 

För att själv kunna se detaljerade felmeddelanden i ex. IE, gå in i Internet Options->Advanced och avmarkera "Show friendly HTTP error messages"

 

Link to comment
Share on other sites

Anjuna Moon

Det enda jag kan tänka mig är att tweak-installationen av IIS helt enkelt inte fungerar. Pröva att göra en vanlig enkel html-fil, index.html med en kort text i. Får du samma fel då också?

 

Som sagt finns inga garantier för att det här kommer att fungera. Workarounden skrevs innan ex. SP2 och för den delen en drös andra patchar till XP, så det är möjligt att det helt enkelt inte fungerar längre.

 

Link to comment
Share on other sites

jag gjorde en index.htm med koden:

 

<html>

hej

</html>

 

men det blev även där modul sak...

jag har inte installerat sp2 eller så.. jag är lite anti sp2 efter att det inte tillät mina spel mm att komma ut på nätet:D hart inte laddat ner ett dugg från update.

 

MVH Fredde

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...