Just nu i M3-nätverket
Jump to content

Vem har rätt?


.sun

Recommended Posts

Som kund hos Nordea har jag länge förvånats över internetbankens favicon. Sen en tid tillbaka har nordea.se en miniatyr av deras logga som favicon. Helt i sin ordning. Men när jag loggat in på banken så byts denna ut mot Netscapes logga. Detta gäller alltså oavsett vilken webbläsare jag testar med. Till slut "tog jag mod till mig" och mailade supporten för att fråga varför.

 

Deras svar låter dock väldigt undflyende:

"Det låter som det är något associationsproblem i din dator.

Inget stort problem i sig, men vill du komma tillrätta med det så vänder

du du dig till din support där du köpte datorn eller till microsoft."

 

Nu är det ju så här att jag jobbar dagligen med datorer, i huvudsak som webbutvecklare, och vill väl lite grann påstå att jag kan det här. Självklart har jag testat på flera datorer och i flera webbläsare med samma resultat. Men innan jag "läxar upp" supporten tänkte jag höra med eforumare. Vad ser du för symbol när du surfar till nedanstående ikon?

 

https://gfs.nb.se/favicon.ico

 

(jämför även med http://gfs.nb.se/favicon.ico - dvs utan SSL)

 

Hur många ser Netscapes logga på den första länken, och Nordeas på den andra?

 

Link to comment
Share on other sites

Vid första anblick tycker jag att det måste bero på att deras server är felkonfigurerad. Content-type: text/plain är ju knappast rätt.

 

Vid nästa titt ser jag att den som har text/plain faktiskt är den som fungerar(!)

 

burken:~>curl -I https://gfs.nb.se/favicon.ico
HTTP/1.1 200 OK
Server: Netscape-Enterprise/4.1
Date: Tue, 08 Mar 2005 19:19:39 GMT
Content-type: image/x-icon
Content-length: 1406

burken:~>curl -I http://gfs.nb.se/favicon.ico
HTTP/1.1 200 OK
Server: Netscape-Enterprise/4.1
Date: Tue, 08 Mar 2005 19:19:59 GMT
Content-type: text/plain
Etag: "b893ca08-5-536-422ce2fc"
Last-modified: Mon, 07 Mar 2005 23:25:48 GMT
Content-length: 1334
Accept-ranges: bytes

 

Tittar man emellertid på filerna så ser man emellertid att den som skickas som text/plain är en korrekt fil och den som skickas som image/x-icon är något helt annat. Jag har inte listat ut formatet än, någon icon är det i vart fall inte.

 

Edit: Jag har också stört mig på det men aldrig orkat bry mig... Har du kontakt med dem är det helt ok att skicka vidare ovanstående.

[inlägget ändrat 2005-03-08 20:29:58 av fhe]

Link to comment
Share on other sites

HTTPS roten har troligen en annan favicon.ico än HTTP roten. Föreslå en enkel cun'n'paste av favicon.ico till HTTPS roten så borde det vara fixat. ;)

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...