Just nu i M3-nätverket
Jump to content

Problem med xf86config i Debian


Prophecy

Recommended Posts

Jag har precis installerat Debian 3.0 (har inte kört Linux innan) och försöker få igång X. Jag kör xf86config som jag antar att man måste göra, och efter mina inställningar så skriver den filen och allt är frid och fröjd. När jag sedan skall starta X med startx så blinkar skärmen till varpå jag får följande meddelande:

 

fatal server error:

no screens found

 

Jag måste säga att jag inte är speciellt imponerad hittills. Någon som vet vad det kan vara för problem??

 

/Johan

 

Link to comment
Share on other sites

Se till att köra apt-get install discover mdetect read-edid för att få autodetektering av hårdvara, och sedan dpkg-reconfigure xserver-xfree86.

 

Förövrigt skulle jag rekommenderat att du installerar den nyare versionen av Debian (sarge) istället, alternativt Ubuntu, som är baserat på Debian. Både sarge och Ubuntu använder det nya installtionsprogrammet, som är betydligt smidigare än det gamla i Woody (plus att all mjukvara är betydligt nyare). All mjukvara i woody är 2 1/2 år gammalt.

 

Link to comment
Share on other sites

okej, testar det.

 

Nyare version? Jag trodde att detta var den senaste, det verkade som på deras webbplats. Vilken version skall jag ha och vart laddar jag ner den? Vill gärna ha en .iso-fil

 

/Johan

 

 

EDIT:

Nu startar X, men det fungerar inte alls som det ska. Det hänger sig efter att jag har loggat in.. Vart kan jag hitta Sarge? Jag hittade något på sunets ftp-arkiv, men jag förstod inte vad det var för filer riktigt. Det fanns nån netboot-mapp och liknande också, även det var konstiga filer. =)

 

 

[inlägget ändrat 2005-01-17 00:44:17 av Prophecy]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...