Just nu i M3-nätverket
Jump to content

jdk och icq


ns

Recommended Posts

Som nybörjare i Linux ville jag installera ICQ. Jag gick till icq.com och såg att det var javaversionen som gällde och att man måste ha jdk installerat.

Så jag gick till sun.com och tog hem senaste jdk1.2.2 och installerade. Så långt allt väl.

 

Sen skulle jag installera icq. Då behövde jag ändra ett par sökvägar i installationsfilen bland annat till java. Den sökvägen som föreslogs av icq pekade på en länk och när jag installerade fick jag felmeddelandet:

java executable not found

 

Nån som vet hur man ska göra?

Link to comment
Share on other sites

Roger Svensson

Det bästa alternativet är att du lägger ner java icq. Det finns kloner skrivna av privatpersoner som är långt bättre.

Om du kollar på [http://www.licq.org] så hittar du en klon med grafiskt gränssnitt. Den kräver dock

att du laddar hem QT 2.0 från [http://www.troll.no] (glöm inte konfigurera med --with-gif). Sen är det bara att kompilera licq och köra på.

Link to comment
Share on other sites

jag tycker att zicq är den bästa icq klonen av alla för den e snabbast lite synd att den är för bashen bara om du vil l tästa den så gå till

www.freshmeat.net och sök på zicq

Link to comment
Share on other sites

  • 2 weeks later...

Licq med GTK+ plugin är nog den kombinationen som är bäst. Dock har de en del kvar att göra på GTK+-pluginnet....

Link to comment
Share on other sites

Roger Svensson

Precis, dom har en del att göra. Så tills det är gjort så rekommenderas QT-gränssnittet eftersom det stöder alla programmets funktioner =)

Link to comment
Share on other sites

Ja om det bara gick att få det att fungera.... har inte lyckats få det att kompilera på min burk iaf....

Link to comment
Share on other sites

Per Larsson

Är du säker på att du lagt in QT 2.1 (vilket krävs för att QT-pluginen ska kompilera felfritt)?

 

/per

Link to comment
Share on other sites

  • 2 weeks later...

Ja det blir nåt fel med att den inte hittar nån funktion i qt-libsen...en version funkade dock som root men de flesta kompilerar inte ens trots rätt libbar...

Link to comment
Share on other sites

Per Larsson

Då hittar den fel QT-libs. Ladda ner QT 2.1.1, kompilera det och lägg det i /usr/local/qt, "berätta" sen för configure-scriptet i Licq-QTplugin-katalogen var dte ligger så ska du se att det fungerar.

 

/per

Link to comment
Share on other sites

Roger Svensson

För att ens få qt att kompilera _måste_ det ligga i /usr/local/qt.

Lättaste sättet är att tanka senaste QT,

cd /usr/local/

tar xfz /path/till/qt.tar.gz

ln -s /usr/local/qt-<version> /usr/local/qt

 

På det viset kan du spara din gamla installation av qt tills du vet att den nya fungerar. Om det skiter sig är det bara att flytta tillbaka sym-länken till den gamla installationen.

 

Obs! det här sättet är inte att rekommendera om du kör KDE som beror på qt-1.44 eftersom du då antagligen kommer att få en mängd trevliga fel. ;)

 

När du byggt qt (glöm inte -gif till configure) så är det _bara _att bygga licq.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...