Just nu i M3-nätverket
Jump to content

Vill någon hjälpa en nybörjare?


gutenius

Recommended Posts

Hej!

Sitter med en färdig??? hemsida gjord i FP (ja, jag vet men det var det enklaste för en okunnig...). Siten ser helt ok ut och funkar i "Preview in browser men när jag publicerar blir inte mycket rätt...Alla knappar utom en framträder som X och de sidor knapparna är länkade till saknas.

Ju längre jag håller på, desto större blir röran...

Har laddat upp alla sidor och bilder på servern efter vad jag kan se men vet inte vad jag gör för fel i övrigt!

 

Någon som har tid att titta?

http://hem.bredband.net/anngut/

 

Ämnet på sidan: Kattuppfödning, känns lite fel på det här forumet men jag hoppas ni har överseende ;-).

 

Mvh

 

Link to comment
Share on other sites

Tittar jag i koden för "länk-framen", så ser jag att den enda skillnaden mellan den länk/bild som funkar och de som inte funkar är att det finns en radbrytning efter <a href="attkopakatt.htm"> (länken som funkar)...

Jag vet inte om det är nån bugg nånstans, eller så, men prova o lägg radbrytningar efter varje <a>...

 

Något i stil med detta:

 

<p><a href="Hanar.htm">
<img border="0" src="buttonHanaron.gif" width="130" height="50"></a></p>
<p><a href="Honor.htm">
<img border="0" src="buttonHonoron.gif" width="130" height="50"></a></p>
<p><a href="Kattungar.htm">
<img border="0" src="buttonKattungaron.gif" width="130" height="50"></a></p>
<p><a href="Memory.htm">
<img border="0" src="buttonMinneon.gif" width="130" height="50"></a></p>
<p><a href="attkopakatt.htm">
<img border="0" src="buttonattkopakatton.gif" width="130" height="50"></a></p>
<p><img border="0" src="Sommarkatt.jpg" width="105" height="42"></p>

 

Vet inte om detta funkar, men du kan ju prova :)

 

/Eminos

 

Link to comment
Share on other sites

En sak jag såg när jag satt och kollade i koden är att du har target="_top" på menyramen (den som heter contents). Ska det vara så? Har du inte tänkt att sidorna ska öppnas i högra ramen? I så fall behöver den ändras...

 

Det kanske redan är precis som du vill att det ska vara, i så fall kan du bortse från det här inlägget...det var bara en fundering från mig =)

 

 

~ Stefan ~

 

"Ingen kan hjälpa alla men alla kan hjälpa någon."

 

Link to comment
Share on other sites

Hej & Tack för fantastiskt snabbt svar!

 

Nu har jag lagt in radbrytningen tror jag och publicerat på nytt men ingen skillnad.

Hade från början döpt alla sidor och bilder med inledande versal, det säger ju en del om mina kunskaper...och upptäckte nu att de ändringar jag gjort på filnamnen i Folders inte följt med i HTML-koden. Har även åtgärdat detta utan framgång. Inget annat du tycker ser konstigt ut?

Eller har jag inte fått radbrytningen rätt i alla fall?

 

Tack igen!

 

Ann-Sofie

 

Link to comment
Share on other sites

Hej!

Fler än jag vakna mitt i natten :-)!

 

Blir det som du skriver så har jag lyckats med något i alla fall!!!!

Vill öppna sidorna utan ramar (har lagt samma länkar längst ner på varje sida) beroende på att de innehåller en hel del bilder och hugande kattungeköpare slipper förhoppningsvis sitta och scrolla i sidled, eller blir det konstigt att jag gjort så här?

 

Tack ändå!

 

Den enda sidan som funkar (och inte är helt klar) innehåller inga bilder, det gör alla de andra, kan det vara det som ställer till det tror ni?

 

Mvh

Ann-Sofie

 

Återvände just till sidan och helt plötsligt finns knapparna där och länkarna fungerar, det var nog radbrytningen i alla fall. TACK!

Får leta vidare i HTML-koden för att se om det är mina byten från inledande versal till gemen som ställt till det!

 

Underbart!

[inlägget ändrat 2004-08-14 01:40:13 av gutenius]

Link to comment
Share on other sites

Vill öppna sidorna utan ramar (har lagt samma länkar längst ner på varje sida) beroende på att de innehåller en hel del bilder och hugande kattungeköpare slipper förhoppningsvis sitta och scrolla i sidled, eller blir det konstigt att jag gjort så här?

Tanken med att använda ramar är väl att man har menyn i en ram och en ram där man öppnar sidorna vid klick i menyn. Naturligtvis kan man ha fler ramar utöver detta, som i ditt fall toppramen.

 

Jag tycker du bör fundera över något av följande alternativ:

 

1. Ta bort ramsetet och slå ihop de tre sidorna som först visas till en sida. Om du ändå öppnar alla sidor med "_top" så känns ramarna helt onödiga.

 

2. Göra undersidorna (de som öppnas via menyn) lite smalare och öppna dessa i ramen som heter "main". För att göra dem smalare kan du t.ex. flytta om några bilder så att det inte ligger flera på bredden.

 

Naturligtvis ska du göra som du själv tycker, det här är bara förslag =)

 

[edit] Glömde en sak...

 

 

~ Stefan ~

 

"Ingen kan hjälpa alla men alla kan hjälpa någon."

 

[inlägget ändrat 2004-08-14 02:15:36 av Stefan K]

Link to comment
Share on other sites

Hej igen!

 

Tack för dina tips, du har rätt i att det ser konstigt ut!

Jag har varit så koncentrerad på att överhuvudtaget så sidan att fungera tills imorgon att det andra fått stå tillbaka....

 

Nu har jag bara tre bilder som jag inte får ordning på, resten verkar funka.

Ögonen går i kors och jag hittar inte felet, känns som om jag försökt allt!

 

Har du eller nåon annan lust att ta en titt på:

http://hem.bredband.net/anngut/kattungar.htm så vore jag oerhört tacksam.

 

Skall titta närmare på dina tips imorgon, tack igen!

 

Ann-Sofie

 

 

Link to comment
Share on other sites

Nu har jag bara tre bilder som jag inte får ordning på, resten verkar funka.

Ögonen går i kors och jag hittar inte felet, känns som om jag försökt allt!

 

Har du eller nåon annan lust att ta en titt på:

http://hem.bredband.net/anngut/kattungar.htm så vore jag oerhört tacksam.

Har du löst problemet med bilderna? Ser inget som är fel...

 

 

~ Stefan ~

 

"Ingen kan hjälpa alla men alla kan hjälpa någon."

 

Link to comment
Share on other sites

Hej igen!

 

Ja, det är löst. Tydligen hade ändringen jag gjort i bildernas namn inte hängt mer vid publiceringen och saknades alltså på servern.

 

Bra, att allt ser OK ut, jag har inte haft möjlighet att titta på sidan på någon annan dator!

 

Mvh

Ann-Sofie

 

Link to comment
Share on other sites

Tydligen hade ändringen jag gjort i bildernas namn inte hängt mer vid publiceringen och saknades alltså på servern.

Oftast är "problemen" så enkla. Man får lov o titta på filerna som ligger på servern en extra gång, när sånt händer.

 

Bra, att allt ser OK ut, jag har inte haft möjlighet att titta på sidan på någon annan dator!

Jag tycker sidan ser helt ok ut (skrev jag det tidigare tro, eller tänkte jag bara?). Som nån redan påpekat så förlorar frames deras mening lite grann, när man öppnar länkarna med "_top", men det är inte så farligt tycker jag. Sidan ser som sagt bra ut, enkel och funktionell.

 

/Eminos

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...