Just nu i M3-nätverket
Gå till innehåll

Är IIS buggig eller e jag knäpp


Rickard2

Rekommendera Poster

Jag har alltid använt Chiliasp istället för IIS och och asp.... Obs .. har inte haft ett enda problem med asp förrän jag började med att använda IIS.

 

Min fråga är .. förmodligen helt knäpp.. Om jag ha en webbmapp med en viss inställning i IIS'n, och en annan med samma inställningen, den ena visas men inte den andra????

 

För att förenkla vad jag menar:

 

ex:

http://localhost/web'>http://localhost/web

http://locahost/web1

 

Dessa har samma inställning i IIS'n men bara

http://localhost/web visas.. Den andra får ett felmeddelande:

HTTP 401.3 - Åtkomst nekades av ACL för resursen.

Låt mig nämna att den innehåller bara enkel html... Inte asp alltså.

 

För mig låter det som jag skall behöva logga in för att se sidan...

 

Har en annan webbsida..

 

www.skalhuset.com...

 

Ibland visas alla bilder som de skall , hmm ibland inte ..

 

 

Jag bara undrar är IIS ett lotteri..

 

 

Länk till inlägg
Dela på andra webbplatser

Kolla följande två saker för den mapp som krånglar:

 

1. Gå in i IIS Manager och ta egenskaper på mappen ifråga. Gå till fliken Directory Security och kolla att Anonymous access är förbockad.

 

2. Leta upp mappen ifråga i Windows och ta egenskaper på den. På fliken Security ska du se till att IUSR_<servernamn> eller Everyone har Read-behörighet i mappen.

 

 

 

Länk till inlägg
Dela på andra webbplatser

Hej... Tack för att du svarade..

 

Tja.. Jag har kollat dessa altenativ.. Men jag har inte lyckats bättre.. Det enda alternativet som fungerade var att jag helt enkelt kopierade in mappen uder root.. Då fungerade den...

 

Alla mina mappar(web) har samma rättigheter..

Det är det jag inte fattar.. Hur kan det då skilja på rättiheterna!

 

Fattar brö!!

Tror att det är min IIS som e buggig.. Trots flera omistallationer av IIS'n ... Funkar det inte..

 

Ett alternativ kan ju vara att min iställningar i XP kan vara fel... Men leta efter det.. The needle in the...

Hjälp....

 

Gillar java.............

 

Länk till inlägg
Dela på andra webbplatser
  • 1 year later...

nr.1 är det XP du använder??

nr.2 har du installerat alla komponenter inom Internet Information Services?

nr.3 har du rätt identitet på adressen??

nr.4 har du rätt "startfil"? Default.htm default.asp index.htm default.aspx

 

fråga gärna om du inte förstår

 

MVH Peter

--Det går perfekt att ha server i en vanlig dator!!--

 

Länk till inlägg
Dela på andra webbplatser

Hej!

Jag förstår precis vad du frågar efter, är ganska bevandrad inom IIS. På alla frågor är svaret JA.

 

Det är konstigt, för jag kan komma åt tidigare sparade hemsidor i wwwroot, men nu när jag lägger dit test.htm och försöker komma åt den kommer "HTTP 401.3 - Åtkomst nekades av ACL för resursen." upp som felmeddelande. Jag har försökt fippla med rättigheter hit och dit utan resultat..

Detta har hänt tidigare när jag ibland zippat upp hela script-paket direkt i en mapp i wwwroot och direkt försökt komma åt det.

 

Tack för hjälp!

 

Länk till inlägg
Dela på andra webbplatser

Med största sannolikhet problem med säkerhetsinställningarna för filerna i fråga. Tänk på att om du ex packar upp en zip-fil som du har på skrivbordet och *flyttar* innehållet till C:\Inetpub\wwwroot så kommer filerna ha kvar sina ursprungliga säkerhetsinställningar! Det innebär med största sannolikhet att bara du kan läsa filerna, och inte webservern. Rätt förfarande är att *kopiera* innehållet så att nya filerna ärver rättigheter från wwwroot-katalogen. Se till att propagera säkerhetsinställningarna från wwwroot-katalogen nedåt så borde det med stor sannolikhet lösa sig.

 

// Johan

 

Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu


×
×
  • Skapa nytt...