Just nu i M3-nätverket
Jump to content

Var är php.ini?


Birk1112

Recommended Posts

Hej!

 

Jag kör register_globals: off men skulle behöva ändra på max_execution_time som tydligen finns i php.ini.

 

Problemet är att jag inte hittar php.ini för att kunna ändra detta värde. Jag har testat "find / -name php.ini men hittar inget.

 

Jag kör PHP Version 4.3.1

 

 

Hjälp!

 

Link to comment
Share on other sites

Jag postade visst i fel forum.

 

I manualen på www.php.net står det:

 

max_execution_time integer

...

You can not change this setting with ini_set() when running in safe mode. The only workaround is to turn off safe mode or by changing the time limit in the php.ini.

 

 

Hur ska jag kunna ändra time limit när jag inte ens hittar php.ini?

 

Link to comment
Share on other sites

När jag kör phpinfo() så står det att den letar efter php.ini i /etc-katalogen.

 

Om jag testar att skapa php.ini i /etc-katalogen så vägrar apache att starta.

 

Link to comment
Share on other sites

Den skall ligga där /etc/php.ini , finns den inte där så får du skapa den.

Se om du har exempelfiler någonstans (med find), de heter php.ini-dist och/eller php.ini-recommended

 

Kopiera den filen som verkar fungera bäst till /etc och byt namn på den till php.ini

 

 

0x--x0

 

[inlägget ändrat 2003-11-02 10:30:58 av 0x2A]

Link to comment
Share on other sites

japp, jag kopierade php.ini-recommended till /etc-biblioteket med namnet php.ini men nu får jag istället problem med mysql.

 

Fatal error: Call to undefined function: mysql_connect()

 

Link to comment
Share on other sites

Mysql funkade innan jag kopierade php.ini-filen till etc-katalogen, nu funkar det inte alls.

 

Efter att ha googlat lite så läser jag på phpportalen om problemet (Call to undefined function: mysql_connect()):

Du har inte mysql-stöd installerat.

 

Det måste jag väl ha eftersom det funkade innan php.ini kopierades över?

 

Link to comment
Share on other sites

Det måste jag väl ha eftersom det funkade innan php.ini kopierades över?

Du hade ju ingen php.ini och då körs väl php med defaulta värden. Du få gå igenom php.ini och titta vad den säger om mysql.

Det kanske bara är någon sökväg som är lite fel.

 

Vad säger phpinfo om mysql? Gjorde den förut?

 

Vad kör du för linux, apache?

 

 

0x--x0

 

[inlägget ändrat 2003-11-02 18:15:34 av 0x2A]

Link to comment
Share on other sites

  • 5 years later...

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...