Just nu i M3-nätverket
Jump to content

nätverksinställningar - redhat


Patrik Corneliusson

Recommended Posts

Patrik Corneliusson

Hej!

 

Jag har kört med dynamisk ip under ett par år. Jag har nu flyttat min server och får därför statisk ip.

Det trodde jag skulle vara en baggis att lägga in, men det fungerar inte.

 

När jag pingar mitt ipnummer så går det bra, men om jag försöker pinga GW:n så får jag "sendto: operation not permitted". Likaså om jag försöker pinga något annat ip i världen.

När jag kör ifconfig verkar det ok. Jag har min ip, jag har min nätmask och broadcast. Likaså står det typ "UP BROADCAST RUNNING PROMISC MULTICAST" (minns inte exakt).

Jag har försökt köra "route add default gw IPNUMMER dev eth0" och då läggs den till i listan "arp -a". Men det står ett frågetecken som första tecken på raden. När jag kör "arp -e" ser det dock helt normalt ut.

 

Jag har provat att köra netconfig ett flertal gånger men det löser sig inte.

 

Någon som kan ge mig några tips?

 

Link to comment
Share on other sites

Patrik Corneliusson

Destination Gateway Genmask IFace

217.73.102.0 0.0.0.0 255.255.255.0 eth0

127.0.0.0 0.0.0.0 255.0.0.0 lo

0.0.0.0 217.73.102.1 0.0.0.0 eth0

 

Link to comment
Share on other sites

Patrik Corneliusson

Det visade sig vara ett konfigurationsfel av brandväggen.

 

Den var öppen för DHCP-trafik men stängd för DNS-klient. Det verkar som att DHCP-trafiksbrandväggen bara vara giltlig när man använde just DHCP. Vad vet jag? Jag öppnade hur som helst DNS-klient och stängde DHCP-trafiken, så fungerade det utmärkt.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...