Just nu i M3-nätverket
Jump to content

asp.net-->mysql


johan_gr

Recommended Posts

Vill kunna komma åt min mysql database....använder ByteFX för att komma åt...

Vad e det för fel man gör...? Skriver i VB.net en asp.net applikation...skriver allt i visual studio.net.

 

 

Dim mycn As New MySqlConnection()

 

mycn.ConnectionString = "Data Source=localhost;" & _

"Database=dbtest;" & _

"User ID=root;" & _

"Password=;" & _

"Command Logging=false"

 

mycn.ConnectionString = "Server=localhost;Database=dbPrelaq;User ID=root;Password=;"

 

Dim mycmd As New MySqlCommand()

 

mycmd.Connection = mycmd

 

mycmd.CommandText = "INSERT INTO m_inst (fltHastighet, fltArtikel)" & _

" VALUES ('" & tbHast.Text & "', '" & tbArtikel.Text & "')"

 

ListBox1.Items.Add(mycmd.CommandText)

mycmd.CommandType = CommandType.Text

mycmd.Connection.Open()

mycmd.ExecuteNonQuery()

mycmd.Connection.Close()

 

 

 

 

File or assembly name System, or one of its dependencies, was not found.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

 

Exception Details: System.IO.FileNotFoundException: File or assembly name System, or one of its dependencies, was not found.

 

 

Link to comment
Share on other sites

Nu kan jag ingenting om MySQL men du deklarerar ju connectionstring två gånger? Det kan inte vara det som är problemet?

 

/JANspeed

 

Link to comment
Share on other sites

Denna del ska inte vara med....kom med utav misstag...fungerar inte ändå..

 

mycn.ConnectionString = "Server=localhost;Database=dbPrelaq;User ID=root;Password=;"

 

 

Link to comment
Share on other sites

Eftersom den inte hittar System assembly (som är basklassen) så är det antagligen något ganska fundamentalt fel. Det kanske kan vara så att du har en äldre .NET Framework version installerat än den VS.NET använder och på så sätt så länkar de olika. Kan kanske vara nån inställning i VS.NET oxå. Kolla så att du verkligen har dina assemblies laddade.

 

Jag tror inte din kod har något att göra med just det felmeddelandet.

 

Däremot så har du en annan tokighet i koden. Du sätter

mycmd.Connection = mycmd 

men egentligen så borde det väl vara

mycmd.Connection = mycn

 

 

_________

-- ante --

 

 

 

 

[inlägget ändrat 2003-07-08 14:07:09 av anteD]

[inlägget ändrat 2003-07-08 14:10:40 av anteD]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...