Just nu i M3-nätverket
Jump to content

W2K+DNS


Fnul

Recommended Posts

Hej !

Jag har uppgraderat min NT4 server till W2k och en sak slog mig...

Jag har telia ADSL och en simpel hårdvarurouter som ger IP adresser till nätet. Jag har haft telias DNS 10.0.0.1/2 i IP konfig på servern (ingen på NT4 servern) med fast Ip (192.168.0.x).

Nu när jag har installerat DNS på w2kservern så måste jag ju installera DNS på den, krav för AD. Allt verkar funka fint på nätverket trots att jag fortfarande har telias DNS server i inställningarna på nätverkskortet men är detta som det skall vara ??

 

Någon som är "kung" på W2K server som kan ge mig ett tips ?

 

Mvh

 

The Fnul

 

Link to comment
Share on other sites

Nu gissar jag !

Det är inte så att du har NetBIOS igång ?!

Då fungerar det väl ändå ?!

 

Jag är inte riktigt hemma på det här, så jag kan ha HELT fel !

 

 

Link to comment
Share on other sites

Hej !

Nej, jag har inte netbios igång, endast TCP/IP. DNS verkar funka... har kallat domänen/AD typ "hemma.local" och burkarna tilldelas enl detta. Iof så hade jag WINS igång på NT4 servern när jag uppgraderade ?

 

Som sagt, det funkar men jag vill veta om jag har gjort rätt ! Minst halva vitsen för mig att pilla igång en W2K server är ju att lära mig den !

 

Mvh

 

The Fnul

 

Link to comment
Share on other sites

Av någon anledning så kräver AD tydligen att W2k servern kör DNS server, eller att man har en fast publik IP på W2k burken. Problemet är att din W2k server kommer att försöka uppdatera telias DNS servers (vilket din burk naturligtvis inte har tillåtelse att göra). Iom att du kör detta över en ADSL lina så är det inget problem, förutom att din maskin kommer att förekomma ganska frekvent i telias loggar för misslyckade dns uppdateringar.

I ISDN sammanhang har liknande upplägg lett till stora telefonkostnader för många, iom de ständiga försöken att uppdatera ISPs DNS.

 

Finns det lösningar så att man kan köra AD lokalt, utan att vare sig ha fast IP eller tillgång att uppdatera ISPs DNS?

 

==Coleburn==

 

--------------------

"It takes a lot of knowledge to

really mess something up!"

 

Link to comment
Share on other sites

Välkommen till aftonens avsnitt av "Sladda i lösgruset" !!

Testade med att ta bort DNS inställningarna (lämna fälten tomma) och DNS associerades automatiskt till "localhost". Och voilá, det hela funkar !

 

Jag antydde ovan att "allt fungerar" men när jag skulle peta in ytterligare en server som domänkontrollant så slog det stopp pg av att det inte fanns någon fungerande DNS i AD. Med ovanstående manöver så slutade servern att gnälla. Tja, om någon serverguru skulle ha vänligheten att lösa detta får ni gärna göra mig uppmärksam på vad mer jag ev har missat ;-)

 

Mvh

 

The Fnul

 

Link to comment
Share on other sites

Hej !

Cache only ? Och den vetgirige undrar snabbt:

-Varför det ? Eller kanske snarare: Vad löser man med det ?

 

Mvh

 

The Fnul

 

Link to comment
Share on other sites

Du bör göra din DNS-server till en forward-dns. Du raderar helt enkelt [.] i dns-konfigurationen. Sedan sätter du forwards i dnsen att peka mot telias DNS.

 

 

Sedan anger du din servers ip-adress i nätverksinställningarna i primary dns. Detsamma gör du på alla klienter.

 

Micke

 

[inlägget ändrat 2003-04-14 20:59:17 av Micke28]

Link to comment
Share on other sites

Hej !

Punkt ?? I DNS konfig så har jag min server, under den mitt forward lookup zone (hemma.local) och nästa trappsteg nedåt så blir det en massa mer, men bara mina lokala IP nummer och servernamn.

 

Jag hade min server angiven i dess egen IP på kortet som DNS och då funkade det inte, se ovan. Och jag anger inga IP inställningar i klienterna, där är allt servertilldelat och förövrigt den andra halvan av vitsen med mitt nätverk, att okunnigt folk (dvs okunnigare än mig, hör och häpna) skall kunna klämma in en bärbar i nätet och logga på utan mixtrande med inställningar.

 

Något jag undrar annars är att under "properties" för servern i trädet finns det en flik som heter "forvarders". Det känns som om man kulle kunna klämma in telias 10.0.0.1/2 där - men frågan är om den känslan i så fall kommer att utbytas mot ångest och panik ??

 

Mvh

 

The Fnul

 

Link to comment
Share on other sites

Du har redan satt upp en forward-dns så nope, ingen panik eller ångest inte. Ange telias dns-ip-adress i forwarders och allt kommer att fungera såå bra.

 

Micke

 

Link to comment
Share on other sites

Oki, klämma in telias DNS som jag antydde ovan så är dte hela som det skall ?

 

Kollade "advanced" och fick upp "cached lookups" och där fanns det minsann en punkt och mååånga adresser angivna ! Nåja, allt går som tåget just nu och med dessa kompletteringar så kanske det hela blir ännu bättre ??

 

Tack, återkom gärna om det är ngt mer !

 

Mvh

 

The Fnul

 

Link to comment
Share on other sites

jepp går som tåget då! Och du kan surfa från servern dessutom :)

 

Micke

 

[inlägget ändrat 2003-04-14 22:22:49 av Micke28]

Link to comment
Share on other sites

Tja, än så länge funkar det - peppar, peppar ! Surfa från servern ? Vadå syndes det ? *S* Bröt en liten egen regel där !

 

Poäng levererad !

 

El Fnulo Surfo !

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...