Just nu i M3-nätverket
Jump to content

Elände med sendmail


Murtin

Recommended Posts

Jag har försökt sätta upp sendmail och fetchmail för att kunna skicka och hämta post under RH6.1.

Det senare har lyckats, det förra har inte lyckats helt. Om jag använder en annan uppkoppling än just Utfors (på vars server också min post ligger) kan jag inte skicka någon post, utan får meddelandet att "relay not permitted". Hur konfigurerar jag så att jag kan skicka post oberoende av vilken ISP jag använder?

 

Fråga 2: Hur gör man för att lägga utgående meddelanden på kö, så att de inte behöver skickas direkt, utan först när modemet är uppkopplat?

Link to comment
Share on other sites

Använd linuxconf. I avsnittet om sendmail ska det finnas något som heter "Spammer controll" eller något liknande. Där väljer du "Relay by name" och fyller i 'localhost' eller vilka som ska få skicka mail från din server. Sedan väljer du 'Generate sendmail.cf' och det ska vara klart.

 

Mail du skickar ut med din sendmail hamnar i '/var/spool/mqueue'. Är du inte uppkopplad ligger de kvar där...

 

/R

Link to comment
Share on other sites

Hej igen och hjärtligt tack för svaret.

 

Först och främst, angående mitt problem nr 2: Problemet var att min utgående post inte alls lades i nån kö, utan försökte skicka sig omedelbums, vilket naturligtvis inte gick då jag var nedkopplad. Detta berodde dock inte på sendmail, utan på en miss jag gjort när jag konfigurerade Pine; jag hade instruerat Pine att skicka all post direkt med SMTP. Sendmail fick därför aldrig nån chans att ta hand om posten. Ett något mer skärpt manualläsande löste detta självförvållade problem.

 

Vad gäller problem nr 1, så tror jag inte att problemet hade att göra med sendmail där heller. Att jag kunde skicka post om jag använde Utfors som ISP, samt att jag nu, när jag använder en annan server för utgående post, kan skicka post oberoende av vilken ISP jag för tillfället är uppkopplad mot, antyder att sendmail.cf och alla andra vitala filer var och är i sin ordning. Snarare verkar det vara Utfors som instruerat sin mailserver att inte skicka vidare post som kommer från IP-nummer utanför Utfors' domän. Eller nåt.

 

Så, öh... kontentan är att problemen verkar ha upplöst sig. Utan linuxconf. Men tack i alla fall.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...