Just nu i M3-nätverket
Jump to content

Ljud i Debian


Miyo1

Recommended Posts

Efter att lyckats installera (med välbehövlig assistans från folk härifrån gällande X, tack än en gång) och konfigurera Debian, så står jag fortfarande inför problemet: inget ljud. Vad göra? Jo, eftersom det inte installeras några ljudmoduler under installationen, får man fixa detta efteråt, vilket innebär kompilera om kärnan, ändra lilo, och så vidare. När jag sökt länge och väl på nätet efter tillvägagångssätt för omkompilering och lilokonfigurering, och blivit både avskräckt och sporrad, hittar jag ett dokument som säger att allt som behövs, är att smälla i installationsskiva #2 i stället för #1 under installationen. Är detta verkligen möjligt?

 

Link to comment
Share on other sites

Det låter onödigt krångligt.. Det går alldeles utmärkt att installera färdigkompilerade kärnor via apt-get, och sedan ladda rätt modul. Vilken modul du ska använda får du dock söka rätt på själv (redhats hårdvarulista är dock användbar). Prova sedan med "modprobe es1371", t ex (om det är ett sånt ljudkort du har). Funkar det, så är det bara att lägga till modulnamnet i /etc/modules så ska den laddas varje gång du startar datorn.

 

Link to comment
Share on other sites

Men jag måste väl fortfarande ändra i LILO om jag kör in en ny kärna? Hur vet jag vilken kärna jag ska använda? Är det inte lite skumt att den kärnan som jag har inte innehåller några ljudmoduler?

 

Link to comment
Share on other sites

Jo, eventuellt måste du lägga in en ny rad i lilo, men installerar du kärnan via apt-get så får du instruktioner om det på skärmen. Jag kör just nu 2.4.20-686, installerad via apt-get.

(och du måste köra kommandot lilo innan du bootar om med en ny kärna!!)

 

Link to comment
Share on other sites

Jag var inne på Debians hemsida och kollade efter kärnor. Är du säker på att du har 2.4.20-686? Jag hittade en kernel-image-2.4.16-686, kan det vara den du menar? Just nu har jag 2.2.20-idepci, men det finns tydligen inget ljud i den kärnan, vilket jag finner en aning märkligt.

 

I vilket fall som helst, ska jag dra ner en ny kärna, exempelvis 2.4.16-686 (hur vet jag vilken jag ska ha?) göra ändringarna i LILO och sedan är allt frid och fröjd? Kan det vara så enkelt?

 

Link to comment
Share on other sites

Du tror inte att du skulle kunna bifoga din /etc/lilo.conf. Jag har ingen lust att sabba allt på grund av en felkonfigurerad textfil.

 

Link to comment
Share on other sites

Yes, helt säker ;)

 

Din /etc/apt/sources.list kan innehålla t ex följande:

 

deb http://ftp.funet.fi/pub/linux/mirrors/debian/ sid main non-free contrib

deb ftp://ftp.du.se/debian/'>ftp://ftp.du.se/debian/ sid main non-free contrib

 

deb-src ftp://ftp.funet.fi/pub/linux/mirrors/debian/ sid main non-free contrib

deb-src ftp://ftp.du.se/debian/ sid main non-free contrib

 

deb ftp://ftp.funet.fi/pub/linux/mirrors/debian-non-US/'>ftp://ftp.funet.fi/pub/linux/mirrors/debian-non-US/ sid/non-US main contrib non-free

 

deb-src ftp://ftp.funet.fi/pub/linux/mirrors/debian-non-US sid/non-US main contrib non-free

 

Kör sedan "apt-get update", och sök sedan med "apt-cache search kernel-image", så bör du få t ex

 

kernel-image-2.4-686 - Linux kernel image 2.4 on PPro/Celeron/PII/PIII/PIV.

 

som svar. Installera sedan den med

"apt-get install kernel-image-2.4-686". Om du har en amd-processor kanske du hellre vill använda den som är kompilerad för k7.

 

Du kommer förmodligen att få ett meddelande om att lägga till raden "initrd=/initrd.img" i lilo.conf. Exempelvis finns i min lilo.conf (utdrag):

 

image=/vmlinuz

label=Linux

read-only

# restricted

# alias=1

initrd=/initrd.img

 

Efter att du gjort detta, så kör kommandot lilo INNAN du bootar om datorn. Vad som händer om du inte gör det är att du eventuellt blir tvungen att starta upp med cd-skiva eller bootdisk för att köra lilo, så glöm inte det.

 

[inlägget ändrat 2003-03-12 19:26:31 av MD]

Link to comment
Share on other sites

Tack så mycket för hjälpen. Dock kom den aningen försent, jag tröttnade på allt och installerade om systemet, gjorde som jag blivit tipsad, dvs bootade med cd-skiva 2, som jag lyckligtvis hade, och kunde installera en kernel med stöd för ljud. Funkar ljudet? Nä, så klart inte. Det kräver starka nerver att hålla på med Linux, den saken är klar.

 

Om jag kollar i /lib/modules/2.2.20/misc så finns det, bland andra, filen soundcore.o. Den har saknats tidigare, så någon slags förbättring är det. Det fanns inte ens någon misc-katalog innan, så något har jag lyckats med. Det finns naturligtvis en rad andra filer i katalogen. Jag kör följande kommandon:

maya:~# modprobe soundcore

och

maya:~# modprobe awe_wave

 

men inte kommer det något ljud. Jag kör cat /dev/sndstat (vilket gav felmeddelande förut) och får reda på följande:

 

Kernel: Linux maya 2.2.20 #1 Sat Apr 20 11:45:28 EST 2002 i686

Config options: 0

 

Installed drivers:

 

Card config:

 

Audio devices:

 

Synth devices:

 

Midi devices:

 

Timers:

0: System clock

 

Mixers:

 

 

Inte mycket att hänga i julgranen. Skriver jag lspci, får jag upp, bland annat:

 

00:0d.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)

 

Vad jag vet så är det ett Soundblaster AWE64 kort. Efter att ha gjort allt det här är jag inte riktigt på det klara med vad jag ska göra för att få det här att fungera. Ska jag inte använda mig av awe_wave modulen, och i så fall, vilken ska jag använda? Behöver jag göra något annat, förutom modprobe?

 

Link to comment
Share on other sites

Jag ser även om jag kör dmesg att det inte verkar som om kortet hittas under uppstarten. Allra längst ner står det AWE32: not detected

 

Vad göra? Kan jag, utan att installera om hela systemet ändra så att den hittar rätt kort? Kan man, liksom man kan köra /usr/sbin/base-config för att konfigurera vissa grejer, köra om kärnan på något enkelt sätt?

 

Link to comment
Share on other sites

Christian...

om du kör: modprobe es1371

vad händer då? Det skall nämligen vara es1371 som skall användas.

 

Link to comment
Share on other sites

Jodå, jag gjorde precis det och äntligen så fungerade det. Hurra, kan tyckas, men naturligtvis är inte mina problem över... Jag lade märke till under installationen att jag inte fick frågan om installation av nätverk. Jag har en DHCP-server i mitt nät, så det har hittills inte varit några problem. Den här gången har inte ens nätverkskortet blivit installerat. Jippie. Tillbaka till modconf, alltså, men problemet är att jag inte vet vilket kort det är. Kör jag lspci så får jag reda på att det är ett Realtek Semiconductor Co., Ltd. RTL-8029(AS) men det hjälper föga eftersom den enda modulen som heter något med Realtek (Realtek RTL-8139 PCI Fast Ethernet Adapter osv.) vägrar låta sig installeras. Allt som händer är

Installation failed.

 

Please press ENTER when you are ready to continue.

 

Jätteroligt. Jag saknar ord.

 

Link to comment
Share on other sites

När du installerar Debian från cd, boota då upp cd:n med "bf24", så får du en 2.4-kärna med lite nyare drivrutiner. Se också till att ladda in moduler för nätverk och ljudkort under installationen (du blir tillfrågad om detta), så laddas de automatiskt nästa gång du bootar om datorn.

Håller med om att installation av Debian är lite knöligt, men har man väl lyckats få in grejorna är det riktigt trevligt.

 

Link to comment
Share on other sites

Jag har redan installerat Debian från CD, och jag är inte helt hundra på vad du menar med "boota upp med bf24". Hursomhelst. Jag har installerat nätverkskortet, men hur ska jag få maskinen att förstå att den får en dynamiskt tilldelad ip-adress av min router?

 

Link to comment
Share on other sites

Titta i /etc/network/interfaces

 

(se också "man interfaces")

 

När man installerar Debian från cd, så kan man vid första skärmen trycka F3, då får man se ett antal alternativ, däribland bf24.

 

Link to comment
Share on other sites

Installera etherconf.

 

Lite kommentarer bara: Debian är inte världens lättaste distribution att installera och få igång. Det krävs att man vet hur saker fungerar. Saker som att hitta och konfigurera hårdvara automatiskt vid installation, vilket många andra distar gör, finns inte i Debian (i dagsläget).

 

Här är en artikel som kan vara relevant: http://www.linuxgazette.com/issue88/tag/2.html

 

Ett tips är att uppgradera till en nyare Debian-version -- lägg in rätt rad i /etc/apt/sources.list, och kör apt-get update; apt-get dist-upgrade . Du vill nog också uppgradera till en 2.4-kärna, det finns en hel del trevliga saker i 2.4 jämfört med 2.2, som är rätt gammal.

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...