Just nu i M3-nätverket
Jump to content

Egen Server...igen...


Eminos

Recommended Posts

Det enklaste är att du installera IIS om du kör Win2k/WinXP Pro ifrån lägg till/ta bort program, och tillåter mapplistningar så det bara är att surfa in till din mapp via http istället, och tanka ner filer via http...

 

Jag fick detta svar en gång i tiden...någon som har lust o hjälpa lite mer i detalj hur jag ska göra...

 

Det jag vill alltså är att komma åt filer som ligger på min hårddisk från tex skolan...vill även ha en egen hemsida på min hårddisk i framtiden...

 

/Eminos

 

Link to comment
Share on other sites

Under Lägg till / ta bort program i kontrollpanelen kan du lägga till Internet Information Server. En del av det är World Wide Web services. När du lagt till det går du in i Administrativa verktyg och öppnar Internet tjänst hanteraren. Väl därinne sätter du vilken mapp du vill att websiten ska bläddra i och sen om du vill kunna se alla filer i den mappen via internet så måste du kryssa i rutan som tillåter "bläddra".

 

För att det sen ska fungera säkert måste du ha NTFS på hårddisken och sätta filrättigheter på allting. Om du har ett konto som heter xxx och ger det tillgång till alla filerna medan inga andra har rättigheter så kommer en inloggningsruta komma upp när du försöker accessa webservern. kontot "IUSR_datorns namn" ger anonyma websurfare rättigheter så akta dig för att ge det kontot rätt till filerna, annat än kanske read. Se dessutom till att ta bort "Everyone - Full Control" som är standard i windows.

 

//Johan

 

Link to comment
Share on other sites

Jag har bara ett konto i WindowsXP...Administrator...

 

Är det några ändringar då?

 

Jag vill inte störa så mycket, och skapa nya konton o grejer i onödan...

 

/Eminos

 

Link to comment
Share on other sites

Hej!

 

Jag får några problem när jag ska göra som du säger...

 

1. "...och öppnar Internet tjänst hanteraren.", säger du...var har jag denna? (Jag har engelsk version av XP)

 

2. Jag försöker lägga till min dator i Internet Information Services, men då kommer det fram en ruta som säger "The dependency service or group failed to start"...när jag kollar i Services, och försöker starta IIS Admin, så får samma felmedelande...jag antar att jag måste ha igång någon service...men vilken?

 

3. Du snackar nånting om konton...jag vill inte behöva skapa andra konton än det administrator kontot som jag redan har...det jag vill är att jag själv ska kunna komma åt vissa filer på min HD (eller varför inte alla?), från Internet (skolan)...det får gärna vara lösenordsskyddat, det spelar ingen roll...

 

Tacksam för hjälp...

 

/Eminos - Får ADSL 'snart'...förhoppningsvis...;)

 

Link to comment
Share on other sites

"när jag kollar i Services, och försöker starta IIS Admin, så får samma felmedelande...jag antar att jag måste ha igång någon service...men vilken?"

Många tjänster/services är beroende av andra tjänster.

Dubbelklicka på IIS och titta på fliken Beroenden så ser du om tjänsten är beroende av att andra tjänster är startade. Om inte så är det bara att starta dessa.

 

Link to comment
Share on other sites

Ok, nu har jag fått igång det...nästan...

 

När jag startar IIS, så får jag nu fram Eminos (local computer) i listan...men jag kan ej få fram något mer...hmm...nån som vet hur jag ska gå till väga sedan...?

 

/Eminos

 

Link to comment
Share on other sites

Det finns en liknande fråga från i höstas. Lyckades aldrig med det hela, men du kan ju läsa tråden kanske du får något tips:

 

//eforum.idg.se/viewmsg.asp?EntriesId=413708

 

Link to comment
Share on other sites

-Patrik Johansson-

Känns som tråden har hamnat i en loop ;-)

 

/Neox -(Patrik J)

"Gravitation can not be held responsible for people falling in love"
- citat av Albert Einstein

 

Link to comment
Share on other sites

Så kan det gå när man har flera inlägg på gång samtidigt.

Denna tråd hade jag i åtanke:

 

//eforum.idg.se/viewmsg.asp?EntriesId=332412

 

Link to comment
Share on other sites

Ok, har spanat lite där...men finns det inget enklare sätt?...;) ...lr, begär jag för mycket nu?...jag tycker det som vi snackat om hittils (IIS) verkar bra...men jag får det inte o funka...

 

Ja, ja...ADSL kommer nog inte på ett tag ändå, kanske bäst o lungna sej lite...;)

 

/Eminos

 

Link to comment
Share on other sites

Ok, jag kan ge det ett försök - för jag tycker det är otroligt enkelt :]

 

Installera IIS, kontrollpanelen->lägg till/ta bort program->windowskomponenter. Se till att avmarkera allt skräp som ingår i web services innan du installerar, såsom frontpage extensionstöd, smtp å annat trams - ftp å http vill du förmodligen ha dock.

 

Bocka för Terminal Services Web Client (eller vad den heter) också, den är bra att ha för ditt syfte - så du kan styra å konfigurera din hemdator ifrån skolan som om du satt vid den (typ flytta filer till ftp-mapparna åsånt).

 

Väl installerat, testa installationen genom att surfa till din egen dator: http://localhost eller http://<din-ip-adress - du bör få upp en IIS startsida, annars har inte installationen lyckats.

 

-

 

Konfiguration, via administrative tools->internet information services (eller via computer management, ser lite annorlunda ut då). Klicka dig ner i trädet så du ser din egen dator, klicka en gång på den å sen på krysset som dök upp/redan fanns till vänster för å expandera trädet. Undermapp för FTP och HTTP bör dyka upp, expandera dessa så visas standardserver för FTP och HTTP. Högerklocka en sådan å välj egenskaper för att konfigurera den... ftp-servern som exempel, ge den ett namn, lämna ip-adressen som 'all unassigned', sätt port 21 eller någon annan om du behöver, gå till nästa flik (security accounts).

 

Bocka BORT anonymous connections och acceptera varningen. Nästa flik kan du skippa, den sista fliken Home Directory ställer du in vart rotmappen för ftp ska vara. Förslagsvis skapar du en ny ftp-mapp på disk någonstans och använder denna till detta. Bocka för write om du ska ladda upp filer oxå. Tryck ok, testa logga in på ftpn med en ftp-klient (IE funkar för detta) genom att ange adressen ftp://<dindatorsip. En lösenordsruta bör dyka upp om du använder IE/webbläsare, fyll i ditt kontonamn och lösenord som du loggar in på datorn normalt med (administrator om det nu är det, men döp då OM kontot så det inte heter just administrator åtminstone. Security by obscurity)...

 

..har du inget lösenord satt på kontot - GÖR DET OMEDELBUMS! Annars funkar det inte hursomhelst ;)

 

--

 

Så, bara å kopiera in filer till den mappen du skapade å angav som ftp-root för att komma åt dem. Vidare kan du högerklicka servern igen men istället för å ta egenskaper kan du välja new->virtual directory och lägga till fler mappar på din dator till ftpn. Dessa kommer du sedan åt genom att ange /<mappnamn> som 'remote dir' i ftp-klienten (exempel i IE: ftp://<dindatorsip>/mappnamn/

 

(vill du ha det användarvänligt kan du skapa en tom mapp med samma namn som ditt virtual directory i din FTP Home Directory - så blir det bara att klicka på den via ftp-klienten för att ta sig till just den VDn.

 

--

 

För att ansluta till datorn via Adm Terminal Services surfar du till http://<dindatorsip/tsweb/ och anger din dators ip i rutan. Kräver IE och ActiveX.

 

--

.Wey

 

Future Hero Next Generati0n

 

[inlägget ändrat 2003-03-11 21:11:26 av Weyland]

Link to comment
Share on other sites

Ok, tack Weyland för det utförliga svaret!...men jag stöter på problem redan i början...

 

Det enda som jag kan välja av det du snackar om i början är Internet Information Services (IIS), väljer jag Details där, så får jag fram följande...:

 

*Common Files

*Documentation

*...(FTP) Service

FrontPage 2000 Server...

*Internet Information Services Snap-In

SMTP...

*World Wide Web Service

 

De med stjärna har jag förmarkerade (installerade)...

 

Något Terminal Services Web Client har jag inte hittat tex...

 

Kikar jag sedan i Internet Information Services så finns varken FTP lr HTTP...bara datorns namn (roten)...

 

/Eminos

 

Link to comment
Share on other sites

Avinstallera, installera igen... brukar hjälpa om det är något snett. Vad står det om du surfar till din dator?

 

TS Web Client (heter visst Remote Desktop Web Connection) ligger under World Wide Web Service.

 

--

.Wey

 

Future Hero Next Generati0n

 

Link to comment
Share on other sites

Jepp, jepp...nu verkar det funka...

 

Jag kan åtminstånde logga in på FTPn...men sen gnager han bara och filerna listas inte...

 

HTTPn har jag inte fixat...får testa mej fram...

 

Tack för hjälpen...!

 

En liten fråga bara...måste jag vara uppkopplad mot nätet när jag testar och försöker komma åt min server?

 

/Eminos

 

[inlägget ändrat 2003-03-11 22:15:26 av Eminos]

Link to comment
Share on other sites

Jag kan åtminstånde logga in på FTPn...men sen gnager han bara och filerna listas inte...

 

Är du nattad månne? Testa slå på Passive FTP i klienten (går även i IE i advanced options).

 

Borde juh iofs absolut inte spela någon roll om du sitter lokalt på samma dator och testar förstås - hum, kan vara rättighetsproblem... IE är dock extremt långsamt på att lista filer, ge det ett par minuter om du inte har ett riktigt FTP-program. Eller använd ett riktigt FTP-program för att få ev. felmeddelanden i klartext.

 

En liten fråga bara...måste jag vara uppkopplad mot nätet när jag testar och försöker komma åt min server?

 

Nope, inte vad jag vet. Har dock inte testat på en dator utan nätverkskort installerat... eller det är klart du inte behöver, men om man måste pula till något om man inte har ett nic aktivt kan jag inte svära på ;)

 

--

.Wey

 

Future Hero Next Generati0n

[inlägget ändrat 2003-03-11 23:08:49 av Weyland]

Link to comment
Share on other sites

Hej...nu har jag fixat HTTP servern oxå...allt verkar funka bra...

 

MEN, nu när jag surfar på webben och sidan försöker ladda någon annons, så frågar datorn efter lösenord och användarnamn...hmm?...var beror detta på?

 

/Eminos

 

Link to comment
Share on other sites

MEN, nu när jag surfar på webben och sidan försöker ladda någon annons, så frågar datorn efter lösenord och användarnamn...hmm?...var beror detta på?

 

Du kanske råkat lägga in det berömda 'hacket' som sätter diverse kända bannerdomäner till 127.0.0.1 (localhost) i datorns hostfil? :)

 

--

.Wey

 

Future Hero Next Generati0n

 

Link to comment
Share on other sites

Inte omöjligt...ska kolla...

 

Tack...

 

[EDIT]

 

Jojo...det var det...:) ...Tack igen...jag skulle aldrig hittat felet själv...

 

/Eminos

 

[inlägget ändrat 2003-03-12 19:22:11 av Eminos]

Link to comment
Share on other sites

Jaha, då stöter jag på problem med servern direkt...

 

När jag surfar på http://localhost så funkar allt perfekt...men när jag är uppkopplad mot nätet och surfar mot min IP-adress, så frågar han efter lösenord..."Administrator" + mitt lösenord funkar inte ...inte häller Eminos (som mitt enda användarkonto (admin-rättigheter) i XP heter)...

 

Vad är fel nu?

 

Vad är det för lösenord och användarnamn som han frågar efter egentligen?

 

/Eminos

 

Link to comment
Share on other sites

"För att ansluta till datorn via Adm Terminal Services surfar du till http://<dindatorsip/tsweb/ och anger din dators ip i rutan."

Jag har noga följt tråden. Ftp har jag fått till, men Http lyckas jag inte med. Vet inte hur jag ska konfigurera under egenskaper. Då jag skriver:

http://<datorns'>http://<datorns ip>/tsweb

så kommer jag till "Sidan kan inte visas". Skriver jag däremot:

http://<datorns ip>

så får jag upp rutan där jag får ange lösenord och efter jag skrivit in det så kommer jag till:

"Välkommen till Windows XP Server Internet Services", där det bl.a. står:

Webbtjänsten körs nu.

Du har inte upprättat någon standardwebbsida för användarna. Om en användare försöker ansluta till webbplatsen från en annan dator visas en sida med informationen Under utveckling i stället.

Därefter står jag handfallen.

 

Link to comment
Share on other sites

men Http lyckas jag inte med

"Välkommen till Windows XP Server Internet Services", där det bl.a. står:

 

Webbtjänsten körs nu.

Du har inte upprättat någon standardwebbsida för användarna. Om en användare försöker ansluta till webbplatsen från en annan dator visas en sida med informationen Under utveckling i stället.

Jamen, du har lyckats sätta upp en webserver ju.

 

Det återstår lite rättigheter och så...letar...

nånstans har jag frågat efter en sida som inte fungerade... ...

återkommer.

 

<edit>Hittat!

http://www.dslwebserver.com/

 

/TN

-+- :thumbsup: -+-

 

[inlägget ändrat 2003-03-13 20:22:35 av Don Tomas]

Link to comment
Share on other sites

"Jamen, du har lyckats sätta upp en webserver ju."

Menar du det?

 

Nyss installerade jag tsweb (tips från gamle bekantingen xyzz http://www.microsoft.com/windowsxp/pro/downloads/rdwebconn.asp ). Och då jag testar med http://<datorns'>http://<datorns ip>/tsweb så kommer jag till sidan: Webbanslutning till fjärrskrivbord. Där man ska ange server.

Men då är frågan vilken server, vilket namn?

 

Jag gissar då att det är detta http://<datorns ip>/tsweb jag skriver in på annan dator för att kunna komma åt min egen.

 

För att det ska kunna lyckas, måste jag ha min dator påslagen, alltså strömmatad?

 

Link to comment
Share on other sites

Men då är frågan vilken server, vilket namn?

 

Ange din dators namn eller ip-adress helt enkelt... det är som sagt för att kunna ansluta till andra datorer i ditt nät via bara en extern webbserver.

 

--

.Wey

 

Future Hero Next Generati0n

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...