Just nu i M3-nätverket
Jump to content

Fel vid uppstart


olofa

Recommended Posts

Hej!

 

Jag har nyligebn installerat Redhat Linux på min dator. När jag nu försöker starta detta operativsystem får jag alltid följande meddelande.

 

Kernel panic: VFS: Unable to mount root fs on 16:01.

 

Varför kommer detta meddelande upp och hur löser jag detta problem?

 

/Olof

 

Link to comment
Share on other sites

Nått har gått fel, verkar inte hitta nått. En tänkbar orsak är annat OS på datorn har skrivit över delar av linuxpartionen. En ny hårddisk instoppad i datorn kan också ge problem.

Försök få igång den genom att starta datorn med RH CDn, tror det finns nån rescue variant. att välja.

 

Link to comment
Share on other sites

hittade följande sida m h a google: http://www.iar.unlp.edu.ar/~fede/revistas/lj/Magazines/LJ56/3169.html

 

VSF Error Messages

I am using Red Hat 5.1. How do I correct a VSF error message? I recently compiled a new kernel from the newly released Red Hat 2.0.35 source tree.

I did a make dep; make clean; make zImage. Everything went fine during the compile phase. I ran LILO and set up my lilo.conf file to test my new kernel. Now, every time I boot, my system stops and displays:

 

 

VFS: Cannot open root device 16:01 Kernel panic:

VFS: Unable to mount root fs on 16:01

How do I resolve this problem?

--

Marlon, yu133048@yorku.ca The kernel tries to mount your root directory from /dev/hdc1 (16:01 is a hex number representing the /dev/hdc1 as major:minor number).

It looks as if you don't have a valid Linux partition on /dev/hdc1. You should add root=/dev/hda1 (or whatever your root partition is) to the LILO prompt or to the append= line in /etc/lilo.conf. The LILO-mini-HOWTO describes this in detail.

--

Alessandro Rubini, rubini@prosa.it

 

[inlägget ändrat 2003-03-08 19:42:58 av [André]]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...