Just nu i M3-nätverket
Jump to content

Undvika tomma celler i Excel


Radiogogo

Recommended Posts

Hej hej alla kloka...för vilken gång i ordningen vill jag inte ens tänka på...

 

Vill få fram de senaste fem resultaten i en tabell och så långt inga problem då jag använder mig utav:

=SUMMA(INDIREKT(ADRESS(MAX(1;ANTAL(G2:G781)-4);1)&":"&ADRESS(ANTAL(G2:G781);1)))

 

Problemet är att jag har ett antal tomma celler och vad jag vill är att den då "hoppar över" den cellen och tar enbart de som har ett värde i sig i beräkningen.

 

Hittade:

{=SUMMA(INDIREKT("A1:A780"&MAX(RAD($A$1:$A$780)*($A$1:$A$780<>""))))}

men denna ger ju inte de fem senaste men å andra sidan så räknar den inte med tomma celler, och jag antar att det är denna *($A$1:$A$780<>""))))} som gör det.

 

Har försökt att nästla in den biten i den första formeln men sprungit in i väggen...( vilket varken jag eller väggen tjänat något på ) ;o)

 

Hoppas ni förstår vad jag är ute efter och att någon vänlig själ kan leda mig rätt?

 

 

Frestelser är ett annat ord för valmöjligheter.

 

[inlägget ändrat 2003-01-30 16:20:16 av Radiogogo]

[inlägget ändrat 2003-01-30 17:29:59 av Radiogogo]

Link to comment
Share on other sites

Radiogogo,

 

Behöver inte be om ursäkt :-)

 

Hade det varit en hemuppgift till skolan hade jag däremot ignorerat dina frågor.

 

Du ska få fundera på följande uttryck att fundera på:

 

>0

 

 

Mvh

Dennis

Besök Sveriges ledande oberoende webbplats om MS Excel: http://www.xldennis.com

 

Link to comment
Share on other sites

Dennis...om du hade den minsta aning om hur många gånger jag varit inne på din sajt dessa dagar *skratt* och jag hoppades på att du INTE skulle se mitt inlägg...ack ja...

 

Vad jag nu vill med mitt lilla "program" är att sortera träningsserier och matchserier utan att grabben behöver fylla i resultaten i två olika uppställningar, ( han kan ju trots allt såväl träna som ha match samma dag ).

 

>0 större än noll? Med andra ord så...måste jag...ta mig en funderare...Hmm du har roligt nu va Dennis? ;o)Nåja, skulle jag antagligen också haft i din position. Återkommer...

 

Frestelser är ett annat ord för valmöjligheter.

 

[inlägget ändrat 2003-01-30 22:35:21 av Radiogogo]

Link to comment
Share on other sites

Okej...

 

I denna formel:

{=SUMMA(INDIREKT("A1:A780"&MAX(RAD($A$1:$A$780)*($A$1:$A$780<0))))}

så blev visserligen den tomma cellen oräknad med <0 men jag kan inte få den att enbart räkna med de fem senaste resultaten.

 

Försökte sedan med:

=SUMMA(INDIREKT(ADRESS(MAX(;ANTAL(A1:A780)-4);1)&":"&ADRESS(ANTAL(A1:A780<0);1)))

men då gav den mig en total som ändå inte var det(?)

 

Efter det denna:

=SUMMA(INDIREKT(ADRESS(MAX(;ANTAL(A1:A780<0)-4);1)&":"&ADRESS(ANTAL(A1:A780<0);1)))

gav mig #Värdefel! Likaså om jag skippade <0 i den sista parentesen.

 

Jag ska fortsätta imorgon bitti *skratt*, skam den som ger sig.

 

Frestelser är ett annat ord för valmöjligheter.

 

Link to comment
Share on other sites

<0

Var det inte >0 du skulle ha? Eller så är det bara jag som inte förstår resten av formeln... ;)

 

 

 

_________

TicoRoman - The One And Only

 

Link to comment
Share on other sites

Radiogogo,

 

Hmm du har roligt nu va Dennis?

 

Nej, men jag tycker mig uppfatta att du vill lära dig och då tillmötesgår jag det behovet genom att begränsa mitt svar.

 

Men kvarstår problem så ger jag givetvis mer.

 

Generellt gör jag mig aldrig roligt på andras bekostnad!

 

 

Mvh

Dennis

Besök Sveriges ledande oberoende webbplats om MS Excel: http://www.xldennis.com

 

Link to comment
Share on other sites

Tico...ser mitt misstag men det hjälpte ändå inte *skratt*.

 

Ska fortsätta precis på det sätt som Dennis tänkte sig...att man måste göra allt för att förstå formlerna man skriver...enda sättet att lära sig.

"Gammal man gör så gott han kan", Hasse Alfredsson.

 

Frestelser är ett annat ord för valmöjligheter.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...