Just nu i M3-nätverket
Jump to content

Program för att spela upp DVD-filmer!


Chribba

Recommended Posts

Försökte mig på att installera ogle men hamnade vid:

 

[root@localhost ogle]# rpm --install ogle-0.8.5-ogle1.i586.rpm

fel: ouppfyllda beroenden:

libxml2 behövs av ogle-0.8.5-ogle1

libxml2.so.2 behövs av ogle-0.8.5-ogle1

 

resp.

 

[root@localhost ogle]# rpm --install libxml2-2.5.1-1.i386.rpm

fel: ouppfyllda beroenden:

libc.so.6(GLIBC_2.3) behövs av libxml2-2.5.1-1

 

Uppenbarligen saknar jag glibc 2.3! Hur kontrollerar jag förresten vilken version av glibc jag har installerad just nu? Är det "ofarligt" att installera glibc 2.3?

 

 

Link to comment
Share on other sites

Installera en äldre version av libxml2. Du kan kolla vilken version av glibc som är installerad genom att skriva "rpm -q glibc" eller -qi för mer info om paketet. Du kan lista alla paket som är installerade med "rpm -qa". "rpm -qa | grep glibc" visar alla paket som innehåller strängen "glibc".

 

Ett smidigt sätt att installera saker på är att använda APT (http://apt-rpm.tuxfamily.org/scripts/apt-rpm.html http://freshrpms.net/apt/).

 

Link to comment
Share on other sites

Tack för hjälpen!

 

Med libxml2-2.4.2-1 gick det bättre att installera ogle. Det gick sedan också bra att titta på en DVD-film med programmet.

 

Angående glibc: var i filstrukturen ligger dessa "source"-filer? Går det att ange olika versioner av glibc när man installerar/kompilerar olika program?

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...