Just nu i M3-nätverket
Jump to content

problem med hårddiskar


wiberg

Recommended Posts

Har stora problem men min dator. Datorn har två HDs en 6,4gb med OS (w2k) och en 20gb. Jag flyttade över båda till en annan dator för att kopiera en del filer och sen tillbaka till min dator.

 

Men nu vill inget funka. :(

 

NTLDR saknas står det bara när jag försökte boota upp. Har testat att ändra byglingen på dem master/slave etc. Har också ändrat i BIOS och försökt boota från båda.

 

Om jag startar upp med w98-startdiskett och försöker köra en DIR på nån av hårddiskarna så stor det "felaktig mediatyp..."

 

Om jag kör fdisk /status så står det ungefär:

 

Enhet - storlek - filsystem

(inget) - 6,4 - (inget)

(inget) - 20 - (inget)

 

Förslag på åtgärd?

 

Link to comment
Share on other sites

Förslag på åtgärd?

 

Stoppa dessa hd i en micro, kör tio minuter på högsta effekt. Glöm vad du hade på dessa HD...

 

 

 

Link to comment
Share on other sites

 

boota upp med Win2K CDn (eller de fyra setup disketterna) och när du får möjlighet välj att reparera nuvarande installation, sen kan du återställa systemfilerna för Win2000.

 

 

 

Link to comment
Share on other sites

1

Du måste vara helt säker på att allt är lika monterat som tidigare.

 

2

Datorn borde hitta båda hd, (med bootdisket)

 

3 Gör sedan som Cytech skrev tidigare.

 

/Vad har du för filsystem på diskarna?

 

Link to comment
Share on other sites

Det är inte helt lätt att vara säker på om det är som tidigare eftersom jag inte kommer ihåg hur det var. :)

 

OS-disken är NTFS och den andra är FAT32.

 

Jag har försökt boota från cdn men den vill inte. Har också försökt starta installationen via dos med en 98-startdiskett men då stod det att det fanns för lite ledigt utrymme.

 

Om jag kör IDE HARDDRIVE DETECTON i BIOSen så hittar båda hårddiskarna.

 

 

Link to comment
Share on other sites

Lite problematiskt detta.

Utan att se datorn, eller själv kunna felsöka så gissar jag på att det är "fel" på bootsektorn, partitions tabbeler.

 

Prova att köra fdisk/mbr från disket på disken med fat 32 till att börja med.

 

Medelandet du får "felaktig mediatyp..." tyder på att dator inte läser dessa. Att du kan köra fdisk och se dessa tyder även det på att datorn "ser" dessa.

 

Om du med fdisk som du beskrivt kommer åt båda hd och de har samma enhets bokstav som tidigare så är felet troligen inte att du monterat fel. Utan något hände när de var monterade i andra datorn med informationen på diskarna.

 

Alla "råd" för att återställa diskaran kan innebära att du tappar all info på dessa. Tyvärr.

 

Om du har möjlighet montera dessa hd i en annan dator och se om de fungerar.

Om de gör det. Kopiera innehållet till den andra datorns hd innan du gör något mer.

 

Har du otur så måste du skapa nya partioner, och då "tappar" du allt.

 

Link to comment
Share on other sites

Jag monterade 6,4gb disken i en annan dator och den gick att läsa. De viktiga filerna finns dock på 20gb disken så jag monterade denna också. Disken visades i windows men kunde inte läsas: "ej formaterad eller okänt filsystem".

 

Med fdisk /status så syns båda hårddiskarna fast utan enhetsbokstav. Det kan mycket väl vara så att de är fel kopplade men jag har provat en massa kombinationer utan förbättring.

 

Hur kör jag fdisk/mbr mot en disk?

a:\>fdisk /mbr c: ?

 

Link to comment
Share on other sites

Något har hänt med filsystemet mao.

Kör fdisk med en hd i datorn så kan det inte bli fel med fdisk.

(koppla lös flatkabeln till den andra, det räcker)

 

Link to comment
Share on other sites

Jag drog ut IDE-kabeln ur 6,4-disken och byglade om 20-disken till master.

 

Gick in i BIOS och 20-disken hittades.

Sparade och startade om.

 

Resultat: Datorn stannar innan den hunnit boota från disketten. Inget felmeddelande.

 

Link to comment
Share on other sites

Har du bara OS på 6,4 disken?

 

Om jag var dig skulle jag ta ur 20 disken , stoppa i och installera om windows på 6,4 disken.

 

Har alltid funkat för mig när jag fått "NTLDR is missing" felmeddelanden.

 

LYCKA TILL

 

/Ex

 

 

 

Link to comment
Share on other sites

Jo men det är ju bara att stoppa tillbaka 20 disken när du fått 6,4 med windows o allt o funka.......

 

Dessutom behöver INTE BIOS hitta disken (20 disken alltså) för att den skall funka i windows.

 

/Ex

 

[inlägget ändrat 2003-01-01 19:46:26 av Erik Övelius]

Link to comment
Share on other sites

När jag flyttade över 20-disken till en annan dator så kunde den ju inte läsas där. "ej formaterad / ogilitig filsystem".

 

Samma sak lär ju hända i denna datorn.

 

För övrigt så kan jag inte installera nåt på 6,4-disken eftersom jag ju inte heller kommer åt den.

 

Jobbigt värre...

 

Link to comment
Share on other sites

Och 20:an är FAT32 sa du? Ledsen kompis... det är mer än jag vet ...

 

Men 6,4:an är det ju bara att formatera om.....

 

 

LYCKA TILL NU!

/Ex

 

 

 

Link to comment
Share on other sites

Prova följande.

Montera bara disken med fat32 i datrorn. Starta med disket. Kör fdisk/mbr. Sedan scandisk. Detta kanske löser problemet med den disken.

Det finns program att ladda ner på för att rädda data annars. Men risken är att skadan blir större när man använder dessa.

Om dina data är väldigt dyrbara. Gör inget lämna in disken till något företag som är speciliserade på denna typ av problem. Typ ibas.

 

Annras är det väl bara att använda fdisk och skapa nya partitioner. Tyvärr. Då du då tappar allt....

 

[inlägget ändrat 2003-01-01 20:35:32 av Axel G]

Link to comment
Share on other sites

Som jag skrev ovan så blir det inte helt bra när bara fat32-disken är monterad. Datorn låser sig innan den hinner boota från disketten.

 

Datan på disken är inte jätteviktig egentligen men vill helst inte förlora den. :)

 

Link to comment
Share on other sites

har du A: som första boot enhet?

 

inte vänt flatkabeln fel? (tror jag iof inte)

 

provat andra flatkablar?(använd 80 ledare, dvs ata66+)

 

disken som master när den sitter själv?

 

i bios, provat att stänga av allt som gör den snabb? (kör pio mode0 (1, ej auto, ingen dma, stängt av annat som ger prestanda på disken? olika på olika mk, bios)

 

 

 

Link to comment
Share on other sites

Vad menar du med "disken som master när den sitter själv?" Ska den inte vara det?

 

Jag lyckades boota upp med startdisketten och körde en fdisk /mbr och sen scandisk c:.

 

"Scandisk kan inte köras på enhet C:"

 

Om man kör fdisk/status så ser det inte ut om hårddisken har fått nån enhet.

 

En annan sak som kan är skumt: Om man kör IDE HDD detection så söker den ju efter pri master, sec master etc. Då sparas ju Hårddisken som pri master.

 

Om man däremot kolla standard BIOS conf så ser det ut som om hårddisken ligger som pri master OCH pri slave OCH sec master.

 

*förvirrad*

 

Skulle det hjälpa er att hjälpa mig om jag fixade bilder på BIOS-inställningar, resultat vid fdisk /status etc?

 

Link to comment
Share on other sites

Vad menar du med "disken som master när den sitter själv?" Ska den inte vara det? Givetvis ska den det...

 

"En annan sak som kan är skumt: Om man kör IDE HDD detection så söker den ju efter pri master, sec master etc. Då sparas ju Hårddisken som pri master.

 

Om man däremot kolla standard BIOS conf så ser det ut som om hårddisken ligger som pri master OCH pri slave OCH sec master.

 

*förvirrad*"

 

Helskumt.. Försök med att i bios stänga av andra enheter än den du använder. (stäng av "pri slave OCH sec master, slave, hur man gör ser olika ut i olika bios, använd manuella inställningar för disken, ej auto)

 

"Skulle det hjälpa er att hjälpa mig om jag fixade bilder på BIOS-inställningar, resultat vid fdisk /status etc?"

 

Vad som skulle kunna hjälpa är om man hadde tillgång till disken och en maskin som man är van att lösa problem med...

Det finns oändligt många varianter på fel som kan tänkas beroende på att i stort alla mb, bios och olika hd har något olika funtion.

 

Därav är det i det närmaste omöjligt att gissa felet om det inte går med standard medoder att lösa det..

 

Hoppas du löser problemet.

Kommer inte längre utan fysik tillgång till disken, och en dator som jag är van att lösa problem med. sory.

 

Link to comment
Share on other sites

Nytt utgångsläge! :)

 

Formaterade 6,4-disken och installerade w2k. Kopplade åter in 20-disken och den visas i windows som E.

 

Försöker man läsa från den så stor det som innan att den inte är formaterad.

 

Kollar man diskhanteraren så står det att det på "disk 2" som är på 20gb finns det dels E (2gb, inget filsystem angivit) och 18gb oallokerad (stavning?) utrymme.

 

Nån man vettigt jag kan testa nu som inte gick tidigare?

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...