Just nu i M3-nätverket
Jump to content

AVI gör XP segt...


brorsan

Recommended Posts

Hej! Vet att de finns en lösning på detta problem postat här på eforum, men jag kan inte hitta den med sökfunktionen.

 

Problemet är när jag klickar på en DivX-film (AVI) blir hela datorn seg i flera minuter. Typ om jag ska högerklicka på avi-filen så börjar HD:n jobba lite och datorn CPU-användning går upp i 100% sen är det bara att vänta några minuter innan den blir klar. Det skulle gå att stänga av att XP ska kolla info om filmfiler, men hur gör man det?

____________________

/brorsan

http://www.brorsan.com - ner tills efter jul

 

[inlägget ändrat 2002-12-24 12:48:46 av brorsan]

Link to comment
Share on other sites

Typ om jag ska högerklicka på avi-filen så börjar HD:n jobba lite och datorn CPU-användning går upp i 100% sen är det bara att vänta några minuter innan den blir klar.

 

Det skulle vara intressant att veta vad detta beror på, eftersom jag själv aldrig har upplevt det fenomenet. Det känns som att det borde bero på nåt man har installerat/inte installerat eftersom det inte drabbar alla.

 

Har du t ex SP1?

 

 

God jul!

---

If I learn from my mistakes, pretty soon I’ll know everything.

 

Link to comment
Share on other sites

Jo, det händer alla, men märks mer eller mindre beroende på hur snabb dator man har, och om man väljer en hel filmfil, eller en som är på väg att laddas ned.

 

Då AVI-filmers index ligger i slutet av filmen, så kan inte Windows XP hitta detta om man inte har en komplett filmfil, vilket resulterar i att Windows söker igenom hela filen, vilket kan ta ett tag med en flera hundra MB stor fil.

 

Skapa en fil som heter "vadsomhelst.inf", och klistra in följande i den:

[version]
signature="$Windows NT$"

[DefaultInstall]
DelReg = Reduce.Reg

[Reduce.Reg]
HKLM, "SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32"

Spara filen, och stäng. Högerklicka sedan på den i Utforskaren, och välj "Installera".

 

Du kan också gå in i registereditorn och ändra standardvärdet för

HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shellex\PropertyHandler

till en tom sträng ("").

[inlägget ändrat 2002-12-24 13:43:48 av Cariad]

Link to comment
Share on other sites

Det är ingen ini-fil, utan en inf-fil ;)

 

Executing this file will remove a registry key which makes explorer load shmedia.dll.

Simply put, this removes the annoying "permission denied" errors when trying to move/copy/delete AVI files.

 

Jag har kört den på flera datorer, helt harmlös. Om du föredrar det, kan du leta upp nyckeln själv i registret, och ta bort den manuellt.

 

Jag kör dock med inf-, och reg-filer, då det går mycket fortare. Så kör man bara ett kommando när man installerat om datorn, och vips, allt är "tweakat", precis så som man vill ha det. :)

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...