Just nu i M3-nätverket
Jump to content

Ftp?


kisumisu

Recommended Posts

Tackar för svaren!

Gör följande

[root@217 root]# pure-pw useradd kevin -u ftp -d /home/mp3

Password:

Enter it again:

[root@217 root]#

 

Men även om allt verkar funka fin fint när man konfiguerar så funkar inte ftp:n...det verkar som det är nåt annat som stör, jag kommer in på ftp:n med datorns användarnamn.

 

Link to comment
Share on other sites

Jag startar ftp med /usr/local/sbin/pure-ftpd &

 

Men jag tror det är KWUFTPD som stör eller har jag fel?

På menyn konfiguration -> Nätverk finns den fortfarande kvar...man kan inte avinstallera den heller? Finns iaf inte med på paketen.

 

Eller e det bara lägga in på "autostart" o starta om?

 

Link to comment
Share on other sites

Verkar som Linux är inget för oss vanliga dödliga ;)

När det gäller att starta server o sånt.

Bara programmerare som klarar sånt...

Även om windows e osäkert...så klarar jag där sätta upp min ftp som jag vill inom några sekunder där.

Börjar tröttna på det här...massa kommandon o ändå händer ingenting får bara igång en server där alla har lika rättigheter dvs rättigheter över HELA hårddisken. På dokumentationer står det massa kommandon om db mm...men får inte virtuella användare fungera och jag fattar inte då varför finns inget sätt o konfiguera då vilka användare på datorn har bara rättigheter komma in på sitt hemkatalog om det nu ska vara så svårt :(

Jag kanske är dum, men kan inte göra nåt åt saken när det inte står nånstans för dummies hur det funkar. Funderar på att installera pirat xp...windows 98 o 2000 suger hänger sig hela tiden...om jag e ärlig suger hela den här datorn, min gamla pII 233Mhz har reset knapp, har inte denna måste dra ur kontakten om datorn hänger sig mm :(

 

 

Link to comment
Share on other sites

Nej man behöver inte kunna programmera. Det räcker att kunna läsa och följa instruktioner.

 

Exakt vad har du gjort? Har du läst README.VirtualUsers och gjort vad det står där? Exempel:

 

# groupadd ftpgroup
# useradd -g ftpgroup -d /dev/null -s /etc ftpuser
# pure-pw useradd w4r3Zd00d -u ftpuser -d /var/ftp -q 1 -Q 5
Password: 
Enter it again: 
# pure-pw mkdb
# pure-pw show w4r3Zd00d

Login              : w4r3Zd00d
Password           : $1$u3oaR/70$ZymcEnh1EFXxlZFoSaWPx0
UID                : 1002 (ftpuser)
GID                : 1002 (ftpgroup)
Directory          : /var/ftp/./
Full name          : 
Download bandwidth : 0 Kb (unlimited)
Upload   bandwidth : 0 Kb (unlimited)
Max files          : 0 (unlimited)
Max size           : 0 Mb (unlimited)
Ratio              : 1:5 (enabled:enabled)
Allowed local  IPs : 
Denied  local  IPs : 
Allowed client IPs : 
Denied  client IPs : 
Time restrictions  : 0000-0000 (unlimited)
Max sim sessions   : 0 (unlimited)

# pure-ftpd -lpuredb:/etc/pure-ftpd/pureftpd.pdb &
[1] 24241
# ftp localhost
Connected to localhost.
220-=(<*>)=-.:. (( Welcome to Pure-FTPd 1.0.13a )) .:.-=(<*>)=-
220-You are user number 1 of 50 allowed.
220-Local time is now 09:54 and the load is 0.55. Server port: 21.
220 You will be disconnected after 15 minutes of inactivity.
Trying KERBEROS_V4...
The server doesn't support the FTP security extensions.

*** Using plaintext user and password ***

Name (localhost:root): w4r3Zd00d
331 User w4r3Zd00d OK. Password required
Password: 
230-User w4r3Zd00d has group access to:  1002    
230-You must respect a 1:5 (UL/DL) ratio
230 OK. Current directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> 

Det är väl nåt sånt man vill ha om man sätter upp en warezsajt...

 

Link to comment
Share on other sites

[david@217 david]$ su

Password:

[root@217 david]# groupadd ftgroup

[root@217 david]# useradd -g ftpgroup -d /dev/null -s /etc ftpuser

[root@217 david]# pure-pw useradd hello -u ftpuser -d /var/ftp -q 1 -Q 5

Password:

Enter it again:

[root@217 david]# pure-ftpd -lpuredb:/etc/pure-ftpd/pureftpd.pdb &

[1] 3411

[root@217 david]# 421 Unknown authentication method: puredb:/etc/pure-ftpd/pureftpd.pdb

 

Link to comment
Share on other sites

Kan vara att du inte har kompilerat in stöd för puredb (om jag förstår det rätt kompilerade du själv?), typ ./configure --with-puredb . Det kan finnas annat som är intressant att ha med; läs README och ./configure --help .

 

Se också till att filen /etc/pure-ftpd/pureftpd.pdb existerar -- kan vara att den heter nåt annat.

 

Link to comment
Share on other sites

okidoki...tusen tack för din hjälp :)

Har testat...o de mesta gick som jag vill. Men när man loggar in på ftp:n händer följande:

220-=(<*>)=-.:. (( Welcome to PureFTPd 1.0.12 )) .:.-=(<*>)=-

220-You are user number 1 of 50 allowed.

220-Local time is now 20:30 and the load is 0.21. Server port: 21.

220 You will be disconnected after 15 minutes of inactivity.

USER zerblat

331 User zerblat OK. Password required

PASS xxxx

421 Unable to read the indexed puredb file (or old format detected) - Try pure-pw mkdb

 

Lite konstigt meddelande.

 

Link to comment
Share on other sites

Nu fick jag igång nånting ;)

Äntligen fick jag igång ett account där användaren inte kommer över hela hd:n...;)

Nu e bara problemet att symbol links verkar plötsligt inte fungera (funkade förut) dvs att jag gjort en "genväg" till Upload och Download...o ratio funkade inte heller trots jag hade det inställt till användarnamnet. Får kolla imorn, glad hittils att jag lyckats komma så här långt :) Var nära o ge upp...tack för dina tips zerblat och Md som hjälpt mig!!

 

Link to comment
Share on other sites

Angående länkar (eller genvägar, som du kallar dem): Tänk på att det i unixvärlden finns två olika typer av länkar, symboliska och hårda länkar. Lär dig skillnaden mellan dem, annars kan förvirrade situationer lätt uppstå ;-)

 

Link to comment
Share on other sites

ok...så det finns båda slags länkar :)

Hårda är mappar? Som tex de där i mount? Måste man då mounta till ftp:ns hem? eller finns det några enklare sätt :)?

 

Link to comment
Share on other sites

Tja, jag vet inte om typen av länkar har något med den här situationen att göra, det var mer en allmän upplysning :)

 

En symbolisk länk är vad man tror att det är, dvs en vanlig länk till en fil. En hård länk, däremot är oskilaktlig ifrån filen den länkar till. Betrakta följande: Om du skapar en symbolisk länk till en fil, och sedan raderar filen, så är filen borta. Om du däremot skapar en hård länk till filen, så finns filen kvar i och med länken!

 

Från man-sidan till ln (från FreeBSD):

By default, ln makes hard links. A hard link to a file is indistinguish­

able from the original directory entry; any changes to a file are effec­

tively independent of the name used to reference the file. Hard links

may not normally refer to directories and may not span file systems.

 

Link to comment
Share on other sites

Från README:

 

--with-virtualchroot: usually, when an user is chrooted (-A and -a
options), it's impossible to go out of his home directory. Enabling that
feature makes it possible: symbolic links are always followed, even if they
are pointing to directories not located in the user's home directory. This
is very useful for having shared directories (for instance, have a symbolic
link to /var/incoming in every home directory) .
This feature isn't enabled by default.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...