Just nu i M3-nätverket
Jump to content

Problem med Loadvariablenum och ASP *Problem löst*


jonas g

Recommended Posts

Tjena

 

Har gett mig på att försöka skapa lite interaktivitet mot flash m.h.a. ASP

 

Jag får inte in något värde när jag försöker hämta svaret från en ASP-sida, koden ser ut så här:

<%
Set Conn= Server.CreateObject ("ADODB.Connection") 
Conn.Open "Provider=Microsoft.Jet.OLEDB.4.0;Data Source="&amp;amp;amp; Server.MapPath("../db/NE.mdb")
Set rs = Server.CreateObject("ADODB.Recordset")
rs.open "SELECT * FROM Inlagg", conn

Namn = rs("Namn")
Text = rs("Text")
Datum = rs("Datum")

Response.write "Namn=" &amp;amp;amp; Namn &amp;amp;amp; "&amp;amp;amp;Text=" &amp;amp;amp; Text &amp;amp;amp; "&amp;amp;amp;Datum=" &amp;amp;amp; Datum
%>

och Actionscriptet så här:

loadVariablesNum("select.asp", 0, "POST");
gotoandplay(read);

Asp-sidan funkar det har jag testat och jag har även testat att ändra Actionscriptet så att det pekar på en txt-fil jag gjort och då funkar den med. Vad har jag gjort för fel med ASP-kopplingen?

Jag misstänker att det kan vara något med utskriften från ASp-sidan men vet inte vad.

 

Jag lade till ett & i response.write delen av ASP-sidan

 

[inlägget ändrat 2002-11-30 18:28:35 av jonas g]

Link to comment
Share on other sites

Pontus östlund

Skulle tippa på att det är detta som strular:

&amp;amp;amp;

 

Och-tecknet används för flash för att deklarera en ny variabel och därför meckar detta ur. Du måste URL-koda texten om du vill ha med &-tecken och < b la

 

 

# ==============================extra===

# Nordens största F l a s h community

# www.communen.com | poppa@communen.com

 

Link to comment
Share on other sites

Tack för svaret, men som sagt problemet var redan löst =)

 

Det du nämnde hände när jag klippte och klistrade in mitt inlägg, alltså ser inte koden ut så.

 

 

Obs, den korrekta Response.write ser i mitt fall ut så här, ifall någon mer har problem =)

Response.write "&Namn=" & Namn & "&Text=" & Text & "&Datum=" & Datum

------------------------

Jonas Granstrand

http://www.patos.se

 

[inlägget ändrat 2002-12-03 12:07:26 av jonas g]

[inlägget ändrat 2002-12-03 12:08:10 av jonas g]

Link to comment
Share on other sites

Pontus östlund

Nice, kom bara ihåg att URL-koda ASP-variablerna ändå. Om någon har skrivit ett &-tecken eller <-tecken så kommer ingen text efter dessa tecken att visas. Strängen kommer alltså att klippas i Flash.

 

 

# ==============================extra===

# Nordens största F l a s h community

# www.communen.com | poppa@communen.com

 

Link to comment
Share on other sites

Pontus östlund

Nu är jag ingen ASP-kung men detta skulle väl funka:

 

Namn = Server.urlEncode(Variabel);

 

 

# ==============================extra===

# Nordens största F l a s h community

# www.communen.com | poppa@communen.com

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...