Just nu i M3-nätverket
Jump to content

Formelproblem i Excel


Jocke001

Recommended Posts

Vore mycket taksam för hjälp med en formel i Excel. Det här är mitt problem...

 

Tre kolumner innehåller ett antal rader med text-strängar, 'a', 'b' eller 'c'. Celler i andra och tredje kolumnen kan ibland vara tomma.

 

För alla rader i tabellen ska följande beräknas:

"Om a i kolumn 1, summera antalet b och c i kolumn 2 och 3 för den raden" subtrahera "antalet a i kolumn 2 eller 3"

 

Exempel:

a b c

a c

b c a

c b

a

 

ska ge 2+1-1=2

Link to comment
Share on other sites

Jag utgår från att din tabell börjar i cell A1. Av din text uppfattar jag att beräkning för varje enskild rad skall göras enbart om kolumn 1 har värdet "a". Men av din sifferuppställning verkar det som att alla "a" i kolumn 2 och 3 skall subtraheras oavsett värdet i kolumn 1. Har därför gjort två formler med olika beräkningsgrund:

 

Drar ifrån antalet "a" i kolumn 2 och 3 endast när kolumn 1 har värdet "a"

=OM(A1="a";ANTAL.OM(B1:C1;"b");0)+OM(A1="a";ANTAL.OM(B1:C1;"c");0)-OM(A1="a";ANTAL.OM(B1:C1;"a");0)

 

Här tas alla "a" bort oavsett värdet i kolumn 1

=OM(A9="a";ANTAL.OM(B9:C9;"b");0)+OM(A9="a";ANTAL.OM(B9:C9;"c");0)-ANTAL.OM(B9:C9;"a")

 

Nu blir det din uppgift att "banta" eller slimma dessa formler. *ler*

 

Ps

Min tanke är att formeln skall kopieras för varje enskild rad i tabellen och sedan summeras för att för att få fram det totala värdet

 

[inlägget ändrat 2002-11-19 12:58:36 av CarlWan]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...