Just nu i M3-nätverket
Jump to content

mySQL på localhost - myODBC?


Kristianstad

Recommended Posts

Hej!

På mitt webbhotell använder jag mySQL som databas och som klient för att administrera databasen använder jag mySQL-Front.

Då jag kör ett ASP-script mot servern går det finfint. Men, då jag försöker köra samma script på min PWS här hemma, får jag felmeddelandet:

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

 

[Microsoft][ODBC Driver Manager] Datakällan hittades inte och ingen standarddrivrutin är angiven

Det hade ju varit praktiskt att förhandsvisa ASP-sidan innan man laddar upp scriptet med FTP:n.

Jag mailade därför supporten på webhotellet som berättade att jag måste ha myODBC för att kunna utföra det på localhost. (http://www.mysql.com/downloads/api-myodbc-2.50.html)

Jag laddade ner filen, men då jag installerar det ser det ut så här:

http://w1.441.telia.com/~u44107495/mysql.jpg

 

Tänkte att man kanske skall klicka på MQIS (SQL Server) - det som jag tyckte verkade närmast mySQL, men den funkade inte.

 

Jag har inte själva mySQL-servern på min dator, utan den finns alltså på webhotellet!

 

Tacksam för hjälp och naturligtvis poäng till den som klarar det! :thumbsup:

/ Kristoffer (Windows ME)

Windows kunde inte hitta något tangentbord. Tryck F1 för att försöka igen eller F2 för att avbryta.

 

[inlägget ändrat 2002-11-10 10:07:00 av Kristianstad]

[inlägget ändrat 2002-11-10 10:09:22 av Kristianstad]

Link to comment
Share on other sites

hmm jag har haft något likande problem innan men jag fick det funka genom att köra installations programmet i felsäkert läge. (men det var några år sen)

 

om du har lyckats med installationen så ska det stå något i kontroll panelen om mysql i ODBC har jag för mig

 

 

jag kan see mitt hus här i från

 

Link to comment
Share on other sites

Hej!

connect.open "Driver={mySQL};Server=[servern];Database=[databasen];UID=[uid];PWD=[lösenordet];option=16387"

Så ser koden ut för databasöppnandet. Hur skall jag konfigurera drivrutinen?

Måste jag ha mySQL Server installerad på min dator också?

/ Kristoffer

Windows kunde inte hitta något tangentbord. Tryck F1 för att försöka igen eller F2 för att avbryta.

 

Link to comment
Share on other sites

Ja, om webhotellet tänker på säkerhet så måste du ha mySQL installerat på localhost oxå.

 

Som default tillåter inte mySQL nätverkskopplingar alls, utan bara från localhost. Om nu webhotellet skulle vilja öppna upp åt dig måste du ha en fast IP adress som de mappar upp i user tabellen (alternativt host?).

 

Jag rekommenderar att du installerar mySQL på din dator oxå, och ser till att installera mySQL drivisarna rätt, då är det bara för dig att testa så mycket du vill innan du skeppar iväg det till webhotellet. På detta sätt slipper du ju oxå att kanske av misstag göra datat i den skarpa databasen korrupt då du testar.

 

[redigerat]Sorry, jag tänkte inte på att du använde mySQL front, eftersom du kommer åt databasen med mySQL front från din dator så ska du ju rimligtvis komma åt den från din lokala web oxå... Du har nog gjort nåt fel vid installation av drivisarna som jag inte kan hjälpa till mig eftersom jag kör under Linux... Lycka till![/redigerat]

 

--

Some say I am crazy..but the Voices in my head disagree...

 

[inlägget ändrat 2002-11-10 12:55:12 av Bj0rN]

Link to comment
Share on other sites

Du borde ju ha ett administrationskonto för databasen så att du kommer åt den utifrån? Alltså om du från dina ASP-sidor använder IP: 192.168.0.56 så kanske du använder ett annat IP för admin med ex.vis MySQLfront. Testa då att använda det IP't i din connectionstring. Men du måste ju samtidigt ha MyODBC installerat och det kanske kräver MySQL för att kunna installeras (själv har jag MySQL så jag har inte kunnat testa att installera MyODBC utan).

 

/Niklas

 

Link to comment
Share on other sites

Hej! Jag avinstallerade allt vad som hette något med SQL i min dator. Sedan startade jag datorn i felsäkert läge. Därefter installerade jag SQL Server och därefter myODBC.

Nu fungerar det lysande!

 

Tack för hjälpen!

/ Kristoffer

Windows kunde inte hitta något tangentbord. Tryck F1 för att försöka igen eller F2 för att avbryta.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...