Just nu i M3-nätverket
Jump to content

Apache - virtuella mappar (genvägar till mappar ut


TicoRoman

Recommended Posts

Hej alla glada!

 

Jag leker lite med Apache på Windows XP, och har stött på ett litet problem.

 

Jag vill alltså göra enheter, som ligger utanför roten, tillgängliga. Dvs jag har roten på C:\hejsan\svejsan och vill alltså att när man surfar in på ip-adress/mapp-från-D så ska där finnas innehållet från en mapp på enhet D.

 

Har försökt lite med virtual hosts, och inte fått det att fungera (den verkade ha hamnat i en oändlig loop), och det verkar också vara en krånglig lösning. Har för mig att man kunde skapa "virtuella länkar" på någt sätt, om jag nu inte drömt om det hela.. :)

 

 

 

PS. Sedan tycker jag att det inte finns någon passande forum för webbserverfrågor. DS.

 

Almir - ...

____________________________________________________________

-Läser Programmet för Informatik med Systemvetenskap på MDH, Västerås.-

 

 

 

[inlägget ändrat 2002-10-04 12:30:46 av TicoRoman (Almir)]

Link to comment
Share on other sites

Hmm det ser lovande ut, men av någon konstig anledning får jag det inte att fungera.

 

Inte ens någon enkelt som länkning till en mapp i roten (samma enhet) verkar fungera:

Alias /pjesme/ "/public/"

 

Mappen "public" finns i roten, och "pjesme" ska länka till public.

 

Jag får ett 404-fel. Och japp jag skriver "/" i slutet av "pjesme", dvs /pjesme/ i sökvägen i browsern. Servern omstartas förstås efter varje ändring i conf-filen.

 

Är det någon speciellt ställe Alias-kommandot ska ligga? Jag la den i "httpd.conf" strax efter raden:

DocumentRoot "c:/bla/bla"

 

Tillägg:

I logg-filen ser anropet ut så här:

213.66.*.* - - [04/Oct/2002:13:53:19 +0200] "GET /pjesme/ HTTP/1.1" 302 316

 

Tillägg 2:

Utdrag ur error-loggen:

[Fri Oct 04 13:47:27 2002] [error] [client 213.66.*.*] File does not exist: c:/phpdev/www/pjesme
[Fri Oct 04 13:49:28 2002] [error] [client 213.66.*.*] File does not exist: c:/phpdev/www/pjesme
[Fri Oct 04 13:51:24 2002] [error] [client 213.66.*.*] File does not exist: /public
[Fri Oct 04 13:51:29 2002] [error] [client 213.66.*.*] File does not exist: /public
[Fri Oct 04 13:52:27 2002] [error] [client 213.66.*.*] File does not exist: /public/
[Fri Oct 04 13:53:19 2002] [error] [client 213.66.*.*] File does not exist: /public/

 

 

Almir - ...

____________________________________________________________

-Läser Programmet för Informatik med Systemvetenskap på MDH, Västerås.-

 

 

[inlägget ändrat 2002-10-04 14:05:35 av TicoRoman (Almir)]

Link to comment
Share on other sites

Eftersom det är en Windows maskin så måste du säkert skriva hela sökvägen med enhetsbokstav och allt. Jag vet inte riktigt hur det där funkar eftersom jag själv inte kör på Windows, men pröva nånting liknande detta:

 

Alias /pjesme/ "d:\public\"

 

Frågan är om Apache gillar backslash, så testa annars med nån av dessa:

 

Alias /pjesme/ "d:/public/"

 

eller:

 

Alias /pjesme/ "d:\\public\\"

 

Se oxå till att du har nån fil som finns i DirectoryIndex, dvs en index.html eller liknande.

 

Link to comment
Share on other sites

Är det någon speciellt ställe Alias-kommandot ska ligga? Jag la den i "httpd.conf" strax efter raden:

 

DocumentRoot "c:/bla/bla"

 

Så länge webben som du vill göra ett alias på inte är en virtualhost så kan du i princip lägga det vart som helst. Efter DocumentRoot passar nog bra.

 

Egentligen är det ju samma sak om det är en virtualhost, lägg den bara innuti VirtualHost taggarna.

 

Har du fått det att funka? Tack för poängen förresten!

 

Link to comment
Share on other sites

Hmm man ska tydligen lägga alla Alias efter "<IfModule mod_alias.c>" och före "</IfModule>" verkar det som.

 

Där fungerar det med vanliga slashes /.

 Alias /pjesme/ "i:/Files/Mp3/"

 

Så nu har jag NÄSTAN fixat det. problemet nu är att jag får ett 403-fel.

 

Logg:

127.0.0.1 - - [04/Oct/2002:14:19:43 +0200] "GET /pjesme/ HTTP/1.1" 403 293

 

Error:

[Fri Oct 04 14:19:43 2002] [error] [client 127.0.0.1] Directory index forbidden by rule: i:/files/mp3/

 

What F***** rule?

 

Har försökt att lägga till följande, efter Alias:

    <Directory "i:/files/mp3">
Order allow,deny
Allow from all
</Directory>

Tyvärr med samma resultat.

 

Se oxå till att du har nån fil som finns i DirectoryIndex, dvs en index.html eller liknande.

Då är problemet att jag liksom INTE vill ha någon index-fil där utan endast lista innehållet i mappen.

 

Damn, jag blir less på det här. :(

 

Är ingen hejare på Apache som det märks. Håller på och lär mig alla dess små hemligheter. :)

 

Tilläg:

Lägger jag dit en index.php, så visas den filen. Så jag har ju fått aliaset att fungera. Men nu gäller det bara att ändra regeln så att innehållet kan listas, då jag inte vill ha index-fil. Inte ens innehållet i undermapparna kan listas, utan resulterar i 403-fel där också.

 

Almir - ...

____________________________________________________________

-Läser Programmet för Informatik med Systemvetenskap på MDH, Västerås.-

 

[inlägget ändrat 2002-10-04 14:37:03 av TicoRoman (Almir)]

[inlägget ändrat 2002-10-04 14:38:13 av TicoRoman (Almir)]

[inlägget ändrat 2002-10-04 14:44:54 av TicoRoman (Almir)]

Link to comment
Share on other sites

Har du fått det att funka?

Läs ovanstående inlägg.

 

Tack för poängen förresten!
Bra svar förtjänar poäng. Du är värd fler om jag löser det helt. Då har du lärt mig något nytt idag. :)

 

 

Almir - ...

____________________________________________________________

-Läser Programmet för Informatik med Systemvetenskap på MDH, Västerås.-

 

Link to comment
Share on other sites

Elementärt min käre Almir.

 

[Fri Oct 04 14:19:43 2002] [error] [client 127.0.0.1] Directory index forbidden by rule: i:/files/mp3/

 

betyder att du inte har någon DirectoryIndex fil, dvs index.html till exempel, och du tillåter inte Apache att lista innehållet i mappen. Detta är default inställningen i Apache och är bra ur säkerhetssynpunkt.

 

För att tillåta listning av innehåll i mappen skriver du detta inom Directory (eller Location) taggarna:

 

Options +Indexes

 

Fixat.

 

Link to comment
Share on other sites

Elementärt min käre Almir.
:)
Fixat.
Japp, nu är det fixat och fungerar fint.

 

Tack för din tid och tålamod. Snart är jag proffs på det här. :)

 

*poäng*

 

Almir - ...

____________________________________________________________

-Läser Programmet för Informatik med Systemvetenskap på MDH, Västerås.-

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...