Just nu i M3-nätverket
Jump to content

Loop


Patric Johansson

Recommended Posts

Patric Johansson

Jag försöker skapa en loop, har testat på 2 sätt, men sidan bara tuggar o tuggar men inget kommer fram

 

vad är fel?

 

TEST1:

<select name=”select” class=”form-input”>

<%

Set rstemp = conntemp.Execute(”SELECT * FROM Login WHERE Not Status=’2’ OR Status=’” & session(”status”) & ”’”)

 

Do Until rstemp.EOF

%>

<option value=”<%=rstemp(”ID”)%>”><%=rstemp(”Anvandare”

)%></option>

 

<%

Loop

%>

</select>

 

TEST2:

<select name=”select” class=”form-input”>

<%

Set rstemp = conntemp.Execute(”SELECT * FROM Login WHERE Not Status=’2’ OR Status=’” & session(”status”) & ”’”)

 

Do While Not rstemp.EOF

%>

<option value=”<%=rstemp(”ID”)%>”><%=rstemp(”Anvandare”

)%></option>

 

<%

Loop

%>

</select>

 

Tack på förhand!

Link to comment
Share on other sites

Du måste flytta fram recordpekaren också... annats så står du på samma record hela tiden och kollar om den posten finns och skriver ut den, kollar om posten finns och skriver ur den osv osv..

 

<%
Do Until rstemp.EOF

response.write "<option value='" & rstemp("ID") & "'>" & rstemp("Anvandare") & "'></option>"

rstemp.movenext
Loop
%>
</select>

- M

-----------------------------------------------------

ju mer jag lär mig ju mer inser jag så lite jag kan

 

[inlägget ändrat 2002-09-12 21:16:38 av Magnus Gladh]

Link to comment
Share on other sites

Du måste flytta framåt i recordsetet också!

 

Lägg in:

rstemp.MoveNext

 

raden före Loop så kommer det att funka

 

(Redigerat)

Argh...Gladh var sekunderna snabbare än mig :-)

 

 

==Coleburn==

 

--------------------

"It takes a lot of knowledge to

really mess something up!"

 

[inlägget ändrat 2002-09-12 21:17:36 av Coleburn]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...