Just nu i M3-nätverket
Jump to content

Uploadscript


ConnyBrusewitz

Recommended Posts

ConnyBrusewitz

Jag har ett script där jag kan skicka upp filer på servern. Det fungerar på min win98 med Personal webserver men inte på min bärbara som har w2k, IIS5.

 

Den bara står och tänker tills det blir TimeOut.

 

 

Tacksam för svar

Link to comment
Share on other sites

ConnyBrusewitz

Nej det är ett ASP-script och det ska inte behövas någon komponent.

 

Jag tror att det har något med skrivrättigheter, men jag har tilldelat rättigheterna read och write (i IIS´en).

 

Måste man änra någon annanstans också?

 

 

 

 

Link to comment
Share on other sites

ConnyBrusewitz

Ehh. vad menar du? Hör inte riktigt hit va.

 

Strunta i uploadskriptet. Problemet är inte det. Det blir samma sak om jag text skriver:

 

<%

Dim Obj

Set Obj = CreateObject("Scripting.FileSystemObject")

 

Obj.CreateTextFile("c:\inetpub\wwwroot\asp\testfil.txt")

%>

 

 

 

 

Link to comment
Share on other sites

Purre Håkansson

Har du NTFS som filsystem? Isåfall måste Internetanvändaren ha skrivrättigheter i mappen som du uploadar till. Vanligtvis har Internetkontot följandenamn: IUSR_"Datornamn". Alltså windowsrättigheter! inte vilka rättigheter IIS har.

 

[inlägget ändrat 2002-04-16 15:20:53 av Patrik Håkansson]

Link to comment
Share on other sites

ConnyBrusewitz

Ja jag har Norton Antivirus. Hur kopplar jag bort script blocking?

 

Jag har nu givit windowsrättigheter Full Control till alla. Fungerar fortfarande inte.

 

Link to comment
Share on other sites

ConnyBrusewitz

OK. Jag hittade scriptblocking, stängde ner. Men det fungerar fortfarande inte! den står bara och tuggar

 

Link to comment
Share on other sites

Öppna Norton klicka på options och script blocking, klicka bort "enable script blocking".

 

Eller gå in i service panelen och stäng ned script blocking servicen.

 

 

Link to comment
Share on other sites

ConnyBrusewitz

Åhh!! Efter omstarten så fick jag iallafall ett felmeddelande istället för att den bara tuggar.

 

Felmeddelandet löd: Permission Denied

 

 

Jag har valt högerklickat på mappen i utforskaren och valt Properties och under fliken Security satt alla på Full Control

 

 

Och i IIS har jag högerklickat på Den aktuella websiten --> Properties och under fliken Virtual Directory kryssat i Read och Write.

 

 

Finns det någonannanstans att ge rättigheter??

 

 

 

Link to comment
Share on other sites

Du kan pröva med att lägga din internetanvändare i administratorgruppen. inte så lyckat i längden men har du gjort det så kan vi utesluta ntfs problem.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...