Just nu i M3-nätverket
Jump to content

Editera fil..?


Erik Thörnblom

Recommended Posts

Erik Thörnblom

Hej,

 

Har laddat hem K Develop... och öppnat rpm filen som den e... men hur öppnar jag programmet...? Jag har hört att man ska editera eller något konstigt, och det vet jag hur man gör, men hur får jag igång det??? Måste jag skriva något eller..?

 

Tacksam för svar,

 

//Erik

Link to comment
Share on other sites

Ja om du installerat programmet borde det väl bara vara att starta det? Så var det iaf om man tagit hem och kompilerat källkoden...

Link to comment
Share on other sites

Erik Thörnblom

Hej,

 

Öch min stora fråga är då hur man kompilerar en källkod i Linux, har försökt hur många gånger som helst...

 

Dessutom är K Develops hemsida gämt nere, så det är lite svprt att hämta hem all källkod..,

 

Yack på förhand,

 

//Erik

Link to comment
Share on other sites

Martin Storsjö

Att kompilera ett program under linux är egentligen _mycket_ enkelt. Följ bara följande enkla steg:

1. Hämta hem en fil som innehåller hällkoden. Den brukar vanligtvis heta ungefär program-1.2.3.tar.gz eller något sådant.

2. Inte nödvändigt, men rekommenderat: Flytta filen du hämtat till någon central plats för alla dina källkodsfiler, t.ex. /usr/src eller /usr/local/src.

4. Packa upp filen du hämtat: tar -zxvf program-1.2.3.tar.gz

5. Byt till själva programkatalogen: cd program-1.2.3

6. Läs alla instruktionsfiler: less README och less INSTALL

7. Om du inte orkat läsa instruktionerna, eller det inte finns några sådana, skriv: ./configure (det här behövs inte alltid, om du får något felmeddelande om att det inte finns någon sådan fil, så fortsätt då bara)

make

make install

8. Starta programmet!

 

// Martin

Link to comment
Share on other sites

Problemet med KDevelop är att man också måste ha qt-1.44 rätt installerat. Dvs det som står i vissa config-filer från början i t ex slackware räcker inte utan man är tvungen att lägga till en del saker. Detta var det som orsakade problem för mig. Är det detta som är problemet?

Link to comment
Share on other sites

Peter Johnsson

Martin har ju uttryckt saken alldeles förträffligt. Och helt klart måste man ju ha Qt installerat. Om jag har fattat saken rätt så är det nåt sorts klassbibliotek (Ramverk) för grafiska applikationer under X. Dom måste ju alltid finnas tillhands. Jag har också installerat KDevelop men får inte glimpse (bl.a) att fungera. Någon som har nåt tips ?, Jag har installerat glimpse-paketet men kanske gjort nåt fel ?

 

/PJ

Link to comment
Share on other sites

Roger Svensson

Precis som du antog Peter så är QT ett 'ramverk', eller widget set som det egentligen heter. Alltså en samling klasser som tillhandahåller utseende för X (om man inte vill dras med X's klassiska MOTIF gränssnitt). Presonligen gillar jag GTK bättre eftersom den hanterar themes så man kan ändra utseende o.dyl på sina widgets utan att behöva kompilera om en hel massa.

 

Men om man prompt vill köra KDE devel, som bygger på QT så finns det inte mycket annat att göra än att tanka det från ftp://ftp.troll.no/qt/source/

 

Det finns dock ett trevligt alternativ till KDE, GNOME som utvecklats av folk som från början var involverade i utvecklingen av KDE. GNOME stöder sig på GTK och är tillsammans med Enlightenment anpassningsbart i oändlighet vad gäller utseende och funktionalitet.

 

Gnome finns att hämta på ftp://ftp.gnome.org och Enlightenment finns att ta hem från ftp://ftp.enlightenment.org

Link to comment
Share on other sites

Roger Svensson

Jodå, det stämmer bra. Det är en av anledningarna till att många utvecklare väljer att gå mot QT istället för GTK. Graham Roff som utvecklar licq hade det som främsta argument när han såg sig om efter ett widget set.

 

Nu måste man ändå komma ihåg att bara för att något är utvecklat i C++ och är objektorienterat så betyder det inte att det är allenarådande. QT har vissa fördelar och GTK har andra... men det finns inget som säger att man inte kan få det bästa av två världar och ha båda installerade på sitt system... ;)

 

Mozilla utvecklas ju med både QT och GTK stöd nu... sen är det bara att hoppas på att fler stora programpaket kommer med stöd för båda widget-set:en... =)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...