Just nu i M3-nätverket
Jump to content

IF formel med Letarad


Opi888
 Share

Recommended Posts

Opi888
Posted (edited)

Hej!

 

Jag försöker få till en formel för att leta upp ett datum som är större än ett annat men jag får inte till formeln alls.

 

I ena fliken har jag ett antal rader med ett specifikt ID nummer samt ett datum när det hände en avvikelse.

i nästa flik har jag en "drös" med ID nummer och datum efter. Alltså samtliga händelser för specifikt ID nummer.

 

Det jag vill göra är att hämta datum för ett specifikt ID nummer som är större än, alltså det datum som är närmst efter det jag har i flik 1.

Sen fyller det på i listan på flik 2 så kommer YYYY och sen ett antal datum för CCCC osv.

 

Är det någon som har en bra lösning på detta?

 

image.png.021b87e4f12ff0275ae39159cebe1054.png

Edited by Opi888
Link to comment
Share on other sites

Finns flera sätt. En är att använda MINIFS() (borde heta MIN.omf på svenska, men nyare formler översätts inte). Det är excels funktion för att hitta det minsta värdet om vissa villkor är uppfyllda:

=MINIFS(Blad2!B:B;Blad2!A:A;A2;Blad2!B:B;">"&B2)

Där det första argumentet Blad2!B:B; är kolumnen du vill hitta det lägsta värdet i

Argument 2-3 Blad2!A:A;A2; betyder att ID numret måste vara lika med den här radens ID

Och Argument 4-5 Blad2!B:B;">"&Blad2!B2 betyder att Datumet måste vara större än radens datum (obs att citattecknen  och &-tecknet ">"& måste vara där)

 

Obs att du får en 0-a, eller 1900-01-00 om du inte får någon träff

en annan variant är att använda filter. Då kan du dölja de rader som inte ger träff  (OBS att det INTE är citattecken runt > i den här formeln)

=OMFEL(MIN(FILTER(Blad2!B:B;(Blad2!A:A=A2)*(Blad2!B:B>B2)));"")

 

 

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...