Just nu i M3-nätverket
Jump to content

Win10-laptop ansluter till Wifi "utan internet"


ChromaWoods
 Share

Recommended Posts

ChromaWoods

Hej! Vi har i vårt hushåll ett tjugotal enheter som alla kopplar upp sig på Wifi-nätverket utan problem (nåja, skrivarn räknar jag inte för skrivare funkar ALDRIG utan problem). Men, min hyfsat moderna Dell XPS (Win 10 pro 64bit) är långsam på att koppla upp sig mot Wifi när man startar datorn. Den hittar nätverket och ansluter till det, men säger "inget internet" med tillhörande offline-symbol. Om man inte gör något så brukar den koppla upp sig efter ett par minuter, men jag brukar istället helt enkelt återansluta manuellt och då funkar det direkt.

 

Nån som har någon idé varför den initialt ansluter utan internet? Har som sagt alla möjliga enheter hemma och de uppvisar inte detta. Jobbdatorn, som också är en hyfsat modern laptop, kopplar t.ex upp sig ögonblickligen.

Link to comment
Share on other sites

Pelle Penna

Ingen idé men råkar ibland ut för detta också sedan en tid. Misstänker någon uppdatering som spökat till systemet. 

Problemet hos mig har uppstått efter jul 

Link to comment
Share on other sites

ChristerE
4 timmar sedan, skrev ChromaWoods:

Men, min hyfsat moderna Dell XPS (Win 10 pro 64bit) är långsam på att koppla upp sig mot Wifi när man startar datorn.

 

Den hittar nätverket och ansluter till det, men säger "inget internet" med tillhörande offline-symbol.

Osäker på om det är uppkopplingen till det lokala nätverket du menar (WiFi) eller långsam tills datorn visar att den är ansluten till internet.


Även om datorn ansluter snabbt till det lokala nätverket och därmed också kan komma ut på internet (om routern har anslutning) så kan det var något i funktionen som kollar vilken symbol som ska visas som inte fungerar korrekt.


"Antingen visar den en bildskärm för trådad anslutning eller en wifi-symbol för trådlöst. Men den kan också visa bara en glob för att markera att du är nätverksansluten, men internetanslutning saknas."

Har du internet eller inte? Så här enkelt kollar du själv - PC för Alla (idg.se)

 

Något du kan testa är att helt ta bort anslutningen mot det trådlösa nätverket, med "Glöm" och sedan ansluta igen, som om det är första gången datorn ansluts till det.


Se punkt 2, "Glöm ett nätverk"

16 tips för bättre hemnätverk med Windows 10 - PC för Alla (idg.se)

 

Link to comment
Share on other sites

Jag skulle nog, i det här fallet, hitta en metod för att kringgå problemet. Någon batch-fil i autostart som gör 

10 timmar sedan, skrev ChromaWoods:

helt enkelt återansluta manuellt

***

Tillägg:

Sökte i gamla trådar och hittade ett skript som jag en gång använde på en bärbar dator.

Där var det nätverkskortet som inte aktiverades automatiskt vid start.

Set WshShell = WScript.CreateObject("WScript.Shell")
Set oExec = WshShell.Exec("C:\Program Files\Launch Manager\WisWBSet.exe")
do while WshShell.AppActivate("Wireless Status Option")=False
WScript.Sleep 100
loop
WScript.Sleep 100
WshShell.sendkeys("{TAB}{TAB}{LEFT}~")

Kanske går det att modifiera så att nätverkskortet först inaktiveras och därefter aktiveras och då med förhoppningen att det sedan lirar.

Jag fick ha en liknande lösning på en HP med Linux.

(startade om network-manager)

 

(skriptet, hittad på nätet, var anpassat för en Fujitsu Amilo och det fungerade direkt för mig men måste givetvis anpassas för att, ev., kunna fungera i annan dator)

Edited by Mikael63
skript
Link to comment
Share on other sites

ChromaWoods
18 minuter sedan, skrev Pelle Penna:

Problemet hos mig har uppstått efter jul 

Ja, min känsla är också att det har uppstått för en tid sedan; det har inte alltid varit såhär. Kan mycket väl vara som du säger.

Link to comment
Share on other sites

ChromaWoods
Just nu, skrev ChristerE:

Osäker på om det är uppkopplingen till det lokala nätverket du menar (WiFi) eller långsam tills datorn visar att den är ansluten till internet.

Datorn i sig är det inget fel på, den är snabb hela tiden. Det är specifikt tillgången till internet som inte ges ögonblickligen.

 

Citat

funktionen som kollar vilken symbol som ska visas som inte fungerar korrekt.

Det tror jag inte. Om man öppnar en webbläsare så bekräftar den att det inte finns någon tillgång till internet.

 

Citat

Något du kan testa är att helt ta bort anslutningen mot det trådlösa nätverket, med "Glöm" och sedan ansluta igen, som om det är första gången datorn ansluts till det.

Hmm tror jag testat detta faktiskt, men ska prova igen. Återkommer!

Link to comment
Share on other sites

ChromaWoods
Just nu, skrev Mikael63:

Jag skulle nog, i det här fallet, hitta en metod för att kringgå problemet. Någon batch-fil i autostart

Hehe, känns som overkill, men kanske värt ett försök om jag surnar till riktigt ordentligt. :) 

Link to comment
Share on other sites

 Share



×
×
  • Create New...